Jump to content
Sign in to follow this  
Fielder

10 second pauses (it's USB turning off/on)

Recommended Posts

After every single Windows update, in Device Manager 1) USB controllers and 2) Human Interface Devices...Properties | Power Management all change back to "allow the computer to turn off this device to save power". About 20 each in 1) and 2). What fun to manually uncheck all those boxes marked "allow the computer..."

If I don't, then right after every windows update I get 3 to 10 second pauses in flight and the tell tale sound (BeeTelBeep) of USB doing its off then right back on thing. Then I go uncheck those boxes in device manager and all is well again. Until the next Windows update in a few weeks. (Sigh).


Ryzen5 5600X, RTX3070, 600 Watt Gold, Dell S3222DGM 32" curved 1440p VA, 16 GB RAM, 2 TB M.2. NVMe...Warthog HOTAS, CH quad, 3 Logitech panels (multi, switch, radio), StreamDeck, Desktop Aviator Trim Panel.

Share this post


Link to post
Share on other sites

I can't really comment on your problem, I've never experienced your described problem, but I still have a question, if I may?  If you uncheck all those boxes on USB devices, do they still power down when computer goes to sleep?


Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz (8 cores) Hyper on, Evga RTX 3060 12 Gig, 32 GB ram, Windows 11, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post
Share on other sites
4 hours ago, Fielder said:

After every single Windows update, in Device Manager 1) USB controllers and 2) Human Interface Devices...Properties | Power Management all change back to "allow the computer to turn off this device to save power". About 20 each in 1) and 2). What fun to manually uncheck all those boxes marked "allow the computer..."

If I don't, then right after every windows update I get 3 to 10 second pauses in flight and the tell tale sound (BeeTelBeep) of USB doing its off then right back on thing. Then I go uncheck those boxes in device manager and all is well again. Until the next Windows update in a few weeks. (Sigh).

SOP before MSFS start is to actually disconnect any USB's aside from yoke/pedals


SAR Pilot. Flight Sim'ing since the beginning.

Share this post


Link to post
Share on other sites

Have you tried to disable USB Selective suspension? 

Open the start menu, type 'power plan', click edit power plan, click 'Change advanced power settings', scroll down to 'USB settings->USB selective suspend settings'. Select disable, click apply, click OK

ShNO6iX.png

Edited by wims80

vatsim s3

1133704.png

Share this post


Link to post
Share on other sites

Thanks wims80 but selective suspend was already set to disabled, and does stay that way with Windows updates.

Unplugging USB devices doesn't help on my system. Keyboard, mouse, wifi all are USB. Windows can disable the HIDs, not just the USB ports being used, if you don't uncheck all the boxes.

I think Bob Church said in Windows XP this did not happen. CH Products controllers ruled back then.


Ryzen5 5600X, RTX3070, 600 Watt Gold, Dell S3222DGM 32" curved 1440p VA, 16 GB RAM, 2 TB M.2. NVMe...Warthog HOTAS, CH quad, 3 Logitech panels (multi, switch, radio), StreamDeck, Desktop Aviator Trim Panel.

Share this post


Link to post
Share on other sites

Sorry to resserect this old post, but I have this exact problem and have to manually disable sleep mode on 20 odd devices after each update too... 

Share this post


Link to post
Share on other sites

PS yoou can run this script in powershell (just copy and paste it) and it will auto disable sleep mode on all your USB devices for you.

$USBHubs = Get-WmiObject -Class Win32_USBHub
$PowerMgmt = Get-WmiObject -Class MSPower_DeviceEnable -Namespace root\wmi

ForEach ($Hub in $USBHubs) {
    Write-Host
    Write-Host -Object "Checking USB Hub '$($Hub.Name)'..."
    $VarPowerSettings = $PowerMgmt | Where {$_.InstanceName -like "*$($Hub.DeviceID)*"}
    If (($VarPowerSettings | Measure).Count -eq 1) {
        If (($VarPowerSettings | Select -ExpandProperty Enable) -eq $False) {Write-Host -Object "USB Hub '$($Hub.Name)' already has power saving disabled" -ForegroundColor Green}
        Else {
            Try {
                $VarPowerSettings.Enable = $False
                $Null = $VarPowerSettings.psbase.Put()
                Write-Host -Object "Disabled power saving features for USB Hub '$($Hub.Name)'" -ForegroundColor Green
            }
            Catch {Write-Warning -Message "One or more exceptions occurred when trying to set power saving settings for USB Hub '$($Hub.Name)'"}
        }
    }
    ElseIf (($VarPowerSettings | Measure).Count -gt 1) {Write-Warning -Message "More than one WMI object representing power settings was found for '$($Hub.Name)', no settings have been changed for this device"}
    Else {Write-Warning -Message "No power settings were found for '$($Hub.Name)', please check if the device supports power saving features"}
}

Share this post


Link to post
Share on other sites
6 minutes ago, Ianrivaldosmith said:

Sorry to resserect this old post, but I have this exact problem and have to manually disable sleep mode on 20 odd devices after each update too... 

You mean you didn't have this problem before and started having it now?


Alvega

Share this post


Link to post
Share on other sites
23 minutes ago, Alvega said:

You mean you didn't have this problem before and started having it now?

I had the pauses but could never figure out what was causing them, then I started hearing very faintly in the background the usb disconnect sound. So, I researched it, and in finding the solution I stumbled across this thread, and realised he was having  the same issue. So hopefully it helps others too.

Ps I’ve had the problem for ages I just have not been simming much the last 9 months or so, too busy doing other things. 

Share this post


Link to post
Share on other sites
24 minutes ago, Tomaz Drnovsek said:

Which USB devices usually cause this issue? I always had UBS suspend enabled and never noticed any issues of this kind.

Same here.


Alvega

Share this post


Link to post
Share on other sites
3 hours ago, Tomaz Drnovsek said:

Which USB devices usually cause this issue? I always had UBS suspend enabled and never noticed any issues of this kind.

Further research shows that it only happens on some motherboards. So, if you don't have the issue, then you are obviously not affected. 

Share this post


Link to post
Share on other sites

Is this Win 11, or Win 10?


Noel

System:  9900K@4.9Ghz@1.19v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVMe 2Tb x 2, RTX 3080 Ti FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, 30 frames vSync to 60Hz.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...