Jump to content
Sign in to follow this  
waltpop

MSFS 2020 Cessna Longitude

Recommended Posts

Did a flight and when I tried to set the coarse I clicked on the Nav Source button and it did nothing. Could not switch from GPS to NAV1. After a while it did change.  Also when I did an ILS approach, and switched over from GPS to NAV1  the plane didn't follow the approach. I was close to final, activated APP, went from GPS to NAV1, correct ILS freq was entered, Coarse was set and plane did not follow approach. Anyone else have this problem? Or any suggestions on why this is happening? Seems like I did everything right and everything was set. Thanks, Walt


Walt Popowski

Share this post


Link to post
Share on other sites

If I remember correctly, you don't need to switch to Nav1, it will catch anyways.


[ This Content Is Restricted To Avsim Premium Members ]

Share this post


Link to post
Share on other sites

Are you using Darkfly's Longitude mod with WT G-3000 mod? I have no problem with them.


| Intel I9 10900K | Corsair 32Gb 3200MHz | Asus Rog Strix OC 2080Ti | Samsung 970 EVO Plus 1TB |

Share this post


Link to post
Share on other sites
4 hours ago, andyjohnston.net said:

If I remember correctly, you don't need to switch to Nav1, it will catch anyways.

Yes, Everything is set for the ISL, APP, NAV1,ILS Freq checked, CRS checked. this bad boy should be going in for a perfect landing. Yet, when I switch over to the VOR1, the plane decides to go sightseeing. 


Walt Popowski

Share this post


Link to post
Share on other sites
4 hours ago, andyjohnston.net said:

If I remember correctly, you don't need to switch to Nav1, it will catch anyways.

Really? That's interresting, because I did notice the glide slope showing up on the PFD while in GPS mode. I'll have to play with this. Thanks


Walt Popowski

Share this post


Link to post
Share on other sites
4 hours ago, Ixoye said:

Are you using Darkfly's Longitude mod with WT G-3000 mod? I have no problem with them.

Yes I have the WT G-3000, and don'tthink I'm having a problem with that.


Walt Popowski

Share this post


Link to post
Share on other sites

Have you selected the correct nav source on the touch screen to your left? It's just below the pilot's side window.


Mike Beckwith

Share this post


Link to post
Share on other sites
1 hour ago, Highmike said:

Have you selected the correct nav source on the touch screen to your left? It's just below the pilot's side window.

Yes, I am doing everything correctly. Have done many many ILS approaches before  without any trouble. So can't figure out why I have this problem all of a sudden. 

Going to try another test flight now from KOXC to KBDL. Landing ILS Runway 33 108.55 Coarse 328. Lets see what happens. 


Walt Popowski

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...