Jump to content

Recommended Posts

Until recently, I hadn't had any real issues with MSFS, though the various updates didn't seem to add a lot.  But the last "update" has broken more than anything else, I've lost track of the number of things that are broken now.

Recent airports no longer show

CTDs

Spoiler key doesn't work

CTDs

Longitude throttle levers don't move

CTDs

So many more!

 


[ This Content Is Restricted To Avsim Premium Members ]

Share this post


Link to post
Share on other sites

SU5 utterly destroyed the sim for me. It is completely unusable. 


Richard Johansson

Share this post


Link to post
Share on other sites
Posted (edited)

I've put about 20 hours into the longitude post SU5, throttles move in the cockpit and work just fine for me #shrug

hRFNO3O.jpg

Edited by CaptainNick
  • Like 5

Nick Silver

http://www.youtube.com/user/socalf1fan

Ryzen 7 5800x, 32gb ddr4 3200mhz ram, RTX 2070 Super, Samsung Odyssey +, 4K Tv Monitor

Share this post


Link to post
Share on other sites

And you felt the need to start another thread about this because?

I've done several flights in the Citation Longitude post SU5 - no new issues. Shrug.

  • Like 3

Share this post


Link to post
Share on other sites
26 minutes ago, Ricardo41 said:

And you felt the need to start another thread about this because?

I've done several flights in the Citation Longitude post SU5 - no new issues. Shrug.

Because it’s a real and undeniable issue where lots of people got their sim destroyed by SU5 + the ”fixes”…? Because it is actually a good idea to keep telling Asobo that ”no, there is something seriously messed up here, fix it.”? 

 

  • Like 2

Richard Johansson

Share this post


Link to post
Share on other sites
6 hours ago, andyjohnston.net said:

Until recently, I hadn't had any real issues with MSFS, though the various updates didn't seem to add a lot.  But the last "update" has broken more than anything else, I've lost track of the number of things that are broken now.

Recent airports no longer show

CTDs

Spoiler key doesn't work

CTDs

Longitude throttle levers don't move

CTDs

So many more!

 

Did you empty your Community folder?


i5-9400, GTX 1660 Super, 24 GB RAM

Share this post


Link to post
Share on other sites

I'm exposed to a strange bug since SU5, all of a sudden the camera view changes to floor level without me doing anything, the second after the whole picture starts flashing violently as if the game had an epileptic seizure, it does not stop flashing if I go back to the main menu either , and it can't be turned off normally, the only way is to force it to close through the task manager.


| Intel I9 10900K | Corsair 32Gb 3200MHz | Asus Rog Strix OC 2080Ti | Samsung 970 EVO Plus 1TB |

Share this post


Link to post
Share on other sites

Still odd that some seem to be getting issues and some don't.  It's hard to fathom.  With the number of issues you are having Andy, reinstalling might cause you a lot less hassle in the long term.  Otherwise we just have to learn to live with them and hope that they get fixed in future updates.

  • Like 1

Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3070 founders edition - 32 Gig RAM - Windows 10 64 bit MSFS 2020 Premium Deluxe Edition Resolution 1920 x 1080

Share this post


Link to post
Share on other sites
Posted (edited)

My spoilers don't work with the / key, but I am betting it's just a lost control assignment. A few key assignments for views seem to have gone astray too. SU5 definitely broke a few things, but it's hardly "destroyed the sim", it's just annoying have to reinput those key maps and waiting for developers to update their addons.

I'm not saying everyone, but many people screaming about CTDs ultimately find out it was caused by something third party (and not necessarily stuff that lives in the community folder). Case in point below, all blamed on SU5 then it's realised it's a seasons addon causing a long load time:

I had one CTD on the initial update, attributed it to TheFrett's G36 mod, the WT G1000 and the G1000NXI not playing together nicely, removed some of those, problem solved.

Edited by ckyliu
  • Like 1

ckyliu, proud supporter of ViaIntercity.com. Find my spec and settings in "About me" on my profile.

support1.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ckyliu said:

the WT G1000 and the G1000NXI not playing together nicely

Yeah they’ve been saying since release of the NXI not to run those two together.

Edited by Tuskin38
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, ckyliu said:

My spoilers don't work with the / key, but I am betting it's just a lost control assignment. A few key assignments for views seem to have gone astray too. SU5 definitely broke a few things, but it's hardly "destroyed the sim", it's just annoying have to reinput those key maps and waiting for developers to update their addons.

I'm not saying everyone, but many people screaming about CTDs ultimately find out it was caused by something third party (and not necessarily stuff that lives in the community folder). Case in point below, all blamed on SU5 then it's realised it's a seasons addon causing a long load time:

I had one CTD on the initial update, attributed it to TheFrett's G36 mod, the WT G1000 and the G1000NXI not playing together nicely, removed some of those, problem solved.

Go to the official FS forum and read the hundreds of posts on Post SU5 CTDs. It will take you a long time to read them all.

 

 https://forums.flightsimulator.com/c/bugs-and-issues/ctds/260


spacer.pngBob Cardone         MSFS 2020     PMDG DC6,  JF Arrow  , Carenado Seminole , Mooney,Simple Traffic  

TrackIR   Avliasoft EFB2    ATC  by PF3    FlyVirtual.net  CLX PC

 

 

Share this post


Link to post
Share on other sites

Most of what I use is the default stuff that came with the program, and I still get CTDs, often even when I'm just on the screen to select my point of departure and arrival.


[ This Content Is Restricted To Avsim Premium Members ]

Share this post


Link to post
Share on other sites
9 hours ago, KevyKevTPA said:

Have you gone through the troubleshooting steps shown on this page that was published by Microsoft?

Kev

Or reinstalled MSFS, or Windows, or replaced PC?  That should almost cover it. 


spacer.pngBob Cardone         MSFS 2020     PMDG DC6,  JF Arrow  , Carenado Seminole , Mooney,Simple Traffic  

TrackIR   Avliasoft EFB2    ATC  by PF3    FlyVirtual.net  CLX PC

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, andyjohnston.net said:

Most of what I use is the default stuff

...but have you tried completely emptying the Community folder, of everything?

Until you do that, you won't know for sure whether something in there (that you may think is harmless, like some scenery) is causing the CTDs.

Although the vanilla sim is completely stable for me now, I am still finding mods on a daily basis that cause problems - yesterday it was the G36 Improvement Mod.  Case in point; this mod has apparantly been updated for "SU5 compatibility", yet it still 100% causes CTDs for me. Once I remove it - no CTDs at all.

As others said, make sure you never have more than one of these in the community folder, at any time:-

  • G1000 NXi (Marketplace, not community folder)
  • Working Title G1000
  • Working Title G3000
  • Working Title G3X
  • PMS GTN750
  • PMS GNS 530 mod

I am sure that avionics mods are a big cause of CTDs at the moment.  If you ensure that you only have one of the following installed at any time (for whichever plane you're about to fly), I'm sure it ensures much higher stability in the sim.  Or at least that's what I have found.

"Improvement mods" to planes also cause many problems at the moment, beause they change variables that Asobo have now made hard-coded changes to.   Remove them all and fly completely default planes for at least a few days, to see if you still get CTDs.

Liveries - many cause huge problems because of hard-coded changes to LODs.  Seen all these posts about liveries that have "turned magenta or purple, on the wings" etc? .... that's what that is.

Make sure your settings are sensible, for your hardware.  No-one talks about it much, but I believe that MSFS can simply crash if your system is being pushed too hard.   When I push my settings too high, odd things start to happen; my TrackIR stops working, my mouse disappears, ATC starts acting more goofy than usual, etc.  I get graphical artifacts. All signs that my PC is not keeping up with the demands being put on it.  Since I moved my settings down to High with some heavy hitters to Medium I've seen a huge increase in stability.

Good luck!

 

Edited by JYW
  • Like 2

Bill

MSFS / XP11

"Teaching children is not a job. It's a privilege"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...