Jump to content
Sign in to follow this  
jmcmanna

Sudden huge frame rate loss with multiple monitors

Recommended Posts

I have been running a cockpit with 5 displays: two on an RTX 3060 (main display and one MIP display) and a GTX 1070 (three cockpit displays).  Everything running great until one day, I forgot to turn on one of the screens before loading P3Dv5.  The main screen loaded into one of the cockpit displays.  I closed P3D and turned on the screen that was off and reloaded P3D.  My frame rates dropped to between 4-8 after this mishap (from 30).  For the last three days I can’t get the frame rates above about 8fps without closing all of the undocked windows making up the cockpit displays.  If I load everything on the main screen, I lose about half of my frame rates with each new window I undock and drag to a different screen.

It doesn’t seem to matter which aircraft I load or if there is any add-on scenery: as soon as I undock a window and drag it to another monitor the frame rate drops in half.  Not sure where to go from here because everything was working fine until a few days ago...what setting could have changed when I forgot to turn on one of the monitors?

 

 

Share this post


Link to post

Using any software to control the 5 displays?

 

Is your P3Dv5 the current version?


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

I am using P3Dv5.2 downloaded from LM about three weeks ago.  No software for controlling the screens, just undocking and dragging windows from the main screen to the 4 used for the instrument displays.  I updated my nvidia drivers yesterday to the latest version as well, but it didn’t have any impact.

Share this post


Link to post

As a quick test:
Move your Prepar3d.cfg file to the desktop. A new default cfg will be built when P3D is later started.

Shut down the PC.
Turn the 5 monitors ON as you would normally.
Turn the PC On.
Start P3D.
Test.

Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

Are you running GSX? 

if so try disabling “render to texture” under the GSX settings 

Share this post


Link to post

No GSX.  
 

I will try running P3D with the clean .cfg file tomorrow and see if it makes a difference, thank you for the suggestion 

Share this post


Link to post
On 9/5/2021 at 9:52 PM, jmcmanna said:

No GSX.  
 

I will try running P3D with the clean .cfg file tomorrow and see if it makes a difference, thank you for the suggestion 

You are welcome.

Have you tested already?


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

halllo,
I only have one monitor but exactly the same problem

everything ok on saturday and it started on sunday.

I thought FSLABS a320 is to blame but I uninstalled everything, including prepar 3d
additionally deleted everything and deleted nvidia with DDU

unfortunately I only have 1-10 fps - standard aircraft and airport, no additional programs
joystick etc. not connected

Share this post


Link to post
7 minutes ago, Perfect_day said:

halllo,
I only have one monitor but exactly the same problem

everything ok on saturday and it started on sunday.

I thought FSLABS a320 is to blame but I uninstalled everything, including prepar 3d
additionally deleted everything and deleted nvidia with DDU

unfortunately I only have 1-10 fps - standard aircraft and airport, no additional programs
joystick etc. not connected

How are you measuring FPS ?

Screenshot with the default P3D flight ?

The General Debugging Steps are here for your review.
https://www.prepar3d.com/forum/viewtopic.php?f=6312&t=123246

 

 


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

with the internal FPS display of prepar3d

it makes no difference whether I block 30 fps or unlimited.

due to the lower FPS, it is impossible to fly

Share this post


Link to post
1 hour ago, Perfect_day said:

with the internal FPS display of prepar3d

it makes no difference whether I block 30 fps or unlimited.

due to the lower FPS, it is impossible to fly

What are you using for a sound system?

Any changes to the sound system?


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

have onboard realtek ASUS Crosshair VIII formula

I deactivated the driver as a test and suddenly I had my usual FPS
i have never updated the driver in the last few months.

then I reactivated the driver and only had 10 FPS again
under the sound setting Prepar3d switched from standard driver to realtek and had my FPS again

with FSLABS I always have the same problems, also there with the FMC option sound switched to Realtek but this time it didn't work there.

really weird the whole thing

Share this post


Link to post

on virus & threat protection settings " OFF " and Control Panel\System and Security\Windows Defender Firewall\Customize Settings turn off windows defender firewall

Share this post


Link to post

@Perfect_day

Glad to hear you located the problem with your sound setup.

Notes:

I use Realtek with Gigabyte Z390 Aorus Pro WiFi (edit) without any problems.
Realtek driver on my setup 6.0.8777.1.

 


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

the current version of realtek V6.0.8960 causes problems
I installed an older one and suddenly there are no problems

The strange thing is, I've never installed any other driver before

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...