Jump to content
Sign in to follow this  
Sesquashtoo

nVidia 471.96 and DXGI_DEVICE_HUNG resolved

Recommended Posts

1 hour ago, RobPol471 said:

Hi Paul,

During operation, Windows starts various checks at predetermined times which obviously can slow down the running programs.

You can check these controls by searching for:

  Utility of start - Task Scheduler Library - Microsoft - Windows.

By clicking on the folders shown you can disable the checks that Windows starts up as for example in the DiskCleanup and DiskDiagnostic folders. 
 

 

 

Hi Rob,

Yep, thank you I've done all of that.  I've also got my Windows Security settings disabled and even get the warnings about having them shut down yet despite that in the background it was still updating it's Virus and Threat protection.  It shows Yellow with a notice about protection being off and my device being vulnerable yet if I open the settings it's still shows Security intelligence is up to date and it's last scan.  I've gone so far as to change device policy settings and it is still updating itself and doing scans.  When those scans happened it also introduced issues with P3D (whose folders were excluded)

Thank you


Have a Wonderful Day

-Paul Solk

Boeing777_Banner_BetaTeam.jpg

Share this post


Link to post

I've taken screenshots of each section of the P3D settings menus and deleted Prepar3d.cfg.

Started P3D again and reinstated my settings by using the screenshots. Easy enough to do. But using SimStarterNG I'm not entirely certain how that works as my settings are stored in each profile.

I shall now fly from Dallas Ft Worth somewhere west.


Ray (Cheshire, England).
System: P3D v5.2 & v3.4, Intel i7-8086K o/c to 5.2Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

The flight from KDFW to KABQ was fine although a sizeable pause when intercepting the localiser at this remote airport was a surprise.


Ray (Cheshire, England).
System: P3D v5.2 & v3.4, Intel i7-8086K o/c to 5.2Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Other software, mostly games, have had this issue as well.  Almost all of the solutions/bandaids have led to setting TDRlevel to 0.  One of the MS docs stated that this error was an application caused error and that the application developer needed to correct it.  While it may be true, it's a typical MS response.  I even found a reference to another set of registry entries called AppInit..._DLLs.  With the theory behind it being that a problem DLL is being loaded via those entries.  Which I really doubt has any merit as for those to be involved would require either an app or a person modify the keys from MS defaults.   If I come up with anything else I'll add it to this thread.

  • Like 1

Share this post


Link to post

@Sabre57, your insight is appreciated. One thing strikes me about all this. DirectX has now become so complicated it’s almost unresolvable. Instead we have a sticking plaster approach to make software useable.

Between Microsoft, Nvidia and LM they’ve created a bit of a mess. The only surprise is that more people aren’t affected. How some don’t have the problem remains a mystery.


Ray (Cheshire, England).
System: P3D v5.2 & v3.4, Intel i7-8086K o/c to 5.2Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

HI, ever since I installed/added TdrLevel, TdrDelay=60, TdrDdiDelay=60(Dword) I have had no problems. None have shown up yet and I have completed at least 10 flights .  I am using 3 4K 65 INCH TV and 2 other   monitors for inside views.....two video cards in one computer...Hopefully this continues.. 

Percy

  • Like 1

Share this post


Link to post
13 hours ago, percylee said:

HI, ever since I installed/added TdrLevel, TdrDelay=60, TdrDdiDelay=60(Dword) I have had no problems. None have shown up yet and I have completed at least 10 flights .  I am using 3 4K 65 INCH TV and 2 other   monitors for inside views.....two video cards in one computer...Hopefully this continues.. 

Percy

What Driver version Percy?  Are you on 471.96 as well?  Good to know and awesome setup 🙂 


Have a Wonderful Day

-Paul Solk

Boeing777_Banner_BetaTeam.jpg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...