Jump to content
Sign in to follow this  
Rob G

Need AIG PSXT RT setup advice please

Recommended Posts

 

Hi all. So I have AIG fully installed and it is operational. I have installed PSXT and Real Traffic (including subscription).

So I am trying to edit the parameters.xml file in PSXT to use the AIG stuff.

Some background info: MSFS is installed on my F: drive and my Community folder is on my E: drive

This is a section of what I have right now in the parameters.xml file for PSXT:

<parameters>
    <parameter name="COLLISION_USER_GND" value="true" />
    <parameter name="MAIN_WINDOW_X" value="400" />
    <parameter name="MAIN_WINDOW_Y" value="20" />
    <parameter name="SNAPSHOT_MINUTES" value="30" />
    <parameter name="DEFAULT_PERCENTAGE_SMALL" value="75" />
    <parameter name="DEFAULT_PERCENTAGE_MEDIUM" value="50" />
    <parameter name="DEFAULT_PERCENTAGE_LARGE" value="35" />
    <parameter name="BORDER_SMALL_MEDIUM" value="20" />
    <parameter name="BORDER_MEDIUM_LARGE" value="100" />
    <parameter name="REMOVE_FALSE_THRESHOLD" value="50" />
    <parameter name="PROGRAM_VERSION" value="30.3" />
    <parameter name="LIVERIES_FOLDER" value="" />
    <parameter name="STOCK_AIRPORTS_FOLDER" value="stock_airports" />
    <parameter name="ADDON_AIRPORTS_FOLDER" value="addon_airports" />
    <parameter name="SPECIALS" value="" />
    <parameter name="lfolder0" value="E:\MSFS\Packages\Community" />
    <parameter name="lfolder1" value="" />
    <parameter name="lfolder2" value="" />
    <parameter name="lfolder3" value="" />
    <parameter name="lfolder4" value="" />
    <parameter name="lfolder5" value="" />
    <parameter name="lfolder6" value="" />
    <parameter name="lfolder7" value="" />
    <parameter name="lfolder8" value="" />
    <parameter name="lfolder9" value="" />
    <parameter name="STOCK_AIRPORTS_PATH" value="E:\MSFS\Packages\Official\Steam\fs-base" />
    <parameter name="afolder0" value="" />
    <parameter name="afolder1" value="" />
    <parameter name="afolder2" value="" />

When I open PSXT I get the message:    48: Set parameters to your airports first.

I am going through the PSXT manual over and over but I can't figure out what I have wrong.

The automatic scan parameters on the app screen are both turned off

Can someone please help me? I feel like I am close but not quite there yet.

UPDATE: It seems if I turn on the Autoscan for Addon Airports it suddenly works but I don't know why.

Can anyone shed some light on this for me?

 
  •  

Intel i9-10900, ASUS ROG Maximus Hero XII WiFi motherboard, 32GB of 4000Mhz CAS 15 memory, ASUS GEFORCE RTX 3090, 1000watt power supply, 2 NVME drives and 4 SSD's, Oculus Quest 2

Share this post


Link to post
Share on other sites

Always try  both autoscans  true first (default).

If you have installed AIG in the Community folder PSXT should find it.

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, kiek said:

Always try  both autoscans  true first (default).

If you have installed AIG in the Community folder PSXT should find it.

I have the AIG data in the Community folder but the Community folder is not in the default location. It appears that I have the parameters set correctly for the liveries to be found.

Don't understand why I have to check the autoscan for addon airports box though since I have only default airports.

 

-------------------------------------------------------------------------------------------

Since you were nice enough to respond to me, I have another question, regarding the LEARNER tool.

I don't understand how it works. I open Real Traffic and open the Learner tool. I enter an ICAO code for an airport. But the Real Traffic screen never does anything and all I ever get on the Learner screen is a message every minute that no live data was available in the last minute. How do you get the learner tool to work?

This is what my log looks like when I start the learner:

Fri Mar 11 17:42:22 2022 (utc) Learner version 9.1

********************************** parameters **********************************
from C:\Users\rgold\AppData\Roaming\Learner\parameters.xml
MAIN_WINDOW_X=238
MAIN_WINDOW_Y=29
REMOVE_FALSE_THRESHOLD=50
PROGRAM_VERSION=9.1
AIRPORT=
LIGHT_AIRCRAFT=true
HELICOPTERS=true
DURATION_MINUTES=45
********************************************************************************

SERVER=false
CLIENT=false
LIVERIES_FOLDER=liveries
STOCK_AIRPORTS_FOLDER=stock_airports
ADDON_AIRPORTS_FOLDER=addon_airports
Read from data\dbase.xml :
   2444 ICAO aircraft types of which 93 heavies, 420 middles, 180 helicopters and 9 gliders
   45 similar type rules
   586 types with wingspan information
      average half wingspans: heavy 25.9m, middle 11.8m, light 5.8m, heli 6.0m
   6370 ICAO Airline codes, 39 PVT codes and 89 GOV codes
   26679 dbase records
AIRPORT=
Data provider connected
Traffic Reader connected
QNH Reader connected
? No QNH found in {"ICAO": "","QNH": 1013, "METAR": "UNKN 000000", "NAME": "UNKNOWN", "IATA": "","DISTNM": 0}
No traffic at all in this region?
 

What am I doing wrong?

LATEST UPDATE: NEVER MIND. STUPID ERROR - AFTER TYPING IN ICAO AIRPORT CODES, I DID NOT HIT ENTER TO TRIGGER IT. DIDN'T SEE ANY INSTRUCTIONS ABOUT DOING THAT. ALL IS WELL NOW LOL.

Edited by Rob G
More info

Intel i9-10900, ASUS ROG Maximus Hero XII WiFi motherboard, 32GB of 4000Mhz CAS 15 memory, ASUS GEFORCE RTX 3090, 1000watt power supply, 2 NVME drives and 4 SSD's, Oculus Quest 2

Share this post


Link to post
Share on other sites
52 minutes ago, Rob G said:

 DIDN'T SEE ANY INSTRUCTIONS ABOUT DOING THAT.

It is clearly written in the Manual section 3.4, the paragraph in red....

Share this post


Link to post
Share on other sites
56 minutes ago, Rob G said:

Don't understand why I have to check the autoscan for addon airports box though since I have only default airports

If you set it to false PSXT assumes you will set an afolder parameter  to your addon airports and if you forget that you get an error message (like you got), that's why....

By setting it to true, you don't get that. It does not mind you do not have addon airports yet. If you will add one later, everything will still work.

 

Share this post


Link to post
Share on other sites
1 hour ago, kiek said:

It is clearly written in the Manual section 3.4, the paragraph in red....

I stand corrected and apologize. I don't know how I could have missed such an obvious included instruction. Going too fast through it I guess

I love the entire system and am thrilled to have it all working now :-).

 


Intel i9-10900, ASUS ROG Maximus Hero XII WiFi motherboard, 32GB of 4000Mhz CAS 15 memory, ASUS GEFORCE RTX 3090, 1000watt power supply, 2 NVME drives and 4 SSD's, Oculus Quest 2

Share this post


Link to post
Share on other sites
Posted (edited)

Two more questions (don't want to start too many threads):

First, I notice when actually using the full AIG product, the boarding ramps at gates seem to be active, moving, and attached to planes at the gate. I don't see that when using PSXT and RT and the AIG database. Is that observation correct? If so, any plans to make the ramps more active? Of maybe direct me to a third party app that automates the ramps?

Second, I notice when using the PSXT system, ground vehicles are driving under planes and planes are passing right over trucks. I am assuming that it's because the they don't know each other are there. How do you folks set up ground vehicles so that this doesn't happen?

Edited by Rob G
adding a second question

Intel i9-10900, ASUS ROG Maximus Hero XII WiFi motherboard, 32GB of 4000Mhz CAS 15 memory, ASUS GEFORCE RTX 3090, 1000watt power supply, 2 NVME drives and 4 SSD's, Oculus Quest 2

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Rob G said:

Two more questions (don't want to start too many threads):

I and the other readers of this forum  prefer that you start a new thread for each new question and to give it a clear subject... 

That way it will be easier to find if the question was asked already.

So please act like that in the future.

About your questions.

The boarding ramps are not active indeed, and will not be that in the future. That's a technical issue but in short: the aircraft in PSXT are just dumb objects that are moved around. They are not 'real artificial' AI aircraft, and thus do not interoperate with boarding ramps.

Second question. That's because they are not aware of each other. It is the same problem with your user aircraft passing over trucks and so on. Just switch off ground vehicles in your Sim if you do not like it.

 

 

 

 

Edited by kiek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...