Sign in to follow this  
turnandbank

Hooray! Solution to mipbias reducing blurries but causing shimmers

Recommended Posts

Many of us have tried Gary Summons tip to add the line mipbias=6 to the fsx.cfg in order to reduce blurries - which it definitely did for me. The well known problem is that it also causes heavy shimmering, especially of fences and trees. Also, mipbias=4 isn't accepted by FSX, nor did it do anything to reduce blurries on my system. As someone suggested, one can force supersampling with nhancer (not sure of the ati method) as the nvidia control panel no longer includes it, except for transparency antialiasing. While this does counteract the shimmering somewhat, it is not - at least for me - all that effective and only makes shimmering truly unnoticeable at a very high 4x4 level. With this setting the performance hit due to the quadruple rendering is simply too much, particularly in low visibility weather and with lower-end cards and non-sli systems.Now to the point: keeping antialiasing on multisampling mode, in the optimizations section of nhancer (also in texture filtering for the standard control panel profile) I set "Negative LOD BIAS" to "Clamp" rather than "Allow". Guess what, the shimmers disappeared almost completely, but the blurries were still greatly reduced by the mipbias tweak! I recommend using nhancer to do this since the standard control panel - besides offering fewer 3d options in general - sometimes doesn't let the clamp stick when anisotropic filtering is application controlled. While you're at it, you might as well force an anisotropic level with nhancer since that's what I did. I hope this helps out those who were injured by blurries only to be insulted by shimmers.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks for the tip;) I already had the LOD BIAS clamped but I had supersampling enabled. I got unbearable shimmering with those settings so I guess I'll enable multisampling and see if I get as lucky as you.What kind of video card do you have btw?

Share this post


Link to post
Share on other sites

I should add that setting a more conservative 4xS or 8xS supersampling will further improve image quality with little if any performance hit on more recent cards. Chris, 8800gtsI too got horrible shimmers.Again, I did force anisotropic filtering to 16x - I tried 8x too to make sure there was no shimmering there either - while leaving the setting ticked in fsx as well. And i'm using the 158.22 drivers. Also, make sure you download and use nhancer if you're not.

Share this post


Link to post
Share on other sites

Great, then it's not a fluke. To make things more conclusive, those for whom this trick works should also post, I think, whether the mipbias tweak continued to mitigate blurries. Edit: Chris, also make sure that negative lod bias is clamped in the individual "MS Flight Simulator X" profile and not merely the global settings (which I left alone).

Share this post


Link to post
Share on other sites

Alrighty, can't wait to try this when I get home. What does your fsx.cfg look like, fiber frame setting, multi-texture bandwidth etc...?

Share this post


Link to post
Share on other sites

Single coreFramerate=unlimitedfiber = .34 (.50 did help with blurries a bit but at the cost of fps. Since mipbias helped much more, I reverted back to the old value). mult = 400 (for some this may cause stutters)PoolSize=5000000 (don't think this matters much anymore)TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000Very Dense Complexityand Dense AutogenAntialiasing and anisotropic both checked in fsx but modes set with nhancer.Also, I play with a widescreen and WideViewAspect=True, which requires more resources but offers significantly greater visibility and of course makes it so the graphics aren't warped.

Share this post


Link to post
Share on other sites

Not to be a pain, but can you notate which settings you made within nhancer? Every time I make an adjustment directly to the card (through the nvidia control panel or nhancer) I end up with pixel and shimmer soup. I think I just don't know which settings to adjust and at what levels to adjust them.

Share this post


Link to post
Share on other sites

>Also, I play with a widescreen and WideViewAspect=True, which>requires more resources but offers significantly greater>visibility and of course makes it so the graphics aren't>warped. I tried this too (setting WideViewAspect=True) but I found it made no difference at all... Yes, the view was zoomed out a lot, but after zooming in it looks EXACTLY the same! I already have the option to choose 1680x1050 by default while having WideViewAspect=False. Maybe on some computers/screens you cannot choose 1680x1050 (or anything wide) without changing False to True...?

Share this post


Link to post
Share on other sites

Here's my exact nHancer settings for FSX, which work really well for me with no blurries. I'm running this on a 256MB 7800GTX with the 160.03 drivers (using a hacked inf to make them install on a non-8 series card)First off in the Global profile:On the Optimizations Tab:Texture filtering: High QualityNegative LOD Bias - ClampFSX Profile:AA: Combined 8xSGamma Correction checkedAF: 16XEverything else is left on the defaults.A few things:1. The clamped LOD bias should be on whenever you're using AF - which for me is every game I play, so I force it always on via the Global profile. What this does essentially is prevent the game from trying to move the mipmap transition zones further into the distance to keep textures sharp. This is totally unnecessary for the game to do this with AF on, since AF's entire purpose is to smooth out those transitions and sharpen textures that are viewed at a steep angle to the viewer.2. I don't turn on the transparency AA because the combined 8xS mode is already applying a supersampling AA algorithm to the whole scene, which includes transparent textures. This type of AA drastically improves the shimmering you see from stuff like trees, power poles and radio towers, which are composed of alpha textures.3. In the sim I leave the AA box off and the filtering pull-down on Anisotropic. I know Nvidia and MS recommend leaving the AA box checked and using the "Enhance the Application" mode in the driver, but I've always gotten better results to my eyes by doing it this way.

Share this post


Link to post
Share on other sites

Ryan's settings are very good, I think. He's also absolutely right about clamping when using AF, which I myself got to after installing new drivers.I, however, always leave the boxes checked in fsx because when "enhanced in-game AA setting" is not checked it will override the program anyway. That way, if I feel like switching between the enhanced and non-enhanced modes I don't have to change anything from within fsx.Some people report greater stability with fsx when "enhanced" is chosen. Others report greater performance when it is not. I fall into the latter group, without falling into the former, so I don't usually check "enhance" unless I want to try coverage sampling for whatever reason.As for wideviewaspect, J van E, it does not just zoom out but actually fixes the screen aspect if you're running a widescreen monitor. You can tell because if you don't set this option to true and merely zoom out the gauges in the vc will remain distorted, oval instead of circular.

Share this post


Link to post
Share on other sites

Thanks! That really helps! I have almost no blurry situations now.

Share this post


Link to post
Share on other sites

Cool, I updated my blog with this and gave weenie props.note, I have seen people try values of 4-7 with varying success as well.

Share this post


Link to post
Share on other sites

>Cool, I updated my blog with this and gave weenie props.>>note, I have seen people try values of 4-7 with varying>success as well.Phil,I'm pretty sure the negative LOD bias Clamp doesn't have anything to do with the supersampling AA, it doesn't increase performance, it just stops the engine from trying to push the texture mipmap boundaries further into the distance, which can cause really bad shimmering with anisotropic filtering on...

Share this post


Link to post
Share on other sites

ah I think I replied to the wrong thread in regards to your tweaks here on nvidia. again though thankyou soo much as not only does the scenery look better in distance...it flys by smoother as well ( not sure if microsofts dual core patch hotfix had anything to do with it) but definitely looks 100% better now! thanks.Craigwoohoo no blurriesflying over palm beach at sunset KPBI2007-5-29_23-23-24-859.jpg

Share this post


Link to post
Share on other sites

Thanks to the information in this thread, I just may have had the most stable, best looking, non-corrupt-simconnect, no-blurry, crisp texture flight I have ever had in FSX (version anything). It definitly rivals FS9 now! Just need some PMDG, LVL-D and UT and I would give up FS9 for good. I would particularly like to thank Tab (Ryan) for his above post about nHancer and his settings. nHancer is definitly sweet and straight to the point. His settings along with mipbias=6 seems to have set me straight and the shimmers were gone for the first time since FS9 came out.One quirk was, after implementing these settings, my FPS tanked on the first statup of FSX. It turns out I had to tweak my overclock settings again in the BIOS. It was at 3.2GHz/400FSB with 4:5 ratio & 5/5/5/15/5 and DDR2-1033. After adjusting the overclock to tighter bus timings and lowering the ratio to 3.2Ghz/400FSB with a 1:1 ratio & 4/4/4/12/5 and DDR2-800, I regained my locked 20FPS settings. Oh, and ASX and XGraphics is awsome now as well.Think I'm gonna just go fly now... Nobody touch nothin' ;)http://forums.avsim.net/user_files/172872.jpg

Share this post


Link to post
Share on other sites

With all the problems with blurries and SP1 still surfacing I thought this thread needs bumping up again. I tried the MipBias6 tweak for blurries previously, but had severe shimmering of autogen until I tried the advice in this thread. I downloaded nhancer and am using 4xs AA and 16X AF and I have Negative LOD set to clamp in optimizations along the the MipBias6 in FSX cfg. I was just about ready to reinstall FS9 prior to this as I had tried everything else to exhaustion with no success. I am now enjoying virtually no blurries and and very smooth flight with no shimmers. I have added the following tweeks to the appropriate sections of FSX cfg.TEXTURE_BANDWIDTH_MULT=0FIBER_FRAME_TIME_FRACTION=.34 ; TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=600My system specs are nothing spectacular eitherASUS A8X-SATHLON64-4000 oc to 2.5 GHZ2048mb PC3200RAM7900GS KO 256mb GRAPHICS CARDWD 120GB IDE DRIVEI lock my frames at 30 and maintain that except at major detailed airports where I am getting 14-16 fps looking towards the gates etc increasing back to 30 fps as I move away. I am using 1x high water, no bloom or ground shadows. Traffic 33%, Cars 20%, Boats and Ships 35%. and Very Dense scenery and Autogen. Everything now looks great and I am finally happy with the performance and look of FSX.I strongly recommend trying the advice in this thread if you are having issues with blurries and you at least have a reasonable hardware setup.RegardsMartin

Share this post


Link to post
Share on other sites

are you sure about the texture bandwidth value of 0?wouldn't that STOP loading textures?

Share this post


Link to post
Share on other sites

excuse my ignorance but do I have to load up nhancer each time I turn my pc on or once i set it up does it save it to the registry and i can forget about it

Share this post


Link to post
Share on other sites

There is an nHancer service which is started when you boot the PC. The nHancer GUI is run by you each time want to make a change to your settings. Each time you click on a setting in the nHancer GUI, the change is immediatly written to the registry.

Share this post


Link to post
Share on other sites

Yes I am using TEXTURE_BANDWIDTH_MULT=0. Interestingly on my system if I let FSX build a new CFG. file that is what it defaults to. I have tried other settings, esp. 40, 100, 200, and 400, but none of these higher settings have improved my texture loading and they all increase stutters although 40 isn't too bad. Using TEXTURE_BANDWIDTH_MULT=0 along with the other suggestions in this thread gives me the best overall experience. My textures load very well, not always 100%, but far better than any other settings I have tried. One other thing I found on my system was that setting the Level of Detail Radius to Large also helped to reduce blurries with no performance hit on my system. With regards to 'nhancer' it will save your settings to the registry so you do not have to reset them every time.ASUS A8X-SATHLON64-4000 oc to 2.5 GHZ2048mb PC3200RAM7900GS KO 256mb GRAPHICS CARDWD 120GB IDE DRIVERegardsMartin

Share this post


Link to post
Share on other sites

Where exactly will I find my FSX.cfg file and where inside it do I make the changes and additions? Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this