Jump to content
Sign in to follow this  
Maikel van der Heijden

Question PMDG P3D V5

Recommended Posts

Posted (edited)

Hi there,

I've installed AAO 2.29 b28 today and I've been trying for 5 hours to get a taxi light switch working on my Stream Deck using the Lorby-SI Axis and Ohs software provided on the website.

Using the stream deck software I drag a new button called OnOff to a new Stream Deck Page. I select Simulator event called: #69749 under PMDG_737NGX and add that to the Write K: event with on ''1'' and of ''0''. 

As Read variable I used: LTS_TaxiSw as stated in the Select Simulator Variable ans set on value to 1 with repeat yes. Long press event is empty.

 

I have no idea what I'm doing wrong, I've reinstalled the Stream Deck and AAO software to see of that was the issue. Once I'm in the Simulator AAO sees the aircraft I'm in and I have a green light. Under tools poort 9080 is on. I also added the SDK line to the 737 ini file.

I've also set PMDG-PMDG_NGX_Data to repeating with 50ms.PMDG-PMDG_SIMAP_INIT_ONCE to One shot with 50ms. PMDG-PMDG_SIMDATA_TO_AP repeating and 50ms.

I'm running everything in adim mode and poorts are all checked and set. No other programs are using that poort.

 

I hope someone can help me because it is really frustrating at the moment.

 

Kind regards,

 

Maikel van der Heijden

Edited by Maikel van der Heijden

Share this post


Link to post
Share on other sites

Is the StreamDeck even working with AAO? Did you try the "Little Gauges" profile and are those showing data?


LORBY-SI

Share this post


Link to post
Share on other sites
Posted (edited)

On the website where you've downloaded the StreamDeck plugin there is a Troubleshooting PDF concerning the WebAPI. Please follow those instructions. Most likely you will have to change the port to 6080 or thereabouts. Apparently 9080 is used by other apps quite frequently, for example Logitech GHub. You can do that change from within AAO, there is a separate dialog for changing it in all extras that depend on AAO. But the Elgato software must be terminated for this to work (you have to do that anyway, otherwise it won't "get" the port change).

Also, there is a Connection action in the AAO StreamDeck plugin that shows you if the Deck is able to talk to AAO or not.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites

Thank you for your quick respone. I will give it a go over the weekend changing the port to 6080 is no problem for me. I think I have more problems programming different button like I said above. In the above example, am I using the corret commands?

Share this post


Link to post
Share on other sites
12 minutes ago, Maikel van der Heijden said:

In the above example, am I using the corret commands?

Looks OK to me. To be certain, you can check them in the RPN Editor in AAO.


LORBY-SI

Share this post


Link to post
Share on other sites

Ok thanks, it´s a bit abracadrabra for me. Would be great to have some pre-loaded PMDG P3D files for varrious aircraft.In the editor I first used the NG3 but I should've used the NGX for the NGXU I guess. Going to try and solve the issue this weekend, I will report back.

Share this post


Link to post
Share on other sites

For some reaseon the program seems to be unable to read the values from the PMDG NGXu.

I own the 737, 747 and the 777, have enabled the SDK functionallity in the options.ini.

I've added the data script for the corresponding type with a interval of 100 milliseconds.

When I lookup the value for the (PMDG:MCP_Altitude) it does give me a reading for the 747 and the 777 but not for the 737.

I'm unable to read any values for the 737. However, the events seem to work. For example. I can turn on the landing lights through an event.

Do you have any idea what can cause this?

Share this post


Link to post
Share on other sites
Posted (edited)
26 minutes ago, Maikel van der Heijden said:

Do you have any idea what can cause this?

Which one of the data gathering scripts are you running with the NGXu?

I think it will be more effective when you send an email with your proof of purchase to the support address. It is on the last page of the manual.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites

Hi, 

I'm using the PMDG_NGX_DATA. I can send actions via the Stream Deck for example landing light on/off. But once I try to add an action like APU or Strobe which has 3 positions the AAO's doesn't read the currect status of the button in the cockpit.

 

Share this post


Link to post
Share on other sites
Posted (edited)

The "NGX" is the old plane from FSX and early P3D.

I'm pretty sure that for the NGXu you have to use the "PMDG_NG3_Data" script.

These scripts are for reading the variables from the PMDG SDK, they have nothing to do with the events. The events always work.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...