Jump to content
Sign in to follow this  
pobee10

Tip for Panning Stutter

Recommended Posts

Been dealing with annoying panning stutters with a good frame rate for a while and think I solved the issue so I thought I would pass along.

if you suffer from panning stutters with otherwise good FPS, take a look at your “free look momentum” setting in the camera settings.  Mine was at 50 and after brining it to zero the annoying stutter is gone. 

  • Like 2

Share this post


Link to post
Share on other sites

Don’t know why this was posted twice- mods plz delete the repeat thread

Share this post


Link to post
Share on other sites

Unfortunately, didn't work for me. Mine was already at zero and still get a bad stutter. 

Share this post


Link to post
Share on other sites

The most effective way I've found to reduce panning stutter is to enable the rolling cache (default 8 GIB size), set Off Screen Terrain Pre-Caching to LOW, and make sure V-Sync is ON (30 FPS limit).

  • Like 2
  • Upvote 3

Share this post


Link to post
Share on other sites
1 hour ago, MadDog said:

The most effective way I've found to reduce panning stutter is to enable the rolling cache (default 8 GIB size), set Off Screen Terrain Pre-Caching to LOW, and make sure V-Sync is ON (30 FPS limit).

Absolutely spot on.  I find medium is OK though on my system using ultra for most other settings.

Rolling cache and vsync 30 also helps a lot.


Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3080 - 32 Gig DDR4 RAM - Windows 11 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post


Link to post
Share on other sites

Interesting. I set Off Screen Terrain Pre-Caching to Ultra to get rid of the stutters while looking around and it worked a treat. As this essentially removes the unloading and reloading of objects.

  • Like 5
  • Upvote 1

Share this post


Link to post
Share on other sites

Lowering the Terrain LOD (100-200) was the only remedy for me. Keep that slider at a number that your system can handle and you will avoid panning stutters.

  • Like 3

Share this post


Link to post
Share on other sites
23 hours ago, pobee10 said:

Been dealing with annoying panning stutters with a good frame rate for a while and think I solved the issue so I thought I would pass along.

if you suffer from panning stutters with otherwise good FPS, take a look at your “free look momentum” setting in the camera settings.  Mine was at 50 and after brining it to zero the annoying stutter is gone. 

Thanks for the tip.  I tried this and it works for me as well.

Share this post


Link to post
Share on other sites
17 hours ago, MadDog said:

The most effective way I've found to reduce panning stutter is to enable the rolling cache

The problem with enabling rolling cache is that I found it creates connection issues. With rolling cache turned off, I no longer have server disconnection issues.


Intel i9 10980XE | Asus 1070 8GB (Soon to be replaced by the RTX 4080 16GB) | Asus ROG Strix X299-E 2066 | Samsung 970 Evo Plus 2TB NVMe M.2 (Main Drive) | Samsung 860 QVO SSD 2TB (Storage) | Arctic Liquid Freezer II 360 | Team Group Xtreem "8 Pack Edition" DDR4 3600 32GB 

Ireland stands with Ukraine 🇺🇦                                   💎🦍

 

 

                                                                                                                                                        

Share this post


Link to post
Share on other sites
On 5/14/2022 at 8:22 PM, pobee10 said:

Been dealing with annoying panning stutters with a good frame rate for a while and think I solved the issue so I thought I would pass along.

if you suffer from panning stutters with otherwise good FPS, take a look at your “free look momentum” setting in the camera settings.  Mine was at 50 and after brining it to zero the annoying stutter is gone. 

Hi, where is the location of the camera file and look for that setting please.

Share this post


Link to post
Share on other sites
20 hours ago, jcuellar said:

Hi, where is the location of the camera file and look for that setting please.

You don't need the file, pobee10 is talking about the in sim settings page- General options- camera settings 

  • Like 1

Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz (8 cores) Hyper on, Evga RTX 3060 12 Gig, 32 GB ram, Windows 11, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post
Share on other sites

Setting Low Latency to ULTRA in NV Control Panel def helps--I haven't done the other two methods to improve or eliminate this issue mentioned here.  I do use Vsync to 30fps and do have Terrain Pre-Caching to ULTRA and yet don't have panning stutter.

  • Like 2

Noel

System:  9900K@4.9Ghz@1.19v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVMe 2Tb x 2, RTX 3080 Ti FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, 30 frames vSync to 60Hz.

 

Share this post


Link to post
Share on other sites
1 hour ago, Noel said:

Setting Low Latency to ULTRA in NV Control Panel def helps--I haven't done the other two methods to improve or eliminate this issue mentioned here.  I do use Vsync to 30fps and do have Terrain Pre-Caching to ULTRA and yet don't have panning stutter.

Everything I've read about ultra low latency says you're more likely experiencing a placebo effect. The mode only does anything if you're getting high FPS and you're GPU-bound. Also, it doesn't even work in DX12, so if you're using DX12, then it's definitely not doing anything. 

Share this post


Link to post
Share on other sites
6 hours ago, Chapstick said:

Everything I've read about ultra low latency says you're more likely experiencing a placebo effect. The mode only does anything if you're getting high FPS and you're GPU-bound. Also, it doesn't even work in DX12, so if you're using DX12, then it's definitely not doing anything. 

Did you try it? It's definitely not placebo! At least in my case it's one of the most effective setting that eliminates stutters and makes panning very smooth. Turning it off makes an extremely noticeable difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...