Jump to content
Sign in to follow this  
willy647

auto start apps from exe.xml

Recommended Posts

MSFS does not launch any of the apps in exe.xml. The path of both apps is correct.

Below the contents of exe.xml

<?xml version="1.0" encoding="utf-8" ?>
<SimBase.Document Type="SimConnect" version="1,0">
    <Descr>SimConnect</Descr>
    <Filename>SimConnect.xml</Filename>
    <Disabled>False</Disabled>
    <Launch.Addon>
        <Name>IVAO Pilot Client</Name>
        <Disabled>False</Disabled>
        <ManualLoad>False</ManualLoad>
        <Path>E:\MSFS2020\IVAO\PilotCore\pilot_core_fs2020.exe</Path>
        <NewConsole>False</NewConsole>
    </Launch.Addon>
    <Launch.Addon>
        <Name>FSRealistic</Name>
        <Disabled>false</Disabled>
        <Path>E:\FSRealistic\FSRealistic.exe</Path>
    </Launch.Addon>
</SimBase.Document>

 


i7-7700K @ 4.9 GHz, 32GB DDR4, GTX1080, 2 x Samsung 1TB NVMe, 1 x 3TB HDD, Windows 10 Prof

Share this post


Link to post
Share on other sites
Posted (edited)

Your file has been derived from the simconnect.xml, hasn't it? That is not really the correct format. The sim may not mind so much, but still, the exe.xml looks like this:

<?xml version="1.0" encoding="utf-8"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
      <Name>IVAO Pilot Client</Name>
      <Disabled>False</Disabled>
      <ManualLoad>False</ManualLoad>
      <Path>E:\MSFS2020\IVAO\PilotCore\pilot_core_fs2020.exe</Path>
      <NewConsole>False</NewConsole>
  </Launch.Addon>
  <Launch.Addon>
      <Name>FSRealistic</Name>
      <Disabled>False</Disabled>
      <Path>E:\FSRealistic\FSRealistic.exe</Path>
  </Launch.Addon>
</SimBase.Document>

Be mindful that it is MSFS that is starting your apps. So if these apps have been set up as to start "As Administrator", then you must start MSFS "As Administrator" too. Otherwiese the sim doesn't have enough privileges to run your apps.

Oh, and make sure that the encoding in the ?xml Tag matches the actual encoding of your file. Using Notepad++ this is done in the menu "Encoding" - select "UTF-8 BOM" for this file, then save it. 
Or change the "encoding" attribute to the correct value. With a standard Windows textfile it is often encoding="Windows-1252".

Edited by Lorby_SI
  • Like 1

LORBY-SI

Share this post


Link to post
Share on other sites

The problem was the admin rights -  apps starting as admin, while msfs not. I also changed the exe.xml format as you suggested - looks more appropriate

Thanks for your help !

 


i7-7700K @ 4.9 GHz, 32GB DDR4, GTX1080, 2 x Samsung 1TB NVMe, 1 x 3TB HDD, Windows 10 Prof

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...