Jump to content
Sign in to follow this  
Nicholas Jackson

Buttkicker Issues

Recommended Posts

All,

 

Had my Buttkicker for years and it was working fine with MSFS202 until recently .It works with the Realtek Audio Manager  with all 5,1 speakers working as they should, including the subwoofer and the Buttkicker.

No joy however in MSFS 2020 I cannot recall altering anything in the Audio settings.

Can anyone help out??

Thank You

Nic

Share this post


Link to post
Share on other sites

I had two buttkickers where the inline cable connector failed.  I cut off the connectors and spliced the wires together and they both work fine after that.

LouP 

Share this post


Link to post
Share on other sites

My original buttkicker just burned out one day about 6 months ago. Shaker melted (almost). I did get my monies worth. It was about 4 years old.


Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz (8 cores) Hyper on, Evga RTX 3060 12 Gig, 32 GB ram, Windows 11, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post
Share on other sites

If its working normally with other programs/music without clipping or going into protection mode then its not a shaker,cable,amplifier or soundcard issue (ie Hardware)

Assuming your on PC then in MSFS you would need to check if your main sound output device matches with what you have selected as your output device on the pc.

If they all match then we will need more info on your setup (second soundcard etc etc)

 

 

 

Share this post


Link to post
Share on other sites

Guys

All sound outputs match tests fine in Realtek Audio Manager (AC 97 Onboard sound) as before with all speakers where they should be in relation to sound, also ran trouble shooting in Windows settings page and tested once again all working as advertised.

 

However played YouTube music no vibration, also tried Re-entry  an orbital simulator no luck there either, so so I am at a bit of a loss. Checked manuals and positive I have everything right???

Regards

 

Share this post


Link to post
Share on other sites

Hi, how did the error manifest in your case?

My BK2 has worked fine about year ago. After a longer break I tried to use it again, but the red on/off light stays red. I can hear the click inside the box when I press the on/off button though. It is connected via an USB Sound Blaster G1 and the Sound Module is set to use it. (even playing just music through the G1 enabled as sound device doesn't wake the BK2 up).

Any suggestions?

Thanks!

 

Share this post


Link to post
Share on other sites
35 minutes ago, Mark1616 said:

Hi, how did the error manifest in your case?

My BK2 has worked fine about year ago. After a longer break I tried to use it again, but the red on/off light stays red. I can hear the click inside the box when I press the on/off button though. It is connected via an USB Sound Blaster G1 and the Sound Module is set to use it. (even playing just music through the G1 enabled as sound device doesn't wake the BK2 up).

Any suggestions?

Thanks!

 

Call them they will send you a new unit.


CPU: Intel i9-11900K @5.2 / RAM: 32GB DDR4 3200 / GPU: 3080 10GB /

Share this post


Link to post
Share on other sites

Just made a flight from Amsterdam to Istanbul.

The Buttkicker 2 worked just fine ( using OpusFSI).


Gerard

13900 8 cores @ 5.5-5.8 GHz / 8 cores @ 4.3 GHz (hyperthreading on) - Asus ROG Strix Gaming D4 - GSkill Ripjaws 2x 16 Gb 4266 mhz @ 3200 mhz / cas 13 -  Inno3D RTX4090 X3 iCHILL 24 Gb - 1x SSD M2 2800/1800 2TB - 1x SSD M2 2800/1800 1Tb - Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's as one wide front view

9900k : all 8 cores @ 5.0 GHz (hypterthreading on) - Asus ROG 370 - 4x Gb 3200 MHz cas 15 - Inno3D RTX 3090 X4 iCHILL 24 Gb  - 1x SSD M2 2800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...