Jump to content
Sign in to follow this  
LH067U

MCE & Tobii Eye Tracker 5

Recommended Posts

Posted (edited)

Hi guys,

since a while I am not able to use MCE on MSFS2020 (latest stable) together with the Tobii Eytracker 5 and ends up in CTD of Tobii Eye tracker & MCE.

Both are at latest versions and FSUIPC as registered as well.

What does happen in detail:

When launching MSFS2020 and Tobii Eye tracker 5 everything works as expected. Starting a flight at any airport is no big deal because everything works as it should be.

After launching of MCE its start-up process is quite normal. But after about 2 minutes Tobii Eye Tracker stops working, led lights are still on but no head movements are possible and it can't really be restarted to solve the issue... And MCE crashes with a message of restarting MCE for a reinitialisation of the picked aircraft frame.

It doesn't matter if I pick PMDG or FENIX. The outcome is the same!

Does anyone out there has got either the same problem or any solution or work-around?

Thanks in advance for any suitable support.

 

Happy flying and safe landings,

LH067U

Edited by LH067U

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, LH067U said:

Hi guys,

since a while I am not able to use MCE on MSFS2020 (latest stable) together with the Tobii Eytracker 5 and ends up in CTD of Tobii Eye tracker & MCE.

Both are at latest versions and FSUIPC as registered as well.

What does happen in detail:

When launching MSFS2020 and Tobii Eye tracker 5 everything works as expected. Starting a flight at any airport is no big deal because everything works as it should be.

After launching of MCE its start-up process is quite normal. But after about 2 minutes Tobii Eye Tracker stops working, led lights are still on but no head movements are possible and it can't really be restarted to solve the issue... And MCE crashes with a message of restarting MCE for a reinitialisation of the picked aircraft frame.

It doesn't matter if I pick PMDG or FENIX. The outcome is the same!

Does anyone out there has got either the same problem or any solution or work-around?

Thanks in advance for any suitable support.

 

Happy flying and safe landings,

LH067U

I don't have the eye tracking hardware so a bit in the dark. 

Is TobiGameHub.the main softwarethat runs in the background and drives the device? If it's the case, will download it.

Please state exat "mce.exe" and "Simco64_Ldr.exe" versions you are on. Thanks

 

Edited by FS++

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, FS++ said:

I don't have the eye tracking hardware so a bit in the dark. 

Is TobiGameHub.the main softwarethat runs in the background and drives the device? If it's the case, will download it.

Please state exat "mce.exe" and "Simco64_Ldr.exe" versions you are on. Thanks

 

Thank you for giving support.

My task manager reports the following processes and / or services linked to Tobii:

  • Tobii.EyeX.Interaction
  • Tobii.EyeX.Engine
  • platform_runtime_IS5LEYETRACKER5_service
  • TobiiVirtualDevice service ( Tobii Eye Tracker generic service)
  • Tobii.Service

After installing the latest MCE version 2.9.79 I found a beta file which has been published here in the forum.

I hope my information will help to sort out the issue. Fingers crossed and many thanks for supporting.

 

LH067U

Edited by LH067U

Share this post


Link to post
Share on other sites
4 hours ago, LH067U said:

Thank you for giving support.

My task manager reports the following processes and / or services linked to Tobii:

  • Tobii.EyeX.Interaction
  • Tobii.EyeX.Engine
  • platform_runtime_IS5LEYETRACKER5_service
  • TobiiVirtualDevice service ( Tobii Eye Tracker generic service)
  • Tobii.Service

After installing the latest MCE version 2.9.79 I found a beta file which has been published here in the forum.

I hope my information will help to sort out the issue. Fingers crossed and many thanks for supporting.

 

LH067U

You're welcome.

 

Meanwhile, have a look at this thread that I came across today. Some users are sating that it doesn't work with MSFS well.

Find out whether it uses Asobo Simconnect or communicates with FSUIPC.

Also, look at the proceses you listed and check none is set to "Real time priority"

 

 

Share this post


Link to post
Share on other sites
19 hours ago, FS++ said:

You're welcome.

 

Meanwhile, have a look at this thread that I came across today. Some users are sating that it doesn't work with MSFS well.

Find out whether it uses Asobo Simconnect or communicates with FSUIPC.

Also, look at the proceses you listed and check none is set to "Real time priority"

 

 

First of all thank you for your response.

MSFS2020 SU9 or even SU10 Beta do work reliable and fine. Just did a 90.minutes-flight and everything was great. No stutters, graphic glitches or anything else that could be adressed to Tobii.

Interesting is your point about the used connection simconnect or FSUIPC. I'll will write to Tobii and FSUIPC vendors to get sure.

By the way: All processes are set to normal by default.

Edited by LH067U

Share this post


Link to post
Share on other sites

P. Dawson was very fast in responsing a request:

FSUIPC Peter Dawson's reply: "...FSUIPC has nothing to do with Tobi and knows nothing about it, as do I! ..."

When Tobii does not use FSUIPC but MCE does ... what else could be the reason?

Edited by LH067U

Share this post


Link to post
Share on other sites
1 hour ago, LH067U said:

P. Dawson was very fast in responsing a request:

FSUIPC Peter Dawson's reply: "...FSUIPC has nothing to do with Tobi and knows nothing about it, as do I! ..."

When Tobii does not use FSUIPC but MCE does ... what else could be the reason?

No, MCE doesn't use FSUIPC main application. We only make use of the wasm module for some airplane switches.

I suggest the following...

Un-install FSUIPC and manually remove <fsuipc-lvars-module> from community folder.

Start MSFS and load the Cessna Longitude or C172.

MCE doesn't make use of the wasm with these planes. It's exclusively via Simconnect.

Wait until aircraft is on tarmac ready to fly, then start MCE.

"Simco64_Ldr.exe" our other app is the gateway to MSFS. Make sure no anti-virus is blocking it.

It is expected to be running when MCE does. If it crashes for some reason, you'll get that "Unable to detect aircraft" message.

Just a reminder, unlike with Pepar3D or FSX, with MSFS, do not start MCE until aircraft has finished loading. For complex supported planes like PMDG 737, FENIX A320, Aerosoft CRJ and Flybywire, you are advised to set one of those as the plane MSFS loads on startup for smooth operation.

 

 

Share this post


Link to post
Share on other sites
On 9/1/2022 at 9:04 PM, FS++ said:

No, MCE doesn't use FSUIPC main application. We only make use of the wasm module for some airplane switches.

I suggest the following...

Un-install FSUIPC and manually remove <fsuipc-lvars-module> from community folder.

Start MSFS and load the Cessna Longitude or C172.

MCE doesn't make use of the wasm with these planes. It's exclusively via Simconnect.

Wait until aircraft is on tarmac ready to fly, then start MCE.

"Simco64_Ldr.exe" our other app is the gateway to MSFS. Make sure no anti-virus is blocking it.

It is expected to be running when MCE does. If it crashes for some reason, you'll get that "Unable to detect aircraft" message.

Just a reminder, unlike with Pepar3D or FSX, with MSFS, do not start MCE until aircraft has finished loading. For complex supported planes like PMDG 737, FENIX A320, Aerosoft CRJ and Flybywire, you are advised to set one of those as the plane MSFS loads on startup for smooth operation.

 

 

So. Got some time for testing.

How did I test?

  1. As instructed I de-installed FSUIPC and deleted the <fsuipc-lvars-module> from community folder manually.
  2. Started MSFS200 and loaded up the C172 on runway with running engines.
  3. Started MCE without any problems. Checklist reading passed. Everything is fine.

Next test: FSUIPC installed

  1. Re-installed FSUIPC and stopped while reading die Mobiflight popup. Could that be a hint?
  2. Started MSFS2020, selected the PMDG 737-700 with running engines on the same runway as the C172 before.
  3. Started MCE- Initialisation fine, Aircraft frame identified correctly. Ramp agent working.
  4. MCE stopped after reading the checklist on item 2, sent MSFS2020 to taskbar and popup says to restart the flight and not the simulator.
  5. Put MSFS2020 back to fullscreen, MCE has automatically opened the option page on the sim
    1. Tobii device missing in the controls page
  6. Restarted MCE, airframe identified, ramp agent annoucing, CTD again...same popup message.

What did I learn?

Difficult. I believe that MCE in combination with FSUIPC kicked Tobii out of my system temporarily. Tobii support was not very helpful and refers to Asobo...hahaha.

Have you got another idea?

 

Share this post


Link to post
Share on other sites
3 hours ago, LH067U said:

 

  1. MCE stopped after reading the checklist on item 2, sent MSFS2020 to taskbar and popup says to restart the flight and not the simulator.

 

This is normal. With PMDG 737 once MCE loads, if it doesn't find all the lvars it needs, it instructs you to reload the plane.

You can prevent the pop-up by reloading the plane and before you start MCE.

I suggest you un-install FSUIPC and just leave the <fsuipc-lvars-module> in \Community\ folder.

That way, any app that relies on FSUIPC main program will stop working.

Share this post


Link to post
Share on other sites
On 9/4/2022 at 9:02 PM, FS++ said:

This is normal. With PMDG 737 once MCE loads, if it doesn't find all the lvars it needs, it instructs you to reload the plane.

You can prevent the pop-up by reloading the plane and before you start MCE.

I suggest you un-install FSUIPC and just leave the <fsuipc-lvars-module> in \Community\ folder.

That way, any app that relies on FSUIPC main program will stop working.

You can prevent the pop-up by reloading the plane and before you start MCE.

... I always load up my planes and do all preps. Then MCE is loaded.

I suggest you un-install FSUIPC and just leave the <fsuipc-lvars-module> in \Community\ folder. That way, any app that relies on FSUIPC main program will stop working.

... am I right that you really suggest disableing FSUIPC to prevent any conflicts with MCE? Keep in mind that many virtual pilots out there have mapped lots of actions via FSUIPC.

For me this solution will result in disableing MCE instead of FSUIPC until the problem will have been fixed. Sorry.

Share this post


Link to post
Share on other sites
9 hours ago, LH067U said:

You can prevent the pop-up by reloading the plane and before you start MCE.

... I always load up my planes and do all preps. Then MCE is loaded.

I suggest you un-install FSUIPC and just leave the <fsuipc-lvars-module> in \Community\ folder. That way, any app that relies on FSUIPC main program will stop working.

... am I right that you really suggest disableing FSUIPC to prevent any conflicts with MCE? Keep in mind that many virtual pilots out there have mapped lots of actions via FSUIPC.

For me this solution will result in disableing MCE instead of FSUIPC until the problem will have been fixed. Sorry.

You mis-read the post.

It was for troubleshooting purposes so you can see which of the programs needs FSUIPC main application.

You don't have to un-installing it. Just make sure it's not running. Run Tobii and see if it works, without running MCE.

FSUIPC has been around for decades and many MCE users who also happen to use PF3 or Pilot2Atc have it running, so no conflict as such (and never had conflicts with it for a decade for that matter).

The Tobii is the unknown. Plenty of threads suggesting it's a hit and miss with MSFS. 

Find out whether they have their own wasm module or whether they are using Simconnect to interact with the sim for a start.

Last time I checked, Simconnect API had limitations with regards "views adjustments" via programming, (works only by triggering keys assigned by user) and that's why ChasePlane couldn't make it to MSFS despite being very popular in FSX & Prepar3D.

 

 

Edited by FS++

Share this post


Link to post
Share on other sites
21 hours ago, FS++ said:

You mis-read the post.

It was for troubleshooting purposes so you can see which of the programs needs FSUIPC main application.

You don't have to un-installing it. Just make sure it's not running. Run Tobii and see if it works, without running MCE.

FSUIPC has been around for decades and many MCE users who also happen to use PF3 or Pilot2Atc have it running, so no conflict as such (and never had conflicts with it for a decade for that matter).

The Tobii is the unknown. Plenty of threads suggesting it's a hit and miss with MSFS. 

Find out whether they have their own wasm module or whether they are using Simconnect to interact with the sim for a start.

Last time I checked, Simconnect API had limitations with regards "views adjustments" via programming, (works only by triggering keys assigned by user) and that's why ChasePlane couldn't make it to MSFS despite being very popular in FSX & Prepar3D.

 

 

When MSFS2020 / FSUIPC and Tobii are running ... everything is fine. Head movements are stable (even in SU10 Beta) and the full immersion is amazing.

The conflict starts after MCE has launched, initialized and the ramp agent did his annoncement. Head movents are stopped and bring me back to cockpit view. Manually head movements are only possible by using the assigned joystick button. Disableing / Enableing Tobii has not effect.

WASM Module: there is not anything like that.

Simconnect: Tobii support refers to Asobo. simconnect.xml shows nothing about Tobii and I can't find out which port they are using in case of interacting via simconnect.

The key assignment had been done but even by pressing the assigned key Tobii is not working again when MCE is running. Complete restart without MCE ... everything is fine.

 

 

Edited by LH067U

Share this post


Link to post
Share on other sites
4 hours ago, LH067U said:

When MSFS2020 / FSUIPC and Tobii are running ... everything is fine. Head movements are stable (even in SU10 Beta) and the full immersion is amazing.

The conflict starts after MCE has launched, initialized and the ramp agent did his annoncement. Head movents are stopped and bring me back to cockpit view. Manually head movements are only possible by using the assigned joystick button. Disableing / Enableing Tobii has not effect.

WASM Module: there is not anything like that.

Simconnect: Tobii support refers to Asobo. simconnect.xml shows nothing about Tobii and I can't find out which port they are using in case of interacting via simconnect.

The key assignment had been done but even by pressing the assigned key Tobii is not working again when MCE is running. Complete restart without MCE ... everything is fine.

 

 

OK, one thing that comes to mind, MCE has a few speech commands for setting views and resetting view. Users operating a headgear (not just Tobii) must disable option in <Sim> tab MCE user interface.

Other than that, I have no answer right now

If it was software only, would have got it and tested it alongside MCE. But it's mostly hardware.

Try to find other MCE users who also use Tobii or some headgear and see if they are facing the same issue.

There are a few threads on Avsim. Here is just one of them

 

 

Share this post


Link to post
Share on other sites
On 9/17/2022 at 7:53 AM, LH067U said:

When MSFS2020 / FSUIPC and Tobii are running ... everything is fine. Head movements are stable (even in SU10 Beta) and the full immersion is amazing.

The conflict starts after MCE has launched, initialized and the ramp agent did his annoncement. Head movents are stopped and bring me back to cockpit view. Manually head movements are only possible by using the assigned joystick button. Disableing / Enableing Tobii has not effect.

WASM Module: there is not anything like that.

Simconnect: Tobii support refers to Asobo. simconnect.xml shows nothing about Tobii and I can't find out which port they are using in case of interacting via simconnect.

The key assignment had been done but even by pressing the assigned key Tobii is not working again when MCE is running. Complete restart without MCE ... everything is fine.

 

 

One more suggestion.

When you install FSUIPC, by default, its wasm module is set to report data at 6 times per second which is only worth setting that extreme value if you are using a hardware simpit with the need to detect flashing lights states and things like that.

Go to \Community\fsuipc-lvars-module\ folder

Open "FSUIPC_WASM.ini" using Notepad and change "LvarUpdateFrequency=6hz" to "LvarUpdateFrequency=Second".

Because the "FSUIPC_WASM.ini" file size will change as a result of the editing, you need to edit another file which tells MSFS the size of the ini file

Right-click "layout.json" file and select "open with". Open it using Notepad.

Look at this section and ensure it looks like this

"path": "FSUIPC_WASM.ini",
"size": 488,
"date": 132941643600000000

The "size" is what you need to set to 488 which is the new expected file size.

That will reduce the load on Simconnect.

 

 

 

Share this post


Link to post
Share on other sites

Interesting thread!

Glad I came across this. I was saving up for Tobi for my Xmas present! No good if I can't use it with MCE!

I also use FSUIPC7 with P2atc.

Oh boy this is complicated. I'm wondering if MSFS is worth the angst!

XP??????😉


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...