Jump to content
Sign in to follow this  
pierrevw

PSXT and P3Dv5 multi PC setup: how to config?

Recommended Posts

Hello all,

I have a 6-PC setup where a main computer (server) drives 5 other 'slave' computers, each being dedicated to a part of a very wide view (5 beamers). The server does not output a view but it is running ProSim737, so I would like it to also get the traffic, such a way it shows in the TCAS. This server is also running RealTraffic, plus a 'server' instance of PSXT_P3D.

Thanks to Kiek, I could load the IVAO_MTL on the server, and it works.

I ticked the server mode in the GUI of this instance of PSXT, shared the 3 recommended folders, and updated the config file with these lines:

<parameter name="LIVERIES_FOLDER" value="\\B737-SYSTEM\liveries" />
<parameter name="ADDON_AIRPORTS_FOLDER" value="\\B737-SYSTEM\addon_airport" />
<parameter name="THIRDPARTY_AIRPORTS_FOLDER" value="\\B737-SYSTEM\3rdparty_airports" /> 

I also ticked the 'client' checkbox on PSXT GUI.

Problem: it seems that the clients are not willing to connect to (some of the) the shared folders, as I get an error #1 "THIRDPARTY_AIRPORTS_FOLDER not found".

Shared folders are tested and working in read/write/delete.

Am I missing something?

 

Thanks guys - and ladies! 🙂 

Share this post


Link to post
Share on other sites
12 hours ago, pierrevw said:

I have a 6-PC setup where a main computer (server) drives 5 other 'slave' computers, each being dedicated to a part of a very wide view (5 beamers). The server does not output a view but it is running ProSim737, so I would like it to also get the traffic, such a way it shows in the TCAS. This server is also running RealTraffic, plus a 'server' instance of PSXT_P3D.

Thanks to Kiek, I could load the IVAO_MTL on the server, and it works.

I ticked the server mode in the GUI of this instance of PSXT, shared the 3 recommended folders, and updated the config file with these lines:


<parameter name="LIVERIES_FOLDER" value="\\B737-SYSTEM\liveries" />
<parameter name="ADDON_AIRPORTS_FOLDER" value="\\B737-SYSTEM\addon_airport" />
<parameter name="THIRDPARTY_AIRPORTS_FOLDER" value="\\B737-SYSTEM\3rdparty_airports" /> 

I also ticked the 'client' checkbox on PSXT GUI.

Problem: it seems that the clients are not willing to connect to (some of the) the shared folders, as I get an error #1 "THIRDPARTY_AIRPORTS_FOLDER not found".

Shared folders are tested and working in read/write/delete.

Am I missing something?

Yes you missed a lot, I'm afraid 😉

Please study sections 2.5  and 2.6 of the Manual carefully first.

1. First of all, you should install RealTraffic at one PC only, and not at the other 5. At the other 5 RT must have been completely uninstalled including the InsideSystems folder in \AppData\Roaming. RT broadcasts its traffic data and weather data over your local network, all PC's with PSXT can listen to it.. 

2. You have to decide if you want to run PSXT networked (Manual section 2.5) or that you want several PSXT running synchronous in parallel at different computers (Manual 2.6).

3. Note that in a networked PSXT config, the PSXT acting as Server has to be at the PC running the Simulator, and PSXT running as Client + RealTraffic are at the networked PC. It is at that networked PC that you have to set the 3 parameters in the parameters.xml of the PSXT as CLient.

4. If you want to run more PSXT's synchronous you are in section 2.6. See the Manual.

 

BTW: two parameters in your post are wrong, the names of the airport folders are fixed:  addon_airports and thirdparty_airports

EDIT: maybe you should contact GSalden, he has a similar setup running Prosim 737 and two PC's

Edited by kiek

Share this post


Link to post
Share on other sites

Your explanations make things much clearer to me, thank you. I had read the manual, but I admit that I did not fully understand the role of each element in a networked configuration.
I changed the name of the sharings to match the ones you recommend. 

However, it seems that there could be a typo in the manual in 2.5 (page #7).
Where we are reading:

<parameter name="THIRDPARTY_AIRPORTS_FOLDER" value="?" />


shouldn't we read instead:

<parameter name="THIRD_PARTY_AIRPORTS_FOLDER" value="?" />  

(underscore between THIRD and PARTY) ? I changed this and now it seems to work.

Last question: if I correctly understand, the PSXT acting as a server doesn't listen to RT locally? So how can we inject the traffic in the P3D running on this computer?

Thanks a lot! 🙂

 

Share this post


Link to post
Share on other sites
22 minutes ago, pierrevw said:

shouldn't we read instead:


<parameter name="THIRD_PARTY_AIRPORTS_FOLDER" value="?" />  

Last question: if I correctly understand, the PSXT acting as a server doesn't listen to RT locally? So how can we inject the traffic in the P3D running on this computer?

 

You are right, thanks for that, will change it.

The PSXT acting as a server is needed to generate information about your liveries and airports only. Once you have done that you don't have to start it again, until you install new liveries or airports.

The traffic is injected  in the Sim (at the PC where PSXT as Server resides) by PSXT as Client at the networked computer via the SimConnect API. That's why you have to configure SimConnect as described in the Manual.

 

Share this post


Link to post
Share on other sites

Hey Kiek,

Still making tests and trials with PSXT, which I really appreciate even if I feel a bit silly... 😉

In my multi-PC setup I finally set the following:

  • the main PC runs P3Dv5 + PSXT ( v32 😉 ) + RT + AIG (it also runs the Prosim737 suite - but this is not relevant here) 
  • 5 client PCs are dedicated to outside view and run P3Dv5 + PSXT 32 + AIG (no RT)

All the PC's are in sync via WidevieW. I followed the explanation at chapter 2.6 of your manual.

I also set params on the clients like this :

<parameters>
	<parameter name="RANDOM" value="false" />
	<parameter name="HIGH_PERF_AIRCRAFT" value="false" />
	<parameter name="LIGHT_AIRCRAFT" value="false" />
	<parameter name="HELICOPTERS" value="false" />
	<parameter name="GLIDERS" value="false" />
	<parameter name="ALWAYS_ON_TOP" value="false" />
	<parameter name="GARMIN" value="false" />
	<parameter name="LIG_AUTOMATIC" value="false" />
	<parameter name="AFG_AUTOMATIC" value="true" />
	<parameter name="CLIENT" value="false" />
	<parameter name="SERVER" value="false" />
	<parameter name="LOG_MATCH_LIVE" value="false" />
	<parameter name="LOG_MATCH_STATIC" value="false" />
	<parameter name="TRAFFIC_WHEN_USER_AIRBORNE_ONLY" value="false" />
	<parameter name="LEARN_DESTINATION" value="false" />
	<parameter name="COLLISION_USER_GND" value="true" />
	<parameter name="COLLISION_LIVE_PARKED_GND" value="true" />
	<parameter name="MAIN_WINDOW_X" value="227" />
	<parameter name="MAIN_WINDOW_Y" value="525" />
	<parameter name="MATCHING_DEPTH" value="8" />
	<parameter name="PARKED_MATCHING_DEPTH" value="8" />
	<parameter name="LATERAL_RANGE" value="40" />
	<parameter name="SNAPSHOT_MINUTES" value="20" />
	<parameter name="PROGRAM_VERSION" value="32.0.0" />
	<parameter name="BLOCK_CALLSIGN" value="" />
	<parameter name="FLIGHTPLANS_FOLDER" value="" />
	<parameter name="RUNNING" value="false" />
	<parameter name="DESTINATION_AIRPORT" value="" />
	<parameter name="lfolder0" value="C:\B737 SIMULATOR\P3Dv5\SimObjects\Airplanes" />
	<parameter name="lfolder1" value="C:\B737 SIMULATOR\AIG\Addon\AIGAIM - OCI\SimObjects" />
	<parameter name="afolder0" value="D:\ORBX\FTX_OLC\FTX_VECTOR_FixedAPT" />
	<parameter name="afolder1" value="D:\ORBX\FTX_AU\FTXAU48_CUSTOM" />
	<parameter name="afolder2" value="D:\ORBX\FTX_AU\FTXAU46_SHORES" />
	<parameter name="afolder3" value="D:\ORBX\FTX_AU\FTXAU45_SCENERY" />
	<parameter name="afolder4" value="D:\ORBX\FTX_AU\FTXAU38_CUSTOM" />
	<parameter name="afolder5" value="D:\ORBX\FTX_AU\FTXAU36_SHORES" />
	<parameter name="afolder6" value="D:\ORBX\FTX_AU\FTXAU35_SCENERY" />
	<parameter name="afolder7" value="D:\ORBX\FTX_AU\FTXAU28_CUSTOM" />
	<parameter name="afolder8" value="D:\ORBX\FTX_AU\FTXAU26_SHORES" />
	<parameter name="afolder9" value="D:\ORBX\FTX_AU\FTXAU25_SCENERY" />
	<parameter name="afolder10" value="D:\ORBX\FTX_AU\FTXAU18_CUSTOM" />
	<parameter name="afolder11" value="D:\ORBX\FTX_AU\FTXAU16_SHORES" />
	<parameter name="afolder12" value="D:\ORBX\FTX_AU\FTXAU15_SCENERY" />
	<parameter name="afolder13" value="D:\ORBX\FTX_AU\FTXAU05_ROADS" />
	<parameter name="afolder14" value="D:\ORBX\FTX_NA\FTX_NA_NCA08_CUSTOM" />
	<parameter name="afolder15" value="D:\ORBX\FTX_NA\FTX_NA_NCA07_MESH" />
	<parameter name="afolder16" value="D:\ORBX\FTX_NA\FTX_NA_NCA06_CVX" />
	<parameter name="afolder17" value="D:\ORBX\FTX_NA\FTX_NA_NCA05_SCENERY" />
	<parameter name="afolder18" value="D:\ORBX\FTX_EU\FTX_EU_WLS_08_CUSTOM" />
	<parameter name="afolder19" value="D:\ORBX\FTX_EU\FTX_EU_WLS_07_MESH" />
</parameters>

The main PC works fine with the traffic. However, the 5 client PCs are only partially working despite they all use the same RT running on the main PC:

  • no aircrafts are shown at the gates/parkings of the client PCs;
  • "live traffic is never as high as on the main PC;
  • the live traffic has big delays so the same airborne aircraft shows at very different positions on the 5 views;
  • "Liveries" and "Aircraft categories" keeps greyed so I'm not sure they work;

How to solve these issues? I'm a bit stuck, even after re-reading the manual...

Thank you !

 

Share this post


Link to post
Share on other sites

Hi

Please don't  post images of text files, because I cannot copy/edit it in my response. Use plain text and hide it with the spoiler. https://www.avsim.com/forums/topic/609916-how-to-hide-contents-in-this-forum-spoiler/

Delete lfolder0 because it is not pointing to AI aircraft but to user flyable aircraft.

Did you let all client PC's generate Livereis and Airports? Were the results exactly the same as on your main PC?

Nico

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Nico,

Sorry for the embedded XML, I thought that "<>" was the correct tool to show code on this board. Will remember your advice!

Quote

Delete lfolder0 because it is not pointing to AI aircraft but to user flyable aircraft.

Well, I deleted lfolder0. I thought that this library was needed to depict all aircraft that are not present in AIG...
To get most of the liveries, I previously added the IVAO_MTL library, but I finally removed it because once added to simobjects.cfg it takes hours to start P3D.

What is then the best way to get most (if not all) AI liveries in P3D? Downloading all the items available in AIG would take hours I guess.

 

Quote

Did you let all client PC's generate Livereis and Airports? Were the results exactly the same as on your main PC?

How to be sure that they generated all liveries and airports and how to check if the result is the same? As you maybe read earlier, the GUI buttons "Liveries" and "Airports" become greyed and deactivated a few seconds after PSXT is started...

 

Kind regards,

Pierre

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, bfsim said:

Well, I deleted lfolder0. I thought that this library was needed to depict all aircraft that are not present in AIG... 

No, no, never use User Flyable aircraft as AI aircraft. They are much to heavy on cpu./pu and they do not always support SimConnect commands.

1 hour ago, bfsim said:

To get most of the liveries, I previously added the IVAO_MTL library, but I finally removed it because once added to simobjects.cfg it takes hours to start P3D.

I never had that problem with IVAO_MTL in P3D? must be something else that causes the wait.

1 hour ago, bfsim said:

What is then the best way to get most (if not all) AI liveries in P3D? Downloading all the items available in AIG would take hours I guess.

Indeed download all of them... or switch back to IVAO_MTL and fixed the issue you have with it.

1 hour ago, bfsim said:

How to be sure that they generated all liveries and airports and how to check if the result is the same? As you maybe read earlier, the GUI buttons "Liveries" and "Airports" become greyed and deactivated a few seconds after PSXT is started...

Start PSXT without P3D running, then the push buttons will be enabled.

You must see the same numbers of liveries and airports in the GUI, then the result is the same.

Edited by kiek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...