Jump to content
Sign in to follow this  

Error Code 0x80070002

Recommended Posts

Could someone possibly help me please. Today for the first time ever when opening msfs2020 I got the message unable to open game "error code (0x80070002)". The only thing I did before trying to open the game was to update my Windows10 via the settings. Surely this shouldn't have affected it? I have tried numerous suggestions found on the internet without joy. Anyone else with this problem?

Share this post

Link to post
Share on other sites

This problem occurs when some files in the update are missing or Windows Update database on the computer is inconsistent with the database instructions in the update.


As you are unable to connect to the network, initially we will troubleshoot internet connection issue.


-Are you using wired/wireless network connection?


Limited connectivity means the PC has successfully connected to the router, but the PC wasn't assigned a valid IP address, so you can't actually get to the Internet. It can also indicate that a valid IP address was assigned but that the PC doesn't have Internet connectivity. If you're connected to a home network, try restarting the router.


Step 1:

Run the network troubleshooter to diagnose and repair any problem related to your network. Access the link mentioned below for steps:



Step 2:

One of the components of the Internet connection on your computer is a built-in set of instructions called TCP/IP. TCP/IP can sometimes become damaged or corrupted. If you cannot connect to the Internet and you have tried all other methods to resolve the problem, TCP/IP might be causing it.

Refer the help article to reset Internet Protocol (TCP/IP).



For reference:


For a full list of steps to try, see the Wired and Wireless tutorial on this page.


Wired and wireless network connection problems in Windows




Ryzen 5800X3D, Nvidia 3080 - 32 Gig DDR4 RAM, 1TB & 2 TB NVME drives - Windows 11 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post

Link to post
Share on other sites

Many thanks fofr your rapid responce. I'm indeed using a wireless connection. Your post suggest (if I'm correct) that I might have been connected ok to my router but the inernet connection might have been sparodic during the download of the windows update. I think this could have indeed been the problem as I have been experiencing bad internet conections of late. We are on a mobile internet service being in a very remote area in West Cork Ireland. I will try re booting the router and report back. Incidentally having downloaded windows updates this morning how can I re down load the same update? When I go to settings it says I'm now up to date. Thank you for your assistance.

Share this post

Link to post
Share on other sites

Hi Powlcown,

I experienced the same thing trying to launch MSFS2020 on patch release day (before I even installed the new SU10 patch).    After much frustration and effort, I finally found a procedure that worked to fix the issue (corruption of MIcrosoft Gaming Services API).   Your results may vary but it sure worked well for me. 

1)  Delete Xbox PC App (if installed)

2)  Delete Microsoft Gaming Services by invoking Windows Powershell in Administrator mode and copy/paste the following line and press Enter:

     get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

3)  Again, using Windows Powershell in Administrator mode, copy/paste the following:

    Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServices” -Recurse

4)  Again, using Windows Powershell in Administrator mode, copy/paste the following:

    Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServicesNet” -Recurse

5)  Restart PC

6)  Download and reinstall XBox app for PC

7)  Download SU10 Update Patch for MSFS2020 via Xbox App

8   Launch MSFS2020






Share this post

Link to post
Share on other sites

My apologies for delay in respoding to #hobart escin.  Thank you for your replay to my query. I wish I'd read your answer before I embarked on a full days frustration. I eventually got it working. Goodness knows how but I obviously pressed the right buttons!!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...