Jump to content
Sign in to follow this  
abrams_tank

NVidia Game Ready Driver with fixes for MSFS released!

Recommended Posts

2 minutes ago, Alvega said:

Did you empty your community folder?

I did

Just now, rutra said:

I know stupid question... but did you restart your PC after fresh installation?

twice in fact....a full shutdown...then a "reboot" after


Regards,

Steve Dra

Download my FSX, P3D paints at Avsim by clicking here
Get my paints for MSFS planes at flightsim.to here, and iFly 737s here

9Slp0L.jpg 

Share this post


Link to post
Share on other sites
13 minutes ago, Steve Dra said:

I did

twice in fact....a full shutdown...then a "reboot" after

Steve

Did you give Download Display Driver Uninstaller DDU a try before rolling back to the studio drivers?


Dan

i9-10900K@5.2 (HT off) / Asus Maximus Hero Z490 / RTX 3090 FE / Patriot Viper Steel 32GB (4 x 8GB) DDR4 4400@4000CL17 / ARCTIC Liquid Freezer II 280 / Phanteks Eclipse P600S / 2ea Samsung 970 EVO Plus SSD 1TB / 1ea Samsung 850 EVO 1TB / EVGA 1000W G3, 80+ Gold / Arctic P14 PWM Case Fans / Sony 43in 4K / P3Dv5.3 & MSFS2020

Share this post


Link to post
Share on other sites
2 minutes ago, Wise87 said:

Steve

Did you give Download Display Driver Uninstaller DDU a try before rolling back to the studio drivers?

I used the "clean install' option in the Nvidia app.  I'll try DDU next. Thanks.


Regards,

Steve Dra

Download my FSX, P3D paints at Avsim by clicking here
Get my paints for MSFS planes at flightsim.to here, and iFly 737s here

9Slp0L.jpg 

Share this post


Link to post
Share on other sites
19 minutes ago, Steve Dra said:

I did

twice in fact....a full shutdown...then a "reboot" after

As above, you first need to boot pc into safe mode run DDU with the option to clean and reboot.

Note once you reboot the first time msconfig again and set to reboot into normal mode but this time use the option to not reboot no, to reboot later.

Install the drivers only. You will find your back to a true fresh install. Now reboot again and hopefully your now good.

the clean install is far from the same thing

Edited by Nyxx

David Murden  MSFS   Fenix A320  PMDG 737 • MG Honda Jet • 414 / TDS 750Xi •  FS-ATC Chatter • 

 Fenix A320 Walkthrough PDF   Flightsim.to •

DCS  A10c II  F-16c  F/A-18c • (Others in hanger) • Supercarrier  Terrains = • Nevada NTTR  Persian Gulf  Syria • Marianas • 

• 10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • TM Warthog HOTAS • TM TPR • Corsair Virtuoso XT with Dolby Atmos®  Samsung G7 32" 1440p 240Hz • TrackIR 5 & ProClip

Share this post


Link to post
Share on other sites

I’m still on the 511.79 drivers. Is it worth to move over to the new drivers?

Edited by Wise87

Dan

i9-10900K@5.2 (HT off) / Asus Maximus Hero Z490 / RTX 3090 FE / Patriot Viper Steel 32GB (4 x 8GB) DDR4 4400@4000CL17 / ARCTIC Liquid Freezer II 280 / Phanteks Eclipse P600S / 2ea Samsung 970 EVO Plus SSD 1TB / 1ea Samsung 850 EVO 1TB / EVGA 1000W G3, 80+ Gold / Arctic P14 PWM Case Fans / Sony 43in 4K / P3Dv5.3 & MSFS2020

Share this post


Link to post
Share on other sites

DX12, and doing circuits at Chicomick's freeware Duxford, around 1000 ft up, the runway markings are very much sharper with TAA than with DLSS. I'm using a 3080Ti, with a 1440p monitor, render scaling set to 200, FidelityFX sharpening set to 100, frames locked at 30. I'll stick with DX12 and TAA, and look forward to further refinements from Asobo. Right now, the sim has never looked or performed better.

  • Like 1

Share this post


Link to post
Share on other sites

My results:

- 3080ti
- 12900K
- 64gb ram

Test Scenario: Fenix spawned on 09L at EGLL - take-off, loop around and land 27R
12pm, scattered clouds and no ai/multiplayer traffic

Frames are ~45 before takeoff and dips to about ~34 during the takeoff but generally is between 35-45 in cockpit during the scenario.

Settings mostly high with clouds and pre-cache on ultra and 2k monitor. I don't use DLSS.

Comparison between SU9 and SU10 and NV driver from August:
DX11 - ~2fps increase and slightly more smooth
DX12 - Similar FPS as DX11, better CPU/GPU utilisation but with major stutters

Comparison between NV driver from August and latest driver:
DX11 - ~2ps increase and feels same as previous driver as far as smoothness goes.
DX12 - feels like another 2fps increase but might be placebo. good CPU/GPU utilisation - I am now seeing mostly GPU limited scenarios. Best smoothness I had to date and much better than DX11. FPS numbers looks more consistent than DX11. For the first time I have now switched to DX12 will continue to monitor the experience. 

Something else I noticed - I usually cap FPS to 38 in the NV control panel and applying this again after my testing it feels like the smoothness might be slightly compromised under DX12 - but I am not 100% sure if my mind is just playing tricks so will have to test more.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Wise87 said:

I’m still on the 511.79 drivers. Is it worth to move over to the new drivers?

Only if you want to use DX12.

Share this post


Link to post
Share on other sites
1 hour ago, Wise87 said:

Steve

Did you give Download Display Driver Uninstaller DDU a try before rolling back to the studio drivers?

Sigh....did a full DDU clean uninstall in safe mode....reloaded studio driver (last know working)....same result.  Up for any other things to try.   Did not create a restore point before installing the driver that started this crapfest!  I will from now on.  (never had this happen in decades of updating drivers.)

 


Regards,

Steve Dra

Download my FSX, P3D paints at Avsim by clicking here
Get my paints for MSFS planes at flightsim.to here, and iFly 737s here

9Slp0L.jpg 

Share this post


Link to post
Share on other sites
1 minute ago, Steve Dra said:

Sigh....did a full DDU clean uninstall in safe mode....reloaded studio driver (last know working)....same result.  Up for any other things to try.   Did not create a restore point before installing the driver that started this crapfest!  I will from now on.  (never had this happen in decades of updating drivers.)

 

Sorry to hear that. I always create a restore point just in case. Hope you get it worked out. 

  • Like 1

Dan

i9-10900K@5.2 (HT off) / Asus Maximus Hero Z490 / RTX 3090 FE / Patriot Viper Steel 32GB (4 x 8GB) DDR4 4400@4000CL17 / ARCTIC Liquid Freezer II 280 / Phanteks Eclipse P600S / 2ea Samsung 970 EVO Plus SSD 1TB / 1ea Samsung 850 EVO 1TB / EVGA 1000W G3, 80+ Gold / Arctic P14 PWM Case Fans / Sony 43in 4K / P3Dv5.3 & MSFS2020

Share this post


Link to post
Share on other sites
1 hour ago, Greazer said:

The new driver does not change the size of the trees 😂

Either you are a joker or a troll, it's impossible you don't know what I was talking about. 


Alvega

Share this post


Link to post
Share on other sites

Zero issues with new Game driver , running DX12 with DLSS .


 

 

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Greazer said:

The new driver does not change the size of the trees 😂

There was a graphical bug happening to some Nvidia users where giant rainbow trees (among other things) would appear in the sky when hitting high ram usage under DX12.

https://forums.flightsimulator.com/t/dx12-issues-weird-graphics-glitches-stutters-in-panning/529129

Edited by Tuskin38
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, St Mawgan said:

DX12, DLSS Quality, Ultra everything, 3840 x 2160, V-Sync on in game, Frame Rate 50% of monitor. 

GPU mem peaked at 13.86 so far. 

GPU temp 68 degrees

Smooth, smooth, smooth! 

Seems about the same as the Studio set to me which were also amazing.  

 

I'm using the same settings and I have to agree. Everything is silky smooth. My test DX11/TAA at FlyTampa Vegas in the Fenix. I would see some pauses as I switched views. Using the settings Ultra for most items and High for a few I get silky smooth transitions and smooth departure out of Las Vegas. I'm going to do some more testing but I like the results so far. 

Update: Noticed that DLSS made the altitude tape blurry while it was scrolling so I switched to TAA which fixed it. More testing using DX12.

Edited by Wise87

Dan

i9-10900K@5.2 (HT off) / Asus Maximus Hero Z490 / RTX 3090 FE / Patriot Viper Steel 32GB (4 x 8GB) DDR4 4400@4000CL17 / ARCTIC Liquid Freezer II 280 / Phanteks Eclipse P600S / 2ea Samsung 970 EVO Plus SSD 1TB / 1ea Samsung 850 EVO 1TB / EVGA 1000W G3, 80+ Gold / Arctic P14 PWM Case Fans / Sony 43in 4K / P3Dv5.3 & MSFS2020

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...