Jump to content
Sign in to follow this  
Rogen

TEXTURE_SIZE_EXP 9 or 10 ?

Recommended Posts

On 2/11/2023 at 4:27 PM, Rogen said:

Great additional comment to expand the thread reference.

I couldn't really say loading time increasing was really noticable to any degree myself, but I suppose if I timed it.

And yeah the CPU is doing lots of work but does feel pretty good loading overall.

An update: I just did some experimenting with it again, and with 20 of 24 cores running P3Dv5 on a 13900K the loading time issue is considerably less pronounced than I remember when I last tried it (on a six-core 8086K running a pair of 11GB 1080Ti GPUs in SLI).  So it sure seems that this may be one of those settings that was a little ahead of its time and which has come into its own on newer hardware.  Anyone running with a 16 or 24GB video card and a 10+ core processor really ought to try it (or as in my case, try it again).

  • Like 1

Bob Scott | President and CEO, AVSIM Inc
ATP Gulfstream II-III-IV-V

System1 (P3Dv5/v4): i9-13900KS @ 6.0GHz, water 2x360mm, ASUS Z790 Hero, 32GB GSkill 7800MHz CAS36, ASUS RTX4090
Samsung 55" JS8500 4K TV@30Hz,
3x 2TB WD SN850X 1x 4TB Crucial P3 M.2 NVME SSD, EVGA 1600T2 PSU, 1.2Gbps internet
Fiber link to Yamaha RX-V467 Home Theater Receiver, Polk/Klipsch 6" bookshelf speakers, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensor retrofit, Thermaltake View 71 case, Stream Deck XL button box

Sys2 (MSFS/XPlane): i9-10900K @ 5.1GHz, 32GB 3600/15, nVidia RTX4090FE, Alienware AW3821DW 38" 21:9 GSync, EVGA 1000P2
Thrustmaster TCA Boeing Yoke, TCA Airbus Sidestick, 2x TCA Airbus Throttle quads, PFC Cirrus Pedals, Coolermaster HAF932 case

Portable Sys3 (P3Dv4/FSX/DCS): i9-9900K @ 5.0 Ghz, Noctua NH-D15, 32GB 3200/16, EVGA RTX3090, Dell S2417DG 24" GSync
Corsair RM850x PSU, TM TCA Officer Pack, Saitek combat pedals, TM Warthog HOTAS, Coolermaster HAF XB case

Share this post


Link to post

I have a 12900k and it takes a minute, if that.

The 24 cores must be helping I suspect. 😀

  • Like 1

Share this post


Link to post
5 hours ago, Bob Scott said:

Anyone running with a 16 or 24GB video card and a 10+ core processor really ought to try it (or as in my case, try it again).

Bob is giving good advice here. I've been using this setting for a about a month now with my i7-13700K and RTX 3080 12GB card. I have all of the processor heavy P3D settings set at max. I can see autogen all the way to the horizon and my processor doesn't even work up sweat. Over Anchorage Alaska at 5000 ft. I use about 15GB of RAM and 8.5 GB of Vmem. So far I have never used more than 10GB Vmem.

So depending on what you fly and where you fly, if you're running an RTX 3080 12GB card it may be worth a try.  Modern hardware definitely makes this setting possible, but you don't necessarily need a top of the line processor or graphics card.

  • Like 1

Version: P3Dv5.4, P3Dv6  CPU: Core i7-13700K @ 5.5 GHz with HT on,  GPU: RTX 3080 12GB,  RAM: 32GB DDR-5MONITOR: 32" 4K with G-Sync enabled, OS: Win10 22H2, Target Frame Rate: P3D 120, NCP Max Frame Rate 35.

Share this post


Link to post
6 hours ago, DonMuskopf said:

I can see autogen all the way to the horizon

This setting has nothing to do with autogen, though.

Share this post


Link to post

Been using a 10 setting for a few days now.

Like Bob, I tried the 10 setting back when I had a 1080 and an 8700K and that system just couldn't hack it.

Now, with a 3080Ti (12 GB VRAM) and an i9 10900K (10 core/20 threads)@ 5.3 Ghz, setting 10 looks great and load time is only about 20 seconds longer.

Thanks, Bob!

 

....Lloyd

 

 

 

 

 

 


Lloyd Noel (Ontario, Canada)

Intel i9 10900KF@5.2GHz / NZXT Kraken X73 AIO / MSI MPG Z590 Gaming+ / 32GB DDR4 3600 Corsair Vengeance LPX / Gigabyte RTX3080Ti Gaming OC / Corsair RM1000e 1KW PS / 1TB WD Black M.2 (Win 11 Pro) / 1TB Sabrent Rocket M.2 .(MSFS2020) / 512GB Sabrent Rocket M.2 (XP12) / 1TB TimeTec SATA (Misc. & FS Support)

Share this post


Link to post
36 minutes ago, Noell said:

Been using a 10 setting for a few days now.

Like Bob, I tried the 10 setting back when I had a 1080 and an 8700K and that system just couldn't hack it.

Now, with a 3080Ti (12 GB VRAM) and an i9 10900K (10 core/20 threads)@ 5.3 Ghz, setting 10 looks great and load time is only about 20 seconds longer.

Thanks, Bob!

....Lloyd

Some of y'all with 12GB card must be using lightweight scenarios to test this, because with it set to 10 and autogen/scenery LOD maxed out, I VRAM OOM at FT's EHAM in the iFly Max on my 12GB 3080Ti. 

Share this post


Link to post
14 hours ago, Chapstick said:

Some of y'all with 12GB card must be using lightweight scenarios to test this, because with it set to 10 and autogen/scenery LOD maxed out, I VRAM OOM at FT's EHAM in the iFly Max on my 12GB 3080Ti.

Well... if you take a look at my first pic you'll see 11854 MB used out of 12160 MB.

And I run distance drawing and densities greater than that offered by sliders.

e.g. AUTOGEN_BATCH_LOD=1

and if you look far in the distance of that pic you'll see the treelines on the hills, might have to display the pic full sized to see though.

I guess this is where those 3090/4090 cards come into their own :-)

Cheers


Ryzen 5800X clocked to 4.7 Ghz (SMT off), 32 GB ram, Samsung 1 x 1 TB NVMe 970, 2 x 1 TB SSD 850 Pro raided, Asus Tuf 3080Ti

P3D 4.5.14, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Prepar3D

Share this post


Link to post
On 2/11/2023 at 1:50 PM, newtie said:

I'm in one of those 'breakage' moments right now.
Soon as I get that behind me I'm going to try the 1024 texture expression in both V4 and V5 and see what's what. I've tried for what seems like forever to get ORBX textures to stop that annoying texture filling, like it loads a slightly higher res overlay on top of another, often right out the window. I have plenty of horsepower both CPU and GPU so that was sidelined as a cause a good while back. Looking forward to it.

Well, I do believe this has a positive effect on texture filling. KTVL > KSTS with stock Orbx base and KSTS > KRDD with TE and only one or two small fills in each trip. I will continue looking at this but I think it's a winner. Running medium/low settings for this test with 5gb out of 11gb.

Share this post


Link to post

This setting has been around for several years now.  The TEXTURE_SIZE_EXP=10 setting is much noticeable at higher resolutions and larger monitors.  

BTW, this setting REQUIRES the following:

HIGH_RESOLUTION_TERRAIN_TEXTURES=1 in the prepar3d.cfg in order for TEXTURE_SIZE_EXP to work.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...