Jump to content
Sign in to follow this  
williebarry1

FSLabs Control Center Issue

Recommended Posts

I have been having trouble for few the past few days downloading the Airbus Fleet. First the FSL Libraries will start downloading and the bar showing the percentage complete will disappear never finshing. Then since the Airbus A320X is next to download it will start but about 30% do the same thing. I already tried asking FSLabs for support but they keep telling me the servers are working on their end and to turn off my antivirus, but all i have is windows defender and that is turned off. Tried downloading using Wifi , Ethernet and VPN with the same result.How to fix this?

Share this post


Link to post
6 hours ago, cyyzrwy24 said:

Best way to get help is their Forum and someone will help you.

I tried that , but since I open a support ticket the closed my topic.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...