Jump to content
Sign in to follow this  
Brocky120

MSFS Adaptive LOD

Recommended Posts

17 minutes ago, GSalden said:

Exactly. I use DX12 on both my pc’s and with the non-automated version I have no issues.

The old app does set the LODs on the ground but only once when initialising for your flight and again if you change LOD profiles on the ground.

Anyway, interesting feedback everyone. I shall look into it more deeply tomorrow.

  • Like 1

Ryzen 7 5800X3D | Gigabyte RTX 4090 Gaming OC 24GB | 32GB 3200MHz RAM | 2TB + 1TB NVME SSD | 2GB SSD | 2GB HDD | Corsair RM850 PSU | 240mm AIO | Buttkicker Gamer 2 | Thrustmaster T.16000M Flight Pack | 75" 4K60 TV | 40" 4K60 TV | Quest 3 | DOF Reality H3 Motion Platform

MSFS @ 4K Ultra DLSS Performance with 2.0x Secondary Scaling |  VR VDXR Godlike 80Hz SSW OXRTK @ 5200x5200 Custom FFR CAS 50% | MSFS VR Ultra DLSS Performance - Windows 11

Share this post


Link to post
Share on other sites

Are any of you folks experiencing ground texture tearing with DX12 with the new app on the SU15 beta or is this only being seen on SU14?


Ryzen 7 5800X3D | Gigabyte RTX 4090 Gaming OC 24GB | 32GB 3200MHz RAM | 2TB + 1TB NVME SSD | 2GB SSD | 2GB HDD | Corsair RM850 PSU | 240mm AIO | Buttkicker Gamer 2 | Thrustmaster T.16000M Flight Pack | 75" 4K60 TV | 40" 4K60 TV | Quest 3 | DOF Reality H3 Motion Platform

MSFS @ 4K Ultra DLSS Performance with 2.0x Secondary Scaling |  VR VDXR Godlike 80Hz SSW OXRTK @ 5200x5200 Custom FFR CAS 50% | MSFS VR Ultra DLSS Performance - Windows 11

Share this post


Link to post
Share on other sites

I can confirm I am seeing the DX12 texture bug with SU15 beta using the latest version (3.7Reset)

Share this post


Link to post
Share on other sites
17 minutes ago, Divij said:

I can confirm I am seeing the DX12 texture bug with SU15 beta using the latest version (3.7Reset)

Bummer. I was hoping the new memory optimisations might address this.

I tried rounding and using larger and smaller LOD steps but it is still triggerable by LOD changes on the ground. I may just have to disable LOD updates on the ground if DX12 is being used, at least until the underlying age-old issue of tearing textures with DX12 is fixed.


Ryzen 7 5800X3D | Gigabyte RTX 4090 Gaming OC 24GB | 32GB 3200MHz RAM | 2TB + 1TB NVME SSD | 2GB SSD | 2GB HDD | Corsair RM850 PSU | 240mm AIO | Buttkicker Gamer 2 | Thrustmaster T.16000M Flight Pack | 75" 4K60 TV | 40" 4K60 TV | Quest 3 | DOF Reality H3 Motion Platform

MSFS @ 4K Ultra DLSS Performance with 2.0x Secondary Scaling |  VR VDXR Godlike 80Hz SSW OXRTK @ 5200x5200 Custom FFR CAS 50% | MSFS VR Ultra DLSS Performance - Windows 11

Share this post


Link to post
Share on other sites

Sorry to divert slightly, but how does one remove any of these programs?  I recently updated my PC and would like to see how it performs without this.  I actually have the original version by Fragtality still installed, though may well update if I still find a need on the new system once the pace of development slows down a little..

Is it as simple as deleting the folder?  It doesn't seem to appear in the list of programs in windows so I can't uninstall it that way.  As it launches automatically I assume it must have updated a file in MSFS?

Share this post


Link to post
Share on other sites
11 minutes ago, VFRHawk said:

Sorry to divert slightly, but how does one remove any of these programs?  I recently updated my PC and would like to see how it performs without this.  I actually have the original version by Fragtality still installed, though may well update if I still find a need on the new system once the pace of development slows down a little..

Is it as simple as deleting the folder?  It doesn't seem to appear in the list of programs in windows so I can't uninstall it that way.  As it launches automatically I assume it must have updated a file in MSFS?

Just run the installer again and choose the remove or uninstall option in the app. Then all is gone


Regards,

Marcus P.

xaP1VAU.png

Share this post


Link to post
Share on other sites
1 hour ago, Reset XPDR said:

Are any of you folks experiencing ground texture tearing with DX12 with the new app on the SU15 beta or is this only being seen on SU14?

My take on the «broken ground textures” issue:

I only very rarely saw it before SU15 beta. After installing the beta, it happened at nearly every airport. I was using dynLOD. Haven’t had the chance to test autoLOD yet. 

Not sure if this helps, just my observations.

  • Like 1

i9-12900KF @ 5.1GHz | MSI Trio Gaming X RTX4090 | MSI MPG Z690 Carbon EK X | G.Skill Trident Z5 32GB DDR5 | WD Black SN850 2TB SSD | Samsung 970 EVO Plus 500GB SSD | 2x Samsung 960 EVO 500GB SSDs | Hela 850R Platinum PCIe 5.0 w/ 12VHPWR cable | Corsair RM750X | LG 77" OLED 3840x2160 | Thrustmaster HOTAS Warthog | MFG Crosswind pedals | Thrustmaster TCA Captain Pack X Airbus Edition

“Intensify the forward batteries. I don’t want anything to get through”

Share this post


Link to post
Share on other sites
8 hours ago, Stona said:

This AutoFPS is exactly what is needed in this sim so well done sir for tackling this.

I noticed that it wasn't automatically raising the TLOD and I think I know why!

I use Vsync at 50fps so in the app I've set my Target FPS to 50 

Therefor if I have the FPS tollerance set to say 10%, I think that means the app is looking for a sim FPS of 55fps before it start raising the TLOD but it will never reach that 55 fps because I have Vsync turned on to lock at 50fps

I proved this theory by setting my Target FPS at 45 and then the app  worked, raising the TLOD as my FPS reached the Vsync rate of 50 fps

 

THE SOLUTION

The FPS Tollerance should only be used to determine if the App should decrease the TLOD once the fps reaches the lower FPS tolerance level.  Once the App sees the Target FPS value it should then start raising the TLOD

Hope that makes sence!

Edit:
I wonder if there should also be a time millisecond threash hold before it starts dropping the TLOD to allow for the new TLOD fps to settle. My system can take a second for the fps to settle after a 5 step or if I pan left or right 

That wouldn't really be a solution. That would mean that the TLOD would be increased up to the upper limit whenever your FPS limit (by VSync) is reached no matter how much headroom is left. So even when your FPS are still stable but just about to drop when approaching a large addon airport the tool would still increase the TLOD. That will inevitably lead to a massiv stutter when your headroom is used up shortly after. The tool will then try to counteract by reducing TLOD but your FPS will have dropped below your VSync limit already so you will see lots of stutters while the tool is decreasing TLOD again. And as soon as you can reach your FPS limit again, the tool will start to increase TLOD again, inevitably calling for the next stutters when your headroom is used up again.

As far as I can see this new version of this tool is unusable for those who limit their FPS by using VSync (or an external tool). It will only lead to more stutters than without using the tool. The new version of this tool only makes sense for those with a GSync monitor who don't need to have a fixed framerate for a stutter-free experience.

So hopefully the previous version (with the AGL- dependant TLOD tables) will still be supported and developed as well. Or - ideally - the developer finds a way to adjust TLOD before the FPS (when limited by VSync) drop - by assessing the remaining CPU/GPU headroom instead of the FPS.

 

 

Edited by RALF9636
  • Upvote 2

Share this post


Link to post
Share on other sites
3 hours ago, mpo910 said:

Just run the installer again and choose the remove or uninstall option in the app. Then all is gone

Thanks, that sorted it.

Share this post


Link to post
Share on other sites

Generally I think this autoLOD version makes a lot of sense. Just testing it a bit more with the Fenix and no issues so far. Since I've got ample GPU headroom, I don't worry about cloud detail. For now I've set target FPS to 30 which corresponds to frame generation FPS of 60. 


i9-12900KF @ 5.1GHz | MSI Trio Gaming X RTX4090 | MSI MPG Z690 Carbon EK X | G.Skill Trident Z5 32GB DDR5 | WD Black SN850 2TB SSD | Samsung 970 EVO Plus 500GB SSD | 2x Samsung 960 EVO 500GB SSDs | Hela 850R Platinum PCIe 5.0 w/ 12VHPWR cable | Corsair RM750X | LG 77" OLED 3840x2160 | Thrustmaster HOTAS Warthog | MFG Crosswind pedals | Thrustmaster TCA Captain Pack X Airbus Edition

“Intensify the forward batteries. I don’t want anything to get through”

Share this post


Link to post
Share on other sites

I've been using the original since it's release so I thought I'd update to the latest verson. However Chrome won't let me download saying 'virus detected' even after bypassing the usual suspicious code keep/discard shenanigans.

Share this post


Link to post
Share on other sites
19 minutes ago, mobeans10 said:

I've been using the original since it's release so I thought I'd update to the latest verson. However Chrome won't let me download saying 'virus detected' even after bypassing the usual suspicious code keep/discard shenanigans.

Got the same issue. I had to create an exlusion in my AV software. I did eventually get Chrome to download it though. 


i9-12900KF @ 5.1GHz | MSI Trio Gaming X RTX4090 | MSI MPG Z690 Carbon EK X | G.Skill Trident Z5 32GB DDR5 | WD Black SN850 2TB SSD | Samsung 970 EVO Plus 500GB SSD | 2x Samsung 960 EVO 500GB SSDs | Hela 850R Platinum PCIe 5.0 w/ 12VHPWR cable | Corsair RM750X | LG 77" OLED 3840x2160 | Thrustmaster HOTAS Warthog | MFG Crosswind pedals | Thrustmaster TCA Captain Pack X Airbus Edition

“Intensify the forward batteries. I don’t want anything to get through”

Share this post


Link to post
Share on other sites
1 hour ago, mobeans10 said:

I've been using the original since it's release so I thought I'd update to the latest verson. However Chrome won't let me download saying 'virus detected' even after bypassing the usual suspicious code keep/discard shenanigans.

Both Chrome and windows flag this. He is aware.

Go up to the downloads icon on Chrome and click it. Click the file. Finally click 'allow download' and it will work.

Edited by Flyfaster_MTN002

SAR Pilot. Flight Sim'ing since the beginning.

Share this post


Link to post
Share on other sites

Wait  - is there a new app ?

 

Maybe a new thread ?

 

I use VSYNC@25HZ/FPS . Should i stick with  0.3.7?

 

Thanks

Michael Moe


Michael Moe

 

fs2crew_747_banner1.png

Banner_FS2Crew_Emergency.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...