Jump to content
Sign in to follow this  
Excelsis

CJ4 banking l/r violently on approach

Recommended Posts

Hi. I love the MSFS CJ4 but why does it veer/bank violently left to right on approach trying to find the LOC on an ILS landing? I'm following the guidelines, tuning is fine, the LOC1 is PRESET and the LOC diamond moves to the centre of the PFD but the moment I hit that APP button on final it goes completely crazy and banks all over the place and only stabilises when I'm about 5m from TD. Am I hitting APP too early? Should I wait until just before FF? Any advice gratefully received!

Share this post


Link to post
Share on other sites

You are now in the correct forum for your questions!


Charlie Aron

AVSIM Board of Directors-Moderator-Registrar

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites

I haven't had the issue you are describing.  One thing I would recommend is to not select APP mode late.  I usually select APP mode prior to or just after the IAF.

The FMS will switch to the localizer automatically and even pre-tune it if you have the proper approach and transition loaded.  The CJ4 will usually capture the LOC and eventually the GS very smoothly unless there's a lot of turbulence or buffeting crosswind present.


Randall Rocke

Share this post


Link to post
Share on other sites
2 hours ago, Excelsis said:

Hi. I love the MSFS CJ4 but why does it veer/bank violently left to right on approach trying to find the LOC on an ILS landing? I'm following the guidelines, tuning is fine, the LOC1 is PRESET and the LOC diamond moves to the centre of the PFD but the moment I hit that APP button on final it goes completely crazy and banks all over the place and only stabilises when I'm about 5m from TD. Am I hitting APP too early? Should I wait until just before FF? Any advice gratefully received!

Yes. Any mods? Try Longitude and see if same behavior?


SAR Pilot. Flight Sim'ing since the beginning.

Share this post


Link to post
Share on other sites

Thanks for the replies. Solved it now, I was panicking about the whole NAV/APP sequence. All I had to do was follow LNAV with FMS activated in the PFD as normal and then when the 'ghost' LOC1 indicator (dotted blue arrow) appeared in the PFD I just pressed APP and APPLOC1 and GS became armed (white). I continued on LNAV until final and it switched automatically to LOC1 (green) and ultimately caught the GS. Didn't have to activate the NAV button with the up and down arrows at all. There was a bit of swaying while it latched on to the LOC  but nothing too frightening and certainly not like I had before!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...