Jump to content
Sign in to follow this  
Ray Proudfoot

[Resolved] Second blank P3D window opening.

Recommended Posts

P3D v5.3HF2. I have GoFlight hardware so use Pollypot GIT to use it with P3D. I also have SimStarterNG to launch several executables to make life easier. One is GIT.

GIT doesn't launch until P3D is running and stable. When it does the program connects via SimConnect and all is well.

But then something odd happens. A second P3D window opens but is blank and in the title bar says "Not Responding".

Even after closing P3D and then SimStarterNG closes those executables including GIT this window remains open.

The program is named ConsoleWindowHost and is 1 of 6 applications linked to P3D. The others are ActiveSkyUTils, Couatl, P3D to module data bridge, SODE, and Prepar3D.

. It appears to be launched soon after GIT is launched but there are no settings in GIT for this. But it's only started happening after I installed a different version of GIT.

Anyone got a clue how to prevent this please? It's not doing any harm but I don't see why it's running.


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke, Fulcrum TQ (pre-production).
Cheadle Hulme Weather

Share this post


Link to post

If I start P3D manually and then start GIT manually this second blank window pops up. So it’s definitely related to GIT. But searching through their website reveals nothing to help.

I would post the question there but the author hasn’t been around since before Christmas. Slightly concerning. I’m hoping @Steve1969 will visit here soon and alleviate my concerns.


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke, Fulcrum TQ (pre-production).
Cheadle Hulme Weather

Share this post


Link to post

This problem has been resolved by updating to the latest version of GIT. It must have been a parameter set in the compiled executable to call the program that displays that window.

Phew!


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke, Fulcrum TQ (pre-production).
Cheadle Hulme Weather

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...