Jump to content
Sign in to follow this  
goofeyfoot

Using “Travel To” Results in Unusual ATC Behavior

Recommended Posts

When I use the Travel  To command, I get unusual results. If I Travel To the Descent, I’m typically off course quite a bit. But then the ATC gives me a vector that takes me even further off course than I already was. Seems like the ATC should do something to place you back on the original course or something like that, I’m not a real pilot so I don’t know for sure. 

Share this post


Link to post
Share on other sites
On 4/11/2024 at 12:09 PM, goofeyfoot said:

When I use the Travel  To command, I get unusual results. If I Travel To the Descent, I’m typically off course quite a bit. But then the ATC gives me a vector that takes me even further off course than I already was. Seems like the ATC should do something to place you back on the original course or something like that, I’m not a real pilot so I don’t know for sure. 

Maybe ATC is trying to get you back to the last waypoint that was on your path before the Travel To? Try requesting a Direct To the new next waypoint based on where you end up after the Travel To.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...