Sign in to follow this  
Guest

SP2-Full Screen Menus - FSX crashes - My Fix

Recommended Posts

This may be a duplicate but.....FSX/SP2 consistently fails when in full screen mode and you access the menus. Seems to be related to nVidia video. After lots of "messing around" I sent a trouble report to Microsoft. While awaiting an answer I read some of the troubleshooting tips. One of the obvious ones was to:Use MSCONFIG (run msconfig)Disable all Startup ProgramsHide all Microsoft ServicesDisable all remaining servicesRebootWell it worked!!! I can now access the FSX menus with no issues. I did restart my firewall.I think that there is also a performance increase but that may be a placebo effect. So, for now I am happy with SP2 since it has given me noticeable FPS improvement (close to 20%) and reduced my FSX load times. I am sure that others will have different results given the probably million -plus permutations possible in the PC environment.Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

After further testing (messing around) I found the culprit - FRAPS. I have been using Fraps without problems since I found it several years ago. Now it turns out to cause an FSX full screen problem. I assumed that the common denominator was nVidia. That led to hours rebooting and configuring without results. Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites

I also have fraps running at all times. Good find, I will test this on my system. if FRAPS is indeed the cause that might help nvidia nail down the driver issue.

Share this post


Link to post
Share on other sites

I have an Nvidia 8800 GTS. I had no CTDs with FSX - SP1. However I'm noting more menu CTDs since SP2 when in unlimited frames mode as opposed to limiting the fps. Would that be related?Lee

Share this post


Link to post
Share on other sites

The only problem I have had has been when you open a pulldown menu while your are in full screen mode. If your problems are somewhat frequent I suggest that you become familiar with MSCONFIG using the Run command under your Start button (lower left). MSCONFIG has a Program tab and a Services Tab. You should be able to safely use the Program tab to disable all of the programs it lists (there is a disable all button). Similarly under Services tab Hide all of the Microsoft services (one button) and the Disable all the services that remain. This gives you a pristine setting without all of the baggage Windows needs for the many functions that have no use in FSX.Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites

What I don't understand here and I could be wrong but wasn't/isn't FSX supposed to run better in windowed mode then in full screen?I thought i'd read that someplace but really dont remember.

Share this post


Link to post
Share on other sites

Can anyone direct me in the right direction here. I can't fly in the full screen mode. The screen flashes on and off every second. In the window mode with the pull down menu, I get unbelieveable performance, so I do not make a big issue of it. What is this all about? I have a Dell Quad Core 3.5 GHTZ, Vista, FSX, SP2, dual 768 8800 GTX cards with dual 24" monitors.Any solution why I can't go to full screen?

Share this post


Link to post
Share on other sites

On my system they are about equal. However, I have seen significant differences but probably while trying tweaks. Given the thousands of permutations in systems and settings everyone has had some variation of experiences. The short of it is, that without a gold standard no one really knows what to expect.>What I don't understand here and I could be wrong but>wasn't/isn't FSX supposed to run better in windowed mode then>in full screen?>I thought i'd read that someplace but really dont remember.>Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites

Before i had a widescreen TFT, i also used 2 monitors, but i had only one graphics card and i couldn't use the fullscreen mode, because of the flashes you are describing. If i remember it correctly, it would work, if you disable AA. But that's no usable solution...

Share this post


Link to post
Share on other sites

What worked for me was to download the new 169.21 drivers from Nvidia. They are not the beta version anymore and Whol. certified.This is for XP users only with Nvidia GeForce cards. Bob G.

Share this post


Link to post
Share on other sites

i wonder if anybody can confirm that the 169.21 WHQL driver solves the menu-crash issue with SP2??Cheers,Michael

Share this post


Link to post
Share on other sites

I've got the 169.09 drivers. I'll try the .21 with FRAPS running when I get home.

Share this post


Link to post
Share on other sites

SP2 on XP/DX9 working fine for me using 169.21 driver and 8800GTX.I waited for positive news about this driver release before installing SP2.Regards,Rich

Share this post


Link to post
Share on other sites

Running Acceleration, XP, & DX9 with my 8600GT and menu crashes are now gone in full screen mode with this new driver.

Share this post


Link to post
Share on other sites

Running XP SP2 Gainward Bliss++ 7800X512 and still getting menu lock-ups under FSX Accel on drivers 169.21 unless in windowed mode. (fresh install)

Share this post


Link to post
Share on other sites

This driver did NOT fix the menu crash on my system while fraps is running. So the only fix I have yet to find is to disable fraps, which works on the .09 driver too.

Share this post


Link to post
Share on other sites

I have the same sort of problem. If I try to access options / settings then my system hard locks and hard drive goes mad. And If I try to enter windowed mode the exact thing happens. Everything else is fine. The problem is I can't fix it, have tried everything, clean install etc. Could this be related to your problems?

Share this post


Link to post
Share on other sites

Yeah mine hard locks too, requiring the power button to be held for 4 seconds.

Share this post


Link to post
Share on other sites

Yeh exactly, which can't be any good for a hard drive that is going crazy at the time of switching off.

Share this post


Link to post
Share on other sites

Hi Nudata, you may want to past this in the nVidia forums. The developers probably keep an eye on them and your investigations may help them with the fix. From what I've been reading everywhere the consensus seems to be this is an nVidia driver problem. It only affects some of us and problems like this are a #### to debug so your info may go some way to help.The work-around you suggested is worth knowing but possibly not a good idea for the less computer literate as they may disable their anti-virus or anti-spyware software without realising it. It's probabyl worth going without FSAcceleration and waiting for a fix rather than open your system up to attack!! Just a thought.Happy New Year all,Ian

Share this post


Link to post
Share on other sites

On my computer after installing SP2 I had the same problem. After several uinstalls and reinstalls I also have the problem with FSX without the service packs. And my computer not only crashes when I access the menus while inflight, but also while flying without doing anything. It suddenly stutters a few seconds and after the blue screen it restarts. Installing the new Nvidia drivers did not help.

Share this post


Link to post
Share on other sites

>I have the same sort of problem. If I try to access options />settings then my system hard locks and hard drive goes mad.>And If I try to enter windowed mode the exact thing happens.>Everything else is fine. The problem is I can't fix it, have>tried everything, clean install etc. Could this be related to>your problems?For some reason I assumed that if trying to enter windowed mode via the menu screen and suffering a system crash, then alt / enter would produce the same result. However, hitting alt / enter works perfectly. I can access the settings via the free flight window and that also works fine. Its not a fix but more a workaround.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this