Sign in to follow this  
bob.bernstein

FS2004 SDK - Somebody stole my light bulbs (Scenery)

Recommended Posts

Has anyone else experienced files generated with the new FS2004 MakeMdl killing night textues that were functioning before? I recompiled a project into the new MakeMdl to add the new airport beacon and lost the night lighting on the helicopter pad and the lawn. Part of the project is still compiled in the previous version of MakeMdl and the night lighting there still funtions correctly. BTW, all the textures are either DXT-1 or DXT-3. Thanks,Al

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you defined the nigt textures in the material editor or did you use the option on the MakeMDL screen in Fs2002?

Share this post


Link to post
Share on other sites

Hi Arno,I posted a message up on your site, reference this, but will throw it out here as well. I am running FS2004 and designing to that program. When the 'lights went out' on the LM textures I tried about everything. A work-around was found but I am not happy with it (though it works perfectly).It appears that the new MakeMDL with the new FS2004 SDK ignores the fact that a daytime texture has an nighttime version (LM) of the same name. If I take the same exact LM texture and change the name of it to a daytime type name (i.e. 'AH9_HairbrainIdea.bmp') and enter that name into the ambient slot of the Materials Controller (Maps), it works perfectly. I have two problems with this. 1) Am I the only one that has this problem (running 2004 on Win XP)?2) If I am not the only one with this problem, is there a fix forthcoming or are we changing the sheme of using LM as an indicator of NightMap textures? The work-around is simple enough, except that keeping the inventory of texture files for public release has now become a groaner. Al

Share this post


Link to post
Share on other sites

Probably you used the option on MakeMDL in Fs2002 that instructed FS that night textures were there. Then it automatically used the _LM variant. In the new MakeMDL you can no longer activate this option (as you don't get the options screen anymore), so to get night textures you must now define them in the material editor as you found out. Of course you could still use the _LM name there.

Share this post


Link to post
Share on other sites

Hello Arno,I have not tried it, but is it not possible to choose the options in MakeMDL before exporting? That is, launch MakeMDL, select the desired options, and exit MakeMDL. Then, export from GMax as usual.As I say, I have not yet attempted this, so it could be useless as a solution.Best regards.Luis

Share this post


Link to post
Share on other sites

I don't understand the problem...you need to have the same number of textures as always, you just assign them in a different place...why is this a bother?Bob B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this