Sign in to follow this  
Guest ScottR

TerraBuilder Scenery Issues

Recommended Posts

I read the TerraBuilder Release Notes and have been working on the Microsoft Niagara Falls example, it gives me the following error. I am learning a lot about TerraBuilder and the various steps to creating a phototexture and then using it in Flight Simulator 2002 Pro. Misho's (TerraBuilder) Release Notes show the easiest way to accomplish this. I am almost figuring this out, but need help with figuring the following error out as below. I did reduce the pixels to 766, and it still did the same.How do I convert to 4.8 meters/pixel?Scenery Issues:Problem:Horizontal scale of the scenery is not 4.8 meters/pixel as required by Terrain SDK.Microsoft's Terrain SDK tool Resample.exe will stretch the image pixels but it will do so by simply multiplying pixel size.Image editing software can do a much better job of resizing, by approximating (interpolating) neighbouring pixels.Suggestion:Exit the Project. Load the source imagery into an Image Editing software such as Adobe PhotoShop or Paint Shop PROMake sure that the resizing method is NOT:PhotoShop: "nearest neighbour"Paint Shop PRO: "pixel resize"Resize the horizontal size of the imagery from the current 767 pixels to 766 pixelsReload the project. The position and the extents of the scenery will remain the same. The horizontal scenery scale should now be 4.8 m/pixelProblem:Bottom edge of the image will be discarded.Suggestion:Exit the project and edit the image.Problem:Left edge of the image will be discarded.Suggestion:Exit the project and edit the image.Problem:Top edge of the image will be discarded.Suggestion:Exit the project and edit the image.Problem:Right edge of the image will be discarded.Suggestion:Exit the project and edit the image. 5 unresolved issues.:-)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Ignore this message. TerraBuilder is just being too picky, suggesting to reduce image by one pixel. Leave it as it is.Ignore all other messages about the edges. TerraBuilder is only warning you that your image crosses LOD grid, and any parts of the image that are not filling the grid will be discarded.

Share this post


Link to post
Share on other sites

Hi there. I'm having the same problem. I received the same error message, however, no files are produced in the folders once they are created.I know it says to wait a while, but I'm using a 2ghz machine, and I don't think it would take that long.Also - running WinXP Pro (MC ed), and attempting to use with MSFS 4k.Am I simply not waiting long enough for the files to be created? If I have a bad install of one of the other programs, how can I tell? Or would I simply not be getting my "scenery issues" at all if there was something incorrectly installed?thanks in advance!!

Share this post


Link to post
Share on other sites

If I have a big bitmap (say 4000 x 6000 pixels) even my 2.2 Ghz pc can take 5-10 minutes to produce all the texture files just for the summer season. I think Misho suggested it in the notes somewhere, but the best thing to do is open the folder where the texture files are to be produced in Windows explorer (don't shutdown TB), note the number of texture files then hit the "refresh" button every 30 seconds or so and see if the file number increases. Once it stops changing, then processing is finished.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this