• Imaginesim KLGA NEW YORK LAGUARDIA P3D V4


    Chuck_Jodry-VJPL

    Just released is imaginesim's new version of KLGA NY LaGuardia for Prepar3D V4. It has vastly improved performance, the result of a complete model optimization and recompile. Among a host of improvements you will find,

    - Big improvement in performance using procedures optimized for Prepar3D V4.

    - Framerate speeds up by over a third compared with previous Prepar3D version. Nearly double when compared to FSX version.

    - High definition building texturing and improved new V4 ground polygons.

    - Fluid usage, even with complex airliner cockpits and high density AI coverage.

    - Low visibility nav lighting.

    - Switchable dynamic lighting option.

    - New and bespoke Operations Center configuration GUI.

    - Comprehensive ground and building optimization.

    - Interactive SODE jetways.

    - Instantaneous scenery cache loading.

    - Seasonal texture options.

    - Low simulator impact.

    - Graduated ground extremeties to seamlessly blend with any vector driven add-on.

    - Free to all existing KLGA 2016 Prepar3D and FSX customers. Your new V4 version will appear in your Flightsim Store account (click your existing Prepar3D V4 download link to obtain the new file), or inside the Flight 1 wrapper downloaded from the imaginesim  website (click the re-install button after downloading).




    User Feedback


    Hi Chuck,

    Thanks for the update - I thought it was already v4 compatible - I'll keep an eye out for the update... Much appreciated...

    Regards,
    Scott

    Share this comment


    Link to comment
    Share on other sites

    Just downloaded the update. Runs extremely smooth compared to previous version. Make sure to back your water detail off if set to ultra to high or you'll have water on the surface. 

    Share this comment


    Link to comment
    Share on other sites
    2 hours ago, DaveS said:

    Just downloaded the update. Runs extremely smooth compared to previous version. Make sure to back your water detail off if set to ultra to high or you'll have water on the surface. 

    I hope so. I installed their new Atlanta version and I still get bad performance.

    Share this comment


    Link to comment
    Share on other sites

    Both the updated version of KLGA and KATL run great. The improvements are very nice and bring new life back to the scenery.

    Share this comment


    Link to comment
    Share on other sites
    5 hours ago, scottb613 said:

    Thanks for the update - I thought it was already v4 compatible - I'll keep an eye out for the update... Much appreciated...

    Compatible, yes, but not optimized for P3Dv4.  Use of v4-specific ground polys, materials better suited for dynamic lighting etc can really improve performance even where it functioned in v4 before.  The difference in KATL was pretty significant; I suspect this one will be a noticeable improvement too.

    Cheers

    Bob Scott

    Share this comment


    Link to comment
    Share on other sites
    18 minutes ago, w6kd said:

    Compatible, yes, but not optimized for P3Dv4.  Use of v4-specific ground polys, materials better suited for dynamic lighting etc can really improve performance even where it functioned in v4 before.  The difference in KATL was pretty significant; I suspect this one will be a noticeable improvement too.

    Cheers

    Bob Scott

    Hi Bob,

    Thanks for the input !!!

    :wink:

    I'll see if I can get it loaded tonight...

    Regards,
    Scott

    Share this comment


    Link to comment
    Share on other sites

    Neither of these (KATL and KLGA) were showing up in my Add-On's list.  During Install I select path D:\Imagine Simulation.

    I see the entries in Add-on.cfg, 

    [Package.0]
    PATH=D:\Imagine Simulation\KATL Atlanta P3Dv4\
    TITLE=Imagine Simulation KATL3_PD4
    ACTIVE=true
    REQUIRED=false
    [Package.1]
    PATH=D:\Imagine Simulation\KLGA LaGuardia P3Dv4\
    TITLE=Imagine Simulation KLGA2_PD4
    ACTIVE=true
    REQUIRED=false

    But they seem to be missing their representative folder under C:\Users\Rob\Documents\Prepar3D v4 Add-ons   ... also the add-on.xml's are not representing their actual install location, they are relative locations?

    I was able to solve the problem by setting up folders under C:\Users\Rob\Documents\Prepar3D v4 Add-ons and copy the add-on.xml files over to these folders and then change the path parameter in the add-on.xml to point to the install location.

    Unfortunately I can't seem to solve this issue (tried everything I know):

    Cheers, Rob.

    Share this comment


    Link to comment
    Share on other sites
    14 minutes ago, Rob Ainscough said:

    Neither of these (KATL and KLGA) were showing up in my Add-On's list.  During Install I select path D:\Imagine Simulation.

    I see the entries in Add-on.cfg, 

    [Package.0]
    PATH=D:\Imagine Simulation\KATL Atlanta P3Dv4\
    TITLE=Imagine Simulation KATL3_PD4
    ACTIVE=true
    REQUIRED=false
    [Package.1]
    PATH=D:\Imagine Simulation\KLGA LaGuardia P3Dv4\
    TITLE=Imagine Simulation KLGA2_PD4
    ACTIVE=true
    REQUIRED=false

    But they seem to be missing their representative folder under C:\Users\Rob\Documents\Prepar3D v4 Add-ons   ... also the add-on.xml's are not representing their actual install location, they are relative locations?

    I was able to solve the problem by setting up folders under C:\Users\Rob\Documents\Prepar3D v4 Add-ons and copy the add-on.xml files over to these folders and then change the path parameter in the add-on.xml to point to the install location.

    Unfortunately I can't seem to solve this issue (tried everything I know):

    Cheers, Rob.

    Turn your water from Ultra to High.

    Share this comment


    Link to comment
    Share on other sites
    1 hour ago, Brian_A_Neuman said:

    Turn your water from Ultra to High.

    I read about, but unfortunately that changes still results in the same issue.

    Cheers, Rob.

    Share this comment


    Link to comment
    Share on other sites

    This may be an elevation problem as I have the same type problem as Rob for KLGA when the default, add-on or payware of KLAG is installed. It seems to be rare and I have not been able to find a cure yet, so holding off on this Imaginesim version hoping Rob finds a cure. I have seen elevation problems corrected in the forums for other airports, but not for KLAG. Orbx is neither on my PC nor any other add-on land class, just default FSX.

    Share this comment


    Link to comment
    Share on other sites

    Hi Folks,

    Loaded this up - are there seasonal textures ? All I see is grass while the surrounding terrain is all snow...

    Thanks...

    Regards,

    Scott

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, scottb613 said:

    Loaded this up - are there seasonal textures ?

    Yes, the scenery configuration tool should have come up during install ... looks very similar to the 29Palms configuration tool so I'm guessing the configuration tool aspect is from the same developer (should be black background with orange checkbox items including seasons option).  If you have the older white background and green X box then that's the older version not the newer version of KLGA.

    14 hours ago, Brian_A_Neuman said:

    you have Orbx vector, did you check AEC?

    Yes, AEC tool doesn't correct the problem.

    4 hours ago, bytes said:

    so holding off on this Imaginesim version hoping Rob finds a cure

    So far I've not found a cure, ran a search on *KLGA*.* and found two files, set them to .OFF unfortunately still the same issue.

    Also tried changing the layer value (default was 2) which would effectively place it at the almost the lowest priority ... not sure I understand ImagineSim thought behind that?  Anyway, tried other layer values and nothing has worked.

     I didn't have DD NY installed, I have Orbx FTX Global, OpenLC NA, Vector and PILOT's Mesh ... tried PILOT's AFM tool to flatten KLGA but that didn't solve the issue either.  In a final last ditch attempt I tried using the old school add to scenery library method AND set water to "High" and that partially solved some of the issues, but I still ended up with Boats in the middle of runways:

    However, boats in the middle of runways and not being able to use Water = Ultra is too much of a "blind eye" for me to accept.

    Just to make sure there isn't some "inherent" problem with my Sim, I installed DD's New York and New York Airports that has KLGA ... there were no issues with DD's KLGA.  

    I prefer Imagine Sim's version ofKLGA, but it does appear there is something not right about their elevation BGL.  So for now I'll stick with DD KLGA and hope Imagine Sim address the issue ... does seem odd since Imagine Sim suggested native P3D V4 compile and even a separate installer for P3D V4.

    Cheers, Rob.

    Share this comment


    Link to comment
    Share on other sites

    If that’s the case then why wouldn’t an interfering BGL also interfere with DD’s KLGA?  I installed DD’s KGLA after installing Imagin Sim’s version.

    definitely still a mystery but Combine this issue with the installer not installing the Add-On process correctly (I had to do it manually and make adjustments) ... my hunch is there is an installer issue, perhaps missing a BGL or two?

    Cheers, Rob

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!


    Register a new account

    Sign in

    Already have an account? Sign in here.


    Sign In Now