peja4791

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

Profile Information

  • Gender
    Male

Flight Sim Profile

  • Commercial Member
    No
  • Online Flight Organization Membership
    none
  • Virtual Airlines
    No

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have a couple of apps that I run with P3D 4.1 and I cannot upgrade to 4.2 since it will cause a CTD... I accidentally upgraded to PTA 2.61 and now I get errors when trying to apply a preset since I run P3D 4.1 not 4.2... A link to download PTA 2.60 would be nice! Previous versions should be on the website in case something like this happens
  2. I have a couple of apps that I run with P3D 4.1 and I cannot upgrade to 4.2... I accidentally upgraded to PTA 2.61 and now I get errors when trying to apply a preset since I run P3D 4.1 not 4.2... A link to download PTA 2.60 would be nice! Previous versions should be on the website in case something like this happens
  3. peja4791

    Need PTA 2.60

    I need PTA 2.60 as well I have a couple of apps that I run with P3D 4.1 and I cannot upgrade to 4.2... I accidentally upgraded to PTA 2.61 and now I get errors when trying to apply a preset since I run P3D 4.1 not 4.2... A link to download PTA 2.60 would be nice! Previous versions should be on the website in case something like this happens