Sign in to follow this  
Guest Ian_Riddell

Elec Hydraulic Pump Problems

Recommended Posts

Firstly, PMDG team, thanks for fixing up the EICAS Hydraulic Indications when using the Elec Hydraulic pumps (with SU1)... and all the other stuff, including the FPV :-)Just one more problem with the Elec Hyd Pumps... They don't appear to be doing anything other than providing pressure indications. E.g. On the ground with the engines switched off and the Elec Hydraulic pumps ON, powered by either External Power or APU Gen Power, I can't get the flaps to move. It might annoy the cargo loaders if I had to start up the engines just to inspect the flaps (say, after a birdstrike). BTW, I hear that the new Gibralta scenery adds circling seagulls, so you never know when you might need to inspect the engines and flaps for damage). ;-)At the moment, I can't recall which position the EDP switches were in (For my sake, I hope they were in the ON position.... I've just read it's better for the hydraulic system if you leave the Engine Hyd Pump switches on at all times, even if the aircraft is not powered.... something to do with not wearing out the depressurization solenoid).Don't know how hard this would be to fix????Thanks.Cheers.Ian.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this