Sign in to follow this  
Guest gasebah

Stutter in Windows 2000 FS2k2

Recommended Posts

Greetings,After reading a few post about the benifits of the Windows 2000 OS I decided to take the plunge. After the upgrade (from Win 98), everything seemed to run fine except for one, very annoying problem, the dreaded stutter in FS2002. This one is different than FS2000. The frame rates stay constant (locked at 18) but every few seconds the display seems to "jump forward" several frames, very annoying especially when landing. I have monitored the frame rates and there is no drop that I can see.I have tried everything that I can think of including:Windows 2000 service pack 2Video drivers 28.32, 29.42, 30.30, and omegaDirectX 8.1bSetting the swap file to a constant valueBumping up the priority of FS2002 in task managerWindows 2000 as an upgrade and as a clean installTurning on and off all hardware options in FS2002Different refresh rates on the monitorChanging settings on the vid card (AA, fog table)Formatting the hard drive and reinstalling Windows 2000 and FS2k2I am at a loss, and to add insult to injury the two NON-microsoft flight sims (FLYII and x-plane) run fine in Windows 2000. Go figure.I formatted and put Win98 back on and and FS2K2 runs with no problems.On the bright side I have become an accomplished hard drive "reformatter". If anyone has any ideas I would be most greatful!!!Jeff FrancisPIII 850512 RAMVetro Gforece 4 TI 4600 (128)Run all apps on a second physical drive (20 Gig with 5 Gig free)CH flighSim yoke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had the same exact problem in FS2K2 when I upgraded to Win2K Pro. My solution? I'm guessing you did the standard install which uses ACPI and everything shares IRQ 9 (check to make sure). That's what I did. ACPI effectively "overrides" any of your carefully placed cards for IRQ assignments and puts everything on this single IRQ. wThis is supposed to work fine, but I have a SCSI U160 controller (Adaptec 19160), and graphics card (Ti4400), and a sound card (TB Santa Cruz) all of which don't like to share IRQs. So, I re-took the plunge and re-installed Win2K Pro. The trick is to press F5 when the install screen says to press F6 for SCSI/RAID/IDE controllers. A screen will eventually appear which asks for the type of OS install...select "Standard PC" instead of ACPI. Go back through the install process and this will once again give you control over your IRQ assignments just like Win98SE...with no observed repercussions.First thing I did was run FS2K2 and VOILA! No More "Jump-Ahead" Stutters!!!Let me know how it works.Gino

Share this post


Link to post
Share on other sites

After my first reinstall (virus) I found the best set up, at least for me, was to NOT install any service packs, security updates, or anything other than DirectX. This keeps my win2k happest for any graphic intensive programs.

Share this post


Link to post
Share on other sites

Gino,Thanks so much for your reply! One question, does re-installing and selecting the option that you pointed out automatically take care of seperating the IRQ's or do you have to do it manually after the installation?Thanks once again,Jeff

Share this post


Link to post
Share on other sites

(sorry...been out of town)It will automatically assign IRQs based on your BIOS settings (PnP OS option enabled lets Windows assign...disabled allows BIOS to assign)In fact...you can install OVER your current istallation with no problems - only the IRQ assignments will have changed, nothing else. I found instructions on Turtle Beach's web site...do a search on IRQ sharing or something like that and you should find it in their archives. This will make it a MUCH faster reload as you can run setup.exe right off the win2K cd instead of using the 4 floppy's.Best of luck to ya,Gino

Share this post


Link to post
Share on other sites

Hi Gino,I have exactly the same problem with WinXp which was also installed as ACPI. But there is now way I can reformat my HD at this time. Would take me weeks to get bakc to the point where I am now.Is there any way to get tha machine working as Standard PC without a reinstall? Can I just edit the registry or somethign like that?Alex

Share this post


Link to post
Share on other sites

Yes...(see my above post)...just run the setup.exe from the Win2KCD and install OVER existing install (make sure you hit F5 at the right time...when the "press F6" message displays. If you need to install RAID or SCSI drivers, then press F5 then F6 quickly). Nothing will change over your existing install except that your IRQ's will be assigned individually per your motherboard.

Share this post


Link to post
Share on other sites

Well I found another way, at least in XP. In the device manager goto Computer/ACPI Computer. Choose update driver; choose Standard Computer and restart. The only problem is that my grphics adaptor shares its IRQ with the onboard USB host controller. No way to change this in BIOS, right?:-(Alex

Share this post


Link to post
Share on other sites

I'm not an XP expert, but you may still want to install OVER the old install per my direction. It is during the setup of Windows that all IRQ's are assigned and maybe the way you chose to do it, the IRQ's may still be sharing. If your way truly does work, than the AGP and USB on your motherboard must share IRQ's automatically...no way to change it (that I know of).

Share this post


Link to post
Share on other sites

Well I guess my way works. After the restart all hardware was freshly installed, and I have the option to change IRQs in the device manager now. All ACPI buttons are gone, and the standby-mode is no longer available from the shutdown menue. I guess these are all good signs that my way actually works. So I guess I have to live with the situation.:-(Alex

Share this post


Link to post
Share on other sites

Odd - I installed Win 2000 with the standard settings (i.e. no F5 and subsequent adapter selection), but my FS is running perfectly smoothly. My system (core components) looks like this: Athlon 1400 on ASUS A7V-133 with WDC WD1000BB 100 gig 7,200 rpm HD on Promise ATA100 controller and ASUS V8200 GF3 Ti 200 64 meg AGP.

Share this post


Link to post
Share on other sites

Gino,Tried your advice last night, worked like a charm, no more stutters.Thanks once again for your help!!!!Jeff

Share this post


Link to post
Share on other sites

O.K. I found a solution. Actually my board has two USB controllers. Only one can be disabled in BIOS. I disabled the one sharing the IRQ with the graphics card and extended the other one with a hub. No more stutters. I have a whole new sim. I actualy thought it was a problem concerning the speed of ram or the grphics card. Wow, what a difference.Alex

Share this post


Link to post
Share on other sites

Great news..glad it worked and glad I actually helped someone fix a problem. I seem to spend more time tweaking/tuning/fixing than flying/playing, but I sure have learned alot in the process.Take care!Gino

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this