Jump to content

Sign in to follow this  
Guest

Elevator flutter?!

Recommended Posts

Guest

I'm a new PIC user and have spent the past weekend reading through the manual and this forum to familiarize myself with this great panel. I tried taking off in both the default PIC and Posky 767 and as soon as I bring in the elevator back pressure, it starts to flutter violently and the aircraft is basiclly unflyable. I did read some posts on a problem with the rudder when fully deflected which I noticed also, but I just stopped putting in full rudder on taxi. But this happening on takeoff without full deflection?? Does anyone have suggestions or insight to this problem? Thanks!

Share this post


Link to post
Share on other sites
Guest

I actually came across a few good posts and I changed some of the elevator values in the .cfg file. It SEEMS to be working for the time being, but now I'm experiencing the same problem with the ailerons. I had no instability there before I messed with the elevator numbers. Has anyone changed the aileron values also?? I've messed with the yaw dampers and haven't noticed a difference one way or the other with how they were set.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...