Sign in to follow this  
Guest Martin

Two Squawkbox problems - with HostSB.dll and multiplayer

Recommended Posts

The last few months I've been having two annoying problems with Squawkbox (SB).The first is related to using SB with HostSB.dll. Often when I try to start SB using HostSB.dll, instead of the "Get Ready To Get Into The Action" button, I get a "standard" Windows "Send/Don't Send" error, i.e. SB crashes. However, sometimes SB starts normally, but there doesn't seem to be any logic in when it works and when it doesn't.If I start SB using SBHost.exe instead, it works fine. The problem is I like having SB visible in FS when I fly (especially as I only have one monitor).The second problem is that I can't get SB to connect to a multiplayer session. I start SBRelay, I start FS, and then I connect to the SBRelay multiplayer session in FS. Then I start the flight in FS and open HostSB.dll. I start SB and SB finds the SBRelay session but when I try to join nothing happens for around 20 seconds and then I get a message saying "unable to join", so eventually I have to choose "No multiplayer".Switching off firewalls, anti-virus programs and so on doesn't seem to have any effect on these problems. Reinstalling SB didn't help either. In the past I've been able to use both HostSB.dll and multiplayer without problems.My system is a P4 1.7 GHz, 512 MB RDRAM, Radeon 9700, using FS2004, Windows XP (SP 2).Thanks in advance for any help, Martin767 fetishistIt's a lot like life and that's what's appealing

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Gday MartinInstead of running through the problem of the sbhost.dlljust start your online flying like thisStart fs9Open SB RELAYStart Multiplayer in FS9Then Open SBHost.exe not SBhost.dllThen Open Sqwarkbox Main program then you are in businessStill have the Sbhost.dll in your modules FolderHope this clears things up for youI have started online flying up like this eversince i got fs9 and being an online flight manager for a VA i teach other people to do the sameHappy FlyingShane

Share this post


Link to post
Share on other sites

Hi Martin and Shane,I too have the same problem with squawkbox crashing and I'm certain that my hostsb.dll is the culprit. As for using sbhost, while it is great on a system/systems with 2 monitors it certainly is not ideal for a 1 monitor layout. I do not think alt-tabbing from sbhost and back to fs2004 is an ideal situation.Regards,Dan PergauPP-SEL (CYOW)

Share this post


Link to post
Share on other sites

An update...Well after some testing on this end I've fixed my problem. When receiving this squawkbox problem/error (as mentioned above) I was always minimizing FS2004 after launching the hostsb module. For fun I decided to leave FS2004 maximized and launch squawkbox via my quick launch toolbar. Squawkbox was able to connect to multiplayer and not crash... hopefully this is not just a fluke. Regards,Dan PergauPP-SEL (CYOW)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this