Sign in to follow this  
Guest cf_sas

Netgear router? Can't hear ATC/other pilots, using AVC?...

Recommended Posts

Hi,Searching different forums, I see that there are quite a few posts about people behind NAT Routers not being able to hear other people transmitting, using AVC (Advanced Voice Client). It seems to be an issue, especially with Netgear routers not forwarding UDP packets correctly, even though the correct ports are set up for port forwarding in the firewall.I have spent almost a week troubleshooting this problem, frustrated about the router not willing to let through any incoming voice transmissions. After trying every imaginable combination of settings I have finally come up with a solution. By posting in this forum, I hope that my findings may be of some value for other people having the same problem.--------------------------------------------------------------------------------------------------------------------------------------------I you don't have time to read this rather long post, you could just scroll to the end of it and read my solution.--------------------------------------------------------------------------------------------------------------------------------------------My problems started when I bought a new Netgear RP614v2 router to replace another broken router. I downloaded the latest firmware (5.20 RC3) and expected a quick and straightforward process to set everything up for Squawkbox/AVC. With my previous routers, this had never been a problem before.Using, the router's web interface, I enabled port forwarding for all relevant ports (including 3290 for AVC). I noticed that it wasn't possible to select wether to forward TCP or UDP traffic, so I assumed that both were forwarded by default.Now I tried to connect to Vatsim. Even though everything connected OK (including AVC), people could hear me, but I couldn't hear them.Tried to open some more ports (3782-3783), but it didn't work. Now, I tried to use port triggering instead of port forwarding, but the result was the same. Using the web interface, I could actually see that the ports were triggered and opened, but I still couldn't hear anything (of course I tried restarting both the router and computer after every change of settings).Tried to use port forwarding and port triggering simultanously - even tried to open a much wider range of ports than needed, but no - it wouldn't work. Turned off Stateful Packet Inspection (SPI), packet filtering and tried every other setting I could find - with no luck.Then I tried to use DMZ instead and - NOW IT WORKED! Of course, using DMZ could only be a temporary solution, considering the security hazards of having all ports wide open. The final solution had to be something else.As most of you probably know, UPnP must be turned off in Windows XP in order for SBRelay to work. I don't even think that AVC supports UPnP, so this was actually the last thing I tried. However, it turned out to be the solution to my problem, although not in the way one would first come to think of.By coincidence, when experimenting with UPnP settings in Windows XP, I found a little utility, called "Internet Gateway Device Discovery And Control Client". I don't think this is installed by default in XP, but it can be added manually afterwards. The purpose of this utility is basically to provide an interface to UPnP routers in the network. I found that by using this utility, I could manually set up forwarding of ports in my router. So, what is the difference between using this utility and using the web interface of the router, you may think? Well, the short answer - IT WORKS!A more detailed answer would be that this particular utility let you select wether to forward UDP or TCP ports. When adding port forwarding entries you can also see them come up in the UPnP section of the web interface with the correct UDP/TCP attribute set.My conclusion is that this router can't forward UDP traffic correctly when using port forwarding/triggering in the web interface. The only way to let through incoming UDP traffic is to use DMZ or UPnP. Don't know if it is supposed to work this way or if it is a bug in the firmware. When I talked to Netgear support yesterday, they claimed that Port Forwarding should work for UDP as well.Ok, but we still have to deal with the problem that SBRelay isn't compatible with UPnP. The way UPnP opens/closes ports in the router on demand may also be a security risk, so you might want it disabled. The good news is that you could get the best of both worlds. I found out that by disabling the "Universal Plug and Play Device Host" service in XP, but leaving "SSDP Discovery Service" ON (automatic) the automatic opening/closing of ports was disabled, but I could still use the nice "Internet Gateway Device Discovery And Control Client" This was enough to make SBRelay work.Now, I finally have a working solution.---------------------------------------------------------------------------------------------------------------------------------********************************************************************************---------------------------------------------------------------------------------------------------------------------------------These are the steps that I went through to make it work:1. Enable UPnP in your router's web interface2. Make sure that port 3290, 3782 and 3783 is not forwarded in the web interface. If they are - delete the entries.2. In the Control Panel: Select "Add or Remove Programs", then "Add or Remove Windows Components". Scroll down to "Networking Services" and click "Details". Make sure that the checkboxes for "Internet Gateway Device Discovery and Control Client" and "Universal Plug and Play" are selected. Click "OK", "Next" and insert the Windows XP CD-ROM if needed.3. Reboot the computer4. Right-click My Computer and select "Manage". Under "Services and Applications", select "Services". Make sure that "SSDP Discovery Service" is set to "Automatic" and that "Universal Plug and Play Device Host" is set to "Disabled".5. Reboot the computer6. In the Control Panel, select "Network Connections". You should see your Router under "Internet Gateway". It is probably called "Internet Connection". Right-click on it and select "Properties" and then click on "Settings".7. Now add TWO different entries. One with UDP selected and the other with TCP selected. You could call them anything you like (I call them "AVC-UDP" and "AVC-TCP" for easy identification), but on BOTH you should enter the IP adress of the computer you are running AVC on and on BOTH you should enter 3290 as the EXTERNAL AND INTERNAL port number.8. After you click OK, port 3290 should be open both on TCP and UDP in your router. You can browse to your router's web interface and make sure you see the two new entries in the UPnP section. There should be one entry for TCP and one entry for UDP. Both should be active, have 3290 as internal and external ports and the IP adress of your computer visible.9. That's all! Now try to use AVC/Squawkbox/SBRelay - it should work. Happy flying!Hope that this could be of any help to anyone having this problem.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this