Sign in to follow this  
Guest garf25

Controls Freezing whilst online

Recommended Posts

Hi all,I am having a problem with all my controls freezing whilst flying or taxiing. It only happens when I am flying online.I might be turning to the right, and the controls will freeze unabling me to level off for a few seconds. The same may happen whilst turning a corner on the ground. If I hit ALT to bring the toolbar up, and then ALT again to resume flying it seems to reset.I have a 1gb processor, with 256 of RAM.I am using the Saitek X45 joystick throttle combination.Any suggestions, as it is driving me mad.Cheers all,Happy Flying.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've had the same problem last week and I have the same X45 stick. Not sure what caused it, but it stared to happen after I had been on-line for about 4 hours(Vancouver-Toronto flight) I hae not had the problem come back but I have not made a flight over 2 hours since.I'll tell you this its not a SB problem becuase I'm testing SB3. I did however just update to the latest version of FSUIPC. Did you pay for your version of FSUIPC or are you running the free version?I'll check the FSUIPC forum and let you know.What drivers are you using? I never did install the Saitek ones just let windows do its thing

Share this post


Link to post
Share on other sites

Thanks for your interest,I am using the Saitek drivers, and have never had a problem with them until I have started flying on line.I do use the profile manager that comes on the CD to customize the buttons to what I want. Dont know if its something to do with that?Its sort of hit or miss when it happens on my system, sometimes when i first boot up, or sometimes if Ive been in the air for a while.Dont know if you are using voice or not, but there is an excellent facility in the above mentioned profile manager to assign your 'push to talk' button onto your joystick or throttle - really good. It would be even better if the damn thing wouldn't keep freezing!!Cheers for your help.

Share this post


Link to post
Share on other sites

Ok I have talked to some other people that I know with this stick and we are not the only ones. Best one I have been told so far is to turn off your USB 2.0 support in your system BIOS screen. I'm going to give it a try and see what happens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this