Sign in to follow this  
Guest PoRrEkE

Multi display problem (gauge panels)

Recommended Posts

Ok, I got a new PCI graph.card here and it's nothing spectacular but I will get the 128 mb version (now 32 mb) as soon as I confirm to the guy that this SIS 315E works ok.It does, however .. I undock my gauge panel. Then I put it on the other display. If I fly like that, every say 10 seconds the sim freezes for .. say 1 second or less. Then if I go to fullscreen mode (provided the settings on the FS hardware menu are equal to the actual windows settings of resolution of both displays, I can get fullscreen. Then the hick-up is gone though my gauges on the panel go very small into the top left corner. Just as if they were 800*600 on a 1280*1024 display. Now if I edit the cfg file to make them bigger, this works but they seem to be "masked" by a frame which only shows gauges within the 800*600 part of the display. So gauges that go outside that are can only bee seen half or not at all.What goos wrong here ??? I've tried changing 'bout everything in the cfg file without any luck.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I fly like that, every say 10 seconds the sim freezes for .. say 1 second or less. disable hardware acceleration via contrel panel -advanced --troubleshooting----only for the pci card

Share this post


Link to post
Share on other sites

I do not find "troubleshooting" in my control panel ...Either way I know what is going wrong and I do not want to turn off hardware acceleration. This would only make the sim take more of my CPU so ...Let me just explain what weird situation is going on.1) you MUST set the resolution in FS for both monitors exactly the same as that which you have set in windows.2) you must go to windowed mode and give the panel you want to undock maximum size there (if you want that panel to fill up the screen on monitor #2 after undocking and going back to fullscreen)The issue I had was as follow. The size of the area on #2 display in which I was able to see gauges was the same area this panel took in the main FS window when not undocked.So e.g. I start FS. I get the "main_left_mip" panel on my screen. It covers the upper left 800*600 pixels of the total 1024*786. If I undock now and put it on display #2, then go to fullscreen, only a zone that has the same proportion as [800*600] compared to [1024*786] will show gauges. If before undocking I dragg the "main_mip_left" panel to cover the entire window of display #1, then undock and go to fullscreen the full display #2 can show gauges. Pfffffff rather complex situation. Not if you know how it works but it took me quite a few hours of testing and trying to figure out that this is the way it works. Seems now I got to re-position my gauges so that they fit the window-gaps.Either way (y) thumbs up .. I am on a roll again :)

Share this post


Link to post
Share on other sites

PhilippeSorry to tell yo that u will NOT be able to rid off stutters running pci card in hardware accelerated mode--even so ,u dont need that at all if u running 2d gauge on this one --not Open GL of courseNow thats the way to find troubleshouting tabControl Panel/click on the secondary display, then advanced and u will hopefully find the needed tabAll this mess with fullscreen really annouyng and i prefer the windowed, even if the fullscreen is possibleWish you luck

Share this post


Link to post
Share on other sites

Sorry--after control panel , go to display then as axplained

Share this post


Link to post
Share on other sites

I have found your page ..Here it is under "control panel" / display / settings / advanced / troubleshoot.If I put that slider to the full left for the PCI card, guess what happens ... yap indeed 3D acceleration drops out in FS9 .. on ALL cards !! My GF2 Ti 500 drops dead'ish. You can no longer access the "hardware" page in FS and you can no longer select fullscreen.

Share this post


Link to post
Share on other sites

> Sorry to tell yo that u will NOT be able to rid off stutters running pci card in hardware accelerated mode--even so ,u dont need that at all if u running 2d gauge on this one --not Open GL of courseAre you using FS9 or FS8 ?? Cuz FS9 does give you great FPS when not 3D accelerated but does not give you super nice textures (if any at all on certain buildings).And you say I will not get ridd of the stutters ? I just did.It all comes down now to getting the gauges to have the right size and position on the panels.And why use 3D mode for gauge panels ? Simple. MS tells us to do so .. and they won't say that so that we would buy expencive cards cuz they sell none.

Share this post


Link to post
Share on other sites

Hi againgYou not loosing 3d acceleration on Agp card --only drivers GUI--and u can check that by running Directx diag And i an talking about the pci card ,displaying gauges not the agp, displaying scenerys, which has to be accelerated --- so nothing to do with buildings textures As to stutters-- play arround with diff scenerys and aircraftsOnly then you will see if you got rid of themHopefully you did , ---i didnt Take care

Share this post


Link to post
Share on other sites

I got what you meant first time 'round you know.PCI acceleration off, AGP acceleration on.This however kills my AGP card as I said. Building textures become black or transparent or something in between with weird patterns. My FPS drops from an average of 80 down to 20, ...Not the most interesting sollution I think (here). Could well be that your system does like it but for sure this is not the ideal way to go on my system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this