Archived

This topic is now archived and is closed to further replies.

Guest Mark McG

CH Pedals - Cleaning

Recommended Posts

Anyone got any experience of dismantling/reassmebling the CH Pro Pedals for cleaning of the components. Could do with some advice about the toe-brakes. Everything has fitted back together nicely, but the Left Toe Brake will not move on the calibration screen.Any help greatly appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have dismantled mine several times. The one problem I had concerned trapping one of the wires between two of the inside parts and cutting it in half. You may want to open it again and check for a broken wire. Milt

Share this post


Link to post
Share on other sites

Hi Milt,thanks for the suggestion. Luckily I have not broken a wire - the Pot still works & shows movement on the calibration screen when i turn it manually.

Share this post


Link to post
Share on other sites

I would say that if you can turn it manually and it works, then it must not be connected properly inside the unit. Another problem I had was not getting all of the physical levers and so on in the right spots. Other than that, I don't know. Milt

Share this post


Link to post
Share on other sites

Thanks Milt. I think I'm going to have to reopen the pedal and reassemble it.

Share this post


Link to post
Share on other sites

Fixed the problem.I had installed the POT for the Left Toe Brake the wrong way round. Although the gears were meshing correctly, because the POT was the wrong way round it was moving only in the dead zone. Once I had the Pot installed correctly and the gears meshed again it was fixed in seconds.

Share this post


Link to post
Share on other sites

Would you mind telling me HOW you open them?I have problems with mine too.I want to get in and check the POTs.Thanks in advance.

Share this post


Link to post
Share on other sites