Sign in to follow this  
Guest

CH Pedal cure ??? - I hope !

Recommended Posts

I put a question mark, as I am loath to announce that a problem has been solved, for normally as soon as I do , the perverse nature of my computer shows itself and the trouble returns. However, in this case it hasn't.Let me explain. When operating with my old computer under Windows 98, both the CH Yoke and Pedals worked faultlessly. However, with my new rig, and using the Windows XP operating system, the Pedals have given me a problem since day one. After loading FS2002, I have always had to disconnect and reconnect the USB plug and at intervals during the flight the rudder would swing hard over to the left necessitating a USB reconnection.As you see from my spec. below I have many USB connecting pieces. In addition to the Yoke and Pedals I have six Go Flight units, a cordless keyboard and mouse plus a scanner and permanently connected digital camera in its cradle. Their are six outputs on my computer, four more on the Monitor hub and I have a further powered hub accomodating another four.What I have done to solve the problem (well it has worked for the past two weeks) is to plug the Pedals into the powered hub, and as soon as I have booted up the computer, I load FS 2002, and from the opening window minimise the flight sim to the task bar, I then go into Word or the internet or whatever, and it works. If I fire up FS 2002 after I have used other programmes I have problems.Thought I would mention it, hoping it might work for someone else with a similar problem. Sorry this is so long winded.My Spec

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Biggles. Your problem is exactly the same as mine. But I don't have any USB peripherals other than the CH yoke and pedals, so they are plugged straight into the USB ports on the front of the box.Good job the ports are on the front: what a fiddle if I had them only at the back!My workaround is to touch the brake pedals from time to time during flight. That seems to keep the pedals awake.I'm going to try your solution: start up FS straight after bootup, minimise it, then do the other things I have to do. Perhaps I will have to get a powered hub if your simple solution doesn't work.Best wishes

Share this post


Link to post
Share on other sites

Go into Control PanelSystemHardwareDevice Manager and open the USB tree and right-click on the USB Root Hub. Select Properties and then select the Power Management Tab and make sure that 'Allow computer to turn off this device to save power' is Unchecked. Do this for both USB Root Hub devices. See if this cures your problem.

Share this post


Link to post
Share on other sites

Thanks, Deeks, but I did that some time ago. The options were already turned off (unchecked). I'mI am going to test out the plan to open FS straight after bootup when I get the chance. Have a lot of accounting work to do first!Best wishesDon Hunt

Share this post


Link to post
Share on other sites

I was having exactly the same problem a few months ago and ended up giving up on WinXP as a direct result. I am now back with WinME and things have been working well.After your post, I thought I'd try loading WinXP again, on my backup HDD. At first, it did the same old same old - ie. would not detect initially then would hard rudder left after 10 or so mins. I even tried the "don't power off USB port" suggestion but to no avail.As a last chance, I tried installing the CH products controller manager for WinXP, and now everything seems sweet! I've only tried it out for about 2.5hrs of flight without a hitch, but seeing that before I couldn't get past about 10 mins of flight before a hard rudder left incident would send me spiraling into the ocean/ground, it's looking pretty promising.Go here: ftp://ftp.chproducts.com/pub/chcmv028.zip to download the control manager software. It installs easy, but just be prepared for about 10 hardware redetects when it installs, 4 of which are on the next bootup. Good luck!Gary

Share this post


Link to post
Share on other sites

I will definitely vouch for this. I had terrible problems with my CH controls locking up in 2000 and XP. Since installing the controller manager I have not had a single problem. I don't even remember how long it's been since I installed it... late last fall sometime.

Share this post


Link to post
Share on other sites

Hi allWell, well. Many thanks everyone. Starting up FS straight after bootup didn't do the trick for me, but downloading and installing CH Control Manager did, it seems. Just done a 40 min low and slow without touching the pedals, and no problem at all. So it looks promising for me too. Whoopee! :-jumpyDon Hunt

Share this post


Link to post
Share on other sites

Just an add-on note. After installing the CH Control Manager I found I had to reassign my yoke buttons and sliders. But once done, that's it..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this