Sign in to follow this  
Guest

Sidewinder Precision 2 not working?

Recommended Posts

hi all, i've been using the MS Sidewinder 2 for almost 2 years now.A couple months ago when I wanted to play FS2002, my joystick wouldn't work. Windows ME (At that time) couldn't even recognise it. according to the computer, I hadn't plugged my joystick into the USB Port.I'm not sure what happened, but the next day it was working perfectly.Now, today, I had the same problem. I was just about to start taxiing when I discovered my joystick was not connected (using WinXP)I've been trying all sorts of things for the past 8hours now, including shutting down the computer for 15minutes over and over again, shutting down, taking the plug out of the USB port (the joystick's plug) and putting it in, taking it out, putting it in, etc. but it still isn't working.I hadn't even touched the joystick when it stopped working.Any ideas anyone? Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had the same thing with the Force Feedback 2. Sometimes it would work, other times not. Is the green power light off or on?In my case the light would go out and the stick would die. I traced it to a bad wire in the USB cable just past the strain relief right near where it comes out of the base. These wire are very small and delicate and I guess it just suffered from fatigue after a while.Hook it up and carefully work your way along the cable gently bending it back and forth and watch the light. If you think you have found the spot unhook it, disconnect the power and remove an inch or two from the section where you think it is broken and splice the good parts back together again.I had to remove the strain relief from mine so if you do too make sure that when you put it back together you put a bit of slack on the USB cable and tape it in position to the power cord. This is a bit hard to describe but you have to be sure that when the cord gets pulled there is still some slack on the USB cable otherwise the little connector inside the base will get broken.That's what I had to do for mine. Of course this may not be your problem but if it is, you may be more patient than I am and actually want to do it properly and see if you can get a replacement cable.If I could afford it I would simply trash the whole thing and pick up something different but it was very expensive here in Canada and I can't justify getting rid of it just yet. When the day comes to finally get rid of this awful thing it won't be too soon. I've never been happy with mine.

Share this post


Link to post
Share on other sites

It's really weird.After trying for 8hours yesterday I got really frustrated and tired so i just yanked the plug out of the USB port and left it there over night.The next morning I tried it and it worked! I pulled it out again, tried it, still worked!It's really crazy because i didnt tamper with any settings/wires etc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this