Sign in to follow this  
Guest SoarPics

CFS2 not 'seeing' TM Cougar, but Windows/DirectInput an

Recommended Posts

Morning All,CFS2 seems to be ignoring the Cougar through DirectInput, but all other DirectInput sims are seeing (and functioning) with it fine.You can go into Settings > Calibration and the DirectInput test is working properly and the same assignment that's been used forever (that's still showing all the correct assignments) is being used.Any ideas? Anyone seen anything similar? I've reinstalled the program allowing it to overwrite existing files, reinstalled DX8.1 and re-flashed the Cougar's firmware with the latest version. No joy...Help! CFS3 is OTW, but it can't help with a desire to fly in the PTO!!Thx,-ScottAlso, has anyone found a way to save a control layout/state in FS2002 like you can in CFS2? Anyone know what the control cfg files are named to save a backup once the setup's squared the way I want it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First thing I'd do is make sure the HOTAS CCP is configured properly:1) On the first page "Axis Parameters" make sure all functions are set-up for DirectInput (make sure there is an "X" in each appropriate box. Also, make sure "Button & Axis Emulation is OFF (Red).2) Go to the "Startup and calibration" page and check the following: a)Axis response= Default b)Emulation= Off c)Calibration Mode= AutoFind the CFS2.cfg file in the main CFS2 directory. Go to the "PREFS" section and make sure this line is in it: "Keyboard_Current=cfs2.Saving a control layout in FS works the same as it does in CFS2.Just curious... why are you using this stick, with it's brilliant software, in DirectInput mode? There came with the Foxy software 2-3 emulation files for CFS2 and FS. These profiles will do so much more than DirectX default assignments. I have written numerous profiles for the different aircraft I fly in FS2K2. Easy to create, easy to manage, easy to load.Good luck... I'll check back here periodically to see if you get the problem sorted.

Share this post


Link to post
Share on other sites

Heya Greg,I've written scripts all over the place for the TM stuff all the way back to when the TM Mk. I throttle UPROMS came out (prior to the Mk. II programmability ;). HOTAS best describe all of my scripts... I hate the keyboard while 'in-sim'. All button setups are custom (except the trigger and weps release), but what I meant was the profile for the Axiis was the default one... nothing 'weird' for the response curves to cause problems with 'normal' response.I'll check the rest of those tonight, though. Come to think of it, about the only other thing that changed on the machine was I did Uninstall FS2002 on this machine prior to the problems (the primary 'Civil' 2002 machine is attached to a PFC Multi console), although what that's change, I don't know. I'll reinstall that and see if it has the same problems or if it corrects the problem on CFS2. Didn't see a 'Save' option in the 2002 control assignmets area here at work, though.Later and Thx,-S

Share this post


Link to post
Share on other sites

OK, You're going to love this.I do most of my flying in the Virtual Cockpit view... I'm allergic to the 2D panels. If the sim ignores the inputs, after workig for 'x' amount of time, then stops accepting inputs and the control input is 'frozen' in the state the controls were in... say a shallow right bank... and it locks-out the controls, I stir the stick around to all four corners, throttle, trigger, weps release and nothing happens (keypress assignements work fine, btw) I'm still in a slow right roll, probably upside down at that point... I CHANGE THE VIEW from Virtual to Spot or back to the 2D pit... control effectiveness regained.Just flat weird. I have no explanation, whatsoever. That happens 100% of the time. It will not go into that mode in 2D or in Spot, however.Seems to happen in the stock Hellcat more often that in other a/c, even 3rd party, and in Campaign more than Free-flight or Quick Combat.Tried taking the Cougar off the USB HUB and going direct to the machine, no effect. Try reducing the sample rate in the Cougar HOTAS from 2 seconds to 1 second, maybe?Hehe, S-T-U-M-P-E-D, but good.-S

Share this post


Link to post
Share on other sites

OK then, now you're giving me a headache. :-lol I would first suspect a problem with the profile you're using. Is it the CFS2 profile that accompanied the Foxy software? If not, try using the Foxy profile as a test. If it is the Foxy profile, strip down the programming to the basics to make the airplane fly, rename it as "TEST" and try it.At least we now know your Cougar has some functionality in CFS2. Better than where you were at yesterday.Press on,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this