Sign in to follow this  
Guest

To all those who have problems with CH Pedals USB

Recommended Posts

I had the infamous 'pedals go to sleep every 5 minutes and only wake up if you disconnect and reconnect' problem. There are a few inconclusive threads on this forum. Well, I got in touch with CH and here is their reply: 1. Your Control Manager is out of date we are on 1.32 and 2.0 is due out this month.2. There are numerous problems with Windows and the VIA chipset according to Microsoft. As of yet they have not admitted to XP but VIA has. We recommend downloading and installing the latest VIA USB Filter Patch from the via site (www.via.com.tw)or trying to get a fix from Microsoft (look on their Knowledge base under Article IDs: Q232889, Q240075, Q297184, Q277464, Q253152, Q246755, Q216096, Q233163). Other users have reported that if they went to the bios and switched off - PCI master read caching - in the advanced options the problem with USB devices stopped. However if you go back into the BIOS it will be switched back on. Your best bet and sure fix is to use a different chipset for your USB host controller. This can be done with a PCI to USB expansion card, preferably with a Intel, Opti, NEC, or Lucent chipset on it.Michael SextonSystems Administrator CH Products The latest USB Filter patch seems to have nailed it for me. Hope some of you get the same result...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this