Sign in to follow this  
Guest

Having Trouble get EZ-Landmark Version 1.1 to work

Recommended Posts

Yesterday I donwloaded version 1.1. I am already a registered user. I downloaded the Complete 8.mb version. It looks like all I got was the updated databases. Not the 1.1 version of the product. I searched their site but cannot find where you can download the updated application.Anyone having the same problem?Thanks to all who reply.Bill

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this