Sign in to follow this  
Guest Daniel42

SimConnect SxS troubles

Recommended Posts

I have developped an add-on using C# and the managed SimConnect library and it works fine. It also worked fine for all users of the add-on, until today. Someone gets this message when starting the add-on:"Could not load file or assembly 'microsoft.FlightSimulator.SimConnect, version =10.0.61242.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies"He does have version 10.0.61242.0 installed, but on closer examination the PublicKeyToken does not match the one in the WinSxS folder name, which is:x86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.61242.0_x-ww_35e8ee9aMy installer checks for this folder (and the vista variant) before starting the install. It is also the one I have, so the user and I seem to have identical SimConnects.So I gave the user a manifest file, specifying the PublicKeyToken=67c7c..... (as in the folder name and in the example manifests) but no luck.Now if only the managed examples in the SDK would have had compiled versions, I could send one to the user to see if the problem is in my compilation/distribution (already tried another SimConnect program which gave the same errors) or in his SimConnect setup.One final clue... the user has the French version of FSX/Sp1.Anybody who knows what's going on?Yours,Daniel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this