Sign in to follow this  
Guest viking77

SIMPLE TAXI

Recommended Posts

I want to add a Beech58 in a mission I am making.. starting from parking and then taxi to the runway..I assume I can add any aircraft included in FS X in an AI mode?The code so far is like this.. and for some reason the 58 will not show up.. Beech58N53

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's a 3 step process ... and you've completed Step 1.Step 2: Create an Object Activation Action - specify the Beech.Step 3: Trigger the Object Activation Action (you can use a Timer trigger set to 0.00 which will run when you start your mission).Cheers,Kevin D. Greenehttp://fsxmissions.blogspot.com/

Share this post


Link to post
Share on other sites

You are saying that anytime I insert an AI object it is by default INACTIVE? But that hasn't been the case in other missions.. I started a DHC-2 on the water for takeoff without activating it?

Share this post


Link to post
Share on other sites

Ok, I confirmed that there is no activation trigger needed for AI. After another hour debugging the mission I found a link to a dialog action that itself had no content (had not yet entered a TEXT or a soundfile link). Fixing that action fixed the mission and everything now works.

Share this post


Link to post
Share on other sites

Viking,My reply to your original post made an assumption that I shouldn't have made ... and was therefore imprecise.To expand:1) You are correct. If you want the AI to begin to do its thing when your mission starts, no Object Activation is necessary.2) If you want the AI to begin doing its thing at any other point in your mission OTHER than at startup of the mission, then you would need an Object Activation action and a trigger to set it flying.Sorry if I steered you down a bum path. It sounds like you had another issue that was preventing your mission itself from loading; and you confused that with your AI not loading. That's an easy mistake to make (I've made it before).Here's a really, really good solution to keep that from happening. Record a .wav of you saying: "Load is good."Create the dialoge actuion, and attach that .wav file to your mission startup trigger, so that it's the first thing that gets played when your mission loads successfully.That way, you can listen for that dialog whenever your mission loads, and if you have made a mistake that is preventing the mission from loading, the sound won't play; and you'll know dead away something you just changed is amiss.Hope that is helpful.Cheers,Kevin D. Greenehttp://fsxmissions.blogspot.com/

Share this post


Link to post
Share on other sites

Incidentally, there is something different about adding a helicopter. For some reason when I try to add waypoints things go odd... I want to start about 150 feet in a hover, but is it possible?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this