Archived

This topic is now archived and is closed to further replies.

Guest frofro64546

simwesterly level 3

Recommended Posts

good day it seems the file is bugged , the mission won't load " as a mission" but a freeflight( got the hangar and everything fine) , the mission simply won't trigger when pressing " escape" i got the "free flight" window ( end flight/continue flt/ view flight analysis) and NOT the mission window where all goals are normally listed (with status pending/completed/failed) anybody got the same problem? maybe dave crandall is in the area ? thx in advance

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>good day >it seems the file is bugged , the mission won't load " as a>mission" but a freeflight( got the hangar and everything fine)>, >the mission simply won't trigger >when pressing " escape" i got the "free flight" window ( end>flight/continue flt/ view flight analysis) and NOT the mission>window where all goals are normally listed (with status>pending/completed/failed) >anybody got the same problem? >maybe dave crandall is in the area ? >thx in advanceMake sure that the SimCopter folder is in your FSX Sound folder.

Share this post


Link to post
Share on other sites

David,Have you thoroughly tested SimWesterly L3 with Service Pack 2 of FSX?I do not believe this mission would ever load if the Player has installed Acceleration.(PS ... big fan of this mission series and wishing also that I could get L3 to load. I've tried to debug it, but gave up after a few hours. You know the mission better than I do, however ... and might could find the error easier.)Just wondering,

Share this post


Link to post
Share on other sites

No I do not have the Acceleration Pack.This could be an issue with my missions. I do not know.I will re-test Level 3 by unistalling it from my compter and re-installing from my upload folder, mistakes do happen. Please be patient with me.Dave

Share this post


Link to post
Share on other sites

I indeed run FSX with acceleration dave , no pressure , but afterall it's YOUR FAULT if 'm now addicted :-lol :-jumpy

Share this post


Link to post
Share on other sites

Today, AVSIM reposted SimWesterly Level 3 on the front page.Don't bother downloading it. It still will not work if you have applied Service Pack 2 (or are running Acceleration).:(

Share this post


Link to post
Share on other sites

Okay, I am NOT a professional designer, I am only a flight sim who like to make missions for the fun of it. I make lots, no tons, no megatons of mistakes with the upload. How many times have I had to upload updates and fixes. I should just give up uploading missions it only gives more frustrations in my already frustrated life.:-violin Okay now that I got that off my chest, lets get down to the problem at hand. I uninstalled Level 3 from my system and all files associated with it and reistalled from the updated version. Indeed it did not work. I suspected a music file so I took my backup music folder and replaced it in my FSX sound folder. The mission loaded. I will be uploading this folder to avsim shortly. I hope this end further problems.:-)

Share this post


Link to post
Share on other sites

David,I apologize if my response to frofro seemd like a criticism of you. It was not meant to be. We are all great fans of the SimWesterly series.Rather, my comment was to save frofro and some others who are having issues with SimWesterly Levels 2 and 3 the trouble of downloading the latest version, which still would not run on machines with Acceleration installed.You can beta test missions before releasing them using the services of the community of mission builders over at http://www.flightsimulatorxmissions.comI never release a mission without first running it by the developers that meet there. They catch many problems with missions before users ever see them. With a series as complex as SimWesterly (especially Level 3) it helps to have folks looking over your shoulder, as it were, to catch any problems.Cheers,

Share this post


Link to post
Share on other sites

David,There are two remaining problems with the latest XML that prevent FSX from loading the mission if the Player has Acceleration installed:Problem 1The landing trigger called "Landing Transport 2" uses a ChangeObjectType action in its list of Actions. Post-Acceleration, LandingTriggers no longer support use of the ChangeObjectType action. (In other words, in the Action list of a LandingTrigger, you can't use a ChangeObjectType action. I have no idea why Microsoft changed that behavior, but they did and it's breaking your mission.)Here is a way around the problem::( Create a TimerTrigger called "Timer_EnterCessna". Set its Time to .001 second, and make sure it is not active.c) Create an ObjectActivationAction called "ActivateTimer_EnterCessna". You will use this action in the next element.d) In the Action list for the LandingTrigger called "Landing Transport 2", add "ActivateTimer_EnterCessna" to the list.This uses a Timer Trigger to set off the ChangeObjectType action, thus, getting around the limitation.Problem #2You have a scenery element that, for some reason, the GUID does not resolve. It is the Toolbox next to the mechanic. FSX is unable to resolve the following GUID:8FA3866A-573B-49D3-9AEA-84FB9879CCFThere are two places where you need to address this:1) The scenery object itself (remove or replace it)2) The "DeactivateMechanic" trigger references this scenery object, so you'll need to edit that trigger also.Somewhere along the line of swapping out scenery elements, this mistake was introduced.If you correct these two items, the mission will load on a workstation that has Acceleration installed. I believe these are the only two remaining bugs that are preventing the mission from being loaded.Let me know if you have any questions.Cheers,

Share this post


Link to post
Share on other sites

David: You may not call yourself a professional, but your missions are some of the most fun and memorable ones I've flown, even with the serious undertone of being medevac missions. That is what's most important in my book and also what I would call professional.Looking forward to a working version of this third installment. Keep it up! :)

Share this post


Link to post
Share on other sites

Thank for the suggestion, I am quesing that this is only a Acceleration problem. Strange thing about the mechanic (this was not a object made by me, rather another designer who had made it FS9) I will create a new XML with these changes for Accelerater uses and hope that this fixes the problem.? How did level 1 and 2 run in Accelerater?Dave.:-)

Share this post


Link to post
Share on other sites

Level 2 has problems in Acceleration owing to some of the characters not appearing correctly.I'm not a scenery designer, so I can't say why exactly ... but the character of the mugger is totally invisible when viewed on a computer running Acceleration/SP2. (Some parts of other characters are also invisible, making them very hard to find.)Because it's the mugger, it is not possible to complete Level 2 and get the password for Level 3 without cheating.(At the request of several Players, I switched out the mugger with another character that does display correctly ... so that they could at least finish the level and get on to L3.)Cheers,

Share this post


Link to post
Share on other sites

Please let me know if anyone has completed this mission. I would like to know if the problem I have been notified is only a Acceleration users problem or if the problem is in the upload file. I have tested this after uninstalling and reinstalling the upload file and found the missing music file. I uploaded the missing sound file to avsim and I am hoping this solves any problems. I am currently trying to fix the Acceleration version. I have a Acceleration user I am working with to get it up and running and will repost the second update version when he gets it working properly on his system.I appologize to everyone who is having problems with my missions. If I know that there is a problem I will do everything in my power to get it working. After all how can enjoy my missions if you can't get it working.:-) Dave

Share this post


Link to post
Share on other sites