Jump to content

Sign in to follow this  
Guest ronin

insane trim problem

Recommended Posts

Guest ronin

Just reinstalled FS9; all of my planes trim full down in flight! My stick is OK, checked it out immediately (I thought it broke and some buttons were stuck or something).Never saw this before, or heard of the problem. How can this be cured?It's a clean install, nothing left behind from old installation...no folders or anything.Thanks!

Share this post


Link to post
Share on other sites
Guest neslesman

Have you tried loading the FS9 C172 Default flight out of Seattle or whereever it is then switch over to the aircraft of your choice from the aircraft menu? That will usually neutralize any out of whack controls settings.Also check that the autopilot isn't defaulting to being on and in a climb mode.Also, can you neutralize the setting when still on the ground by pressing number pad 5 for a few moments while in "numbers lock"?

Share this post


Link to post
Share on other sites
Guest ha5mvo

are you using any weather program in the background?If so, check wether that happens without it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...