Sign in to follow this  
Guest Nealoc187

First time having Out Of Memory problems - what's going on here?

Recommended Posts

I've been simming for about a year now and tonight I had FS9 freeze up on me and tell me I was out of memory twice - first time this has ever happened.I was flying the F1 Pilatus PC12 (and aircraft I've flown quite often, never a problem). The trip was only 660 miles so it's not as though it was an overwhelmingly long flight. The only change I've made recently was the addition of a freeware airport, KBHB, which was my destination for this flight and about a week ago I added flight environment, but I've completed multiple flights since adding it so I don't think that's the issue. I run activesky and radar contact as I do with all of my flights. I've got ultimate terrain, ground environment pro, and FS genesis mesh all installed. The first time it froze up it seemed to start acting strangely about 40 miles from my destination - started taking longer for textures to pop when switching views, then a minute or two before it froze up some textures stopped popping entirely - and part of the plane was just solid gray as was some of the ground areas. Then it froze and gave me an out of memory message. I shut down the computer, restarted, and flew the flight again in the exact same manner - I figured it was just a fluke. This time it gave me the error again - I was about a mile from my destination (unbelievably annoying on a 3 hour flight). I didn't notice any issues prior to the out of memory message this time. It just popped up the little dialog saying it was out of memory, perhaps my hard disk was too full (it's not, I've got 15gb free on one disk and over 150gb free on another) and it shut down on me. So, anyone have any ideas? Tomorrow I'm going to try the flight again using the same parameters but I'm going to try a different aircraft. If that doesn't work then i'm going to try removing that freeware addon airport and see if that might have something to do with it, though KBHB is a tiny airport without much AI traffic whereas I sucessfully land at the major airports with 150 AI planes around without any problems.Anyone have any insights on other stuff I might need to check?My system specs are:Intel E4400 @ 2.92ghzAsrock 4core dual vsta moboati x850xt AGP card2gb corsair valueselect ramall components are in good working order and pass stress testing benchmarks - as I said I've been simming for over a year and this is the first time this has occurred.thanks,NC

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi NC, my first guess would be to check for empty folders your scenery and texture folders - it's a notorious memory eater. I had the same problem as you, suddenly getting out of memory even though i had 4gb on the machine. Using the filemon tool I was able to pinpoint which files it was trying to load and which folders it was looking in - some of those folders where empty. I cant remember if i removed them or just filled them with a random file, but in any case, it worked for me. No more OOMs/almkennedy

Share this post


Link to post
Share on other sites

>Hi NC, my first guess would be to check for empty folders>your scenery and texture folders - it's a notorious memory>eater. I had the same problem as you, suddenly getting out of>memory even though i had 4gb on the machine. Using the filemon>tool I was able to pinpoint which files it was trying to load>and which folders it was looking in - some of those folders>where empty. I cant remember if i removed them or just filled>them with a random file, but in any case, it worked for me. No>more OOMs>>/almkennedycan you go into a little more detail on this? I just went and looked in my Addon Scenery folder, found an empty 'texture' folder listed under an addon airport that is in a different geographical area. It is NOT the airport that I added last night so I'm not sure if it would affect the area of the country that I am flying in or not. Another thing, the airport I added last night had a bunch of "optional" files included with it so that it's scenery lined up with either Ultimate Terrain or default terrain, so that the airport name was properly pronounced in VOXATC, etc. So there a quite a few optional files in there that I am not using - should I have deleted those optional files?

Share this post


Link to post
Share on other sites

Try the flight without the KBHB addon. If it works, then you know it's the addon and educated guess says maybe a bad texture file that is a part of the scenery.

Share this post


Link to post
Share on other sites

>Try the flight without the KBHB addon. If it works, then you>know it's the addon and educated guess says maybe a bad>texture file that is a part of the scenery.should I just uninstall the addon in the scenery selection option in FS9 or should I delete it entirely from my Addon Scenery folder in the FS9 directory?I just tried a flight from KBHB to KPVD and I didn't actually freeze up and crash, but I have a feeling if I had gone much longer I would have. Textures stopped working, the ground turned purple, switching views started happening very slowly, the memory usage of FS9 on the process monitor started climbing from around 550,000kb used during most of the flight to almost 800,000kb by the time I was on the ground and everything was acting weird. this is really starting to tick me off.

Share this post


Link to post
Share on other sites

I'm not familiar with the addon, so what it entails I can't be specific about. If it installs to a folder under Addon scenery then I would remove the entry from the FS scenery library and delete the folders that contain the scenery itself. FS9 can get quite whacked out when it gets hit with a bad texture file, as it sounds you are witnessing. If you have a backup ZIP file of the scenery then you still have the opportunity to reinstall, should something else be the culprit. But the visual anomolies and crashing of the sim lead me to say it "should be" a bad texture problem. Since I am not familiar with the addon I can only hope that it doesn't install any files outside of it's own scenery and texture folders.

Share this post


Link to post
Share on other sites

>I'm not familiar with the addon, so what it entails I can't>be specific about. If it installs to a folder under Addon>scenery then I would remove the entry from the FS scenery>library and delete the folders that contain the scenery>itself. FS9 can get quite whacked out when it gets hit with a>bad texture file, as it sounds you are witnessing. If you have>a backup ZIP file of the scenery then you still have the>opportunity to reinstall, should something else be the>culprit. But the visual anomolies and crashing of the sim lead>me to say it "should be" a bad texture problem. Since I am not>familiar with the addon I can only hope that it doesn't>install any files outside of it's own scenery and texture>folders.Yeah it was just a simple install with a 'texture' folder and 'scenery' folder.Earlier today I flew the PC12 from KBHB to KPVD and had problems at the end of the flight (as noted above) and then I did the exact same flight in the Dreamfleet Baron and the flight went perfectly - so I might have it narrowed down to an issue with the PC12 aircraft- however I've flown the PC12 a million times before with no problems so it could be just a coincidence. It'll take more testing to be sure. I thank you for your advice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this