Archived

This topic is now archived and is closed to further replies.

Guest macdawg

modules not loading!

Recommended Posts

hello to all! when i start FS9 i get a message that some aircraft or software was unable to load,but i can click O.K. and FS9 starts.what's not loading is FDSConnection.dll and FSUIPC.dll.i have had these in my FS9 modules folder for many months with no problems,until now.also, once FS9 is running and i press the ALT key to bring up the toolbar,FSUIPC no longer shows up under modules,although my FLYBY still shows up under modules.one other thing i notice is that all my other .dll's in my FS9 modules folder have a series of numbers like 3.7.0.2 under the name of the .dll and under these numbers are the words "microsoft flight simulator".my FDSC and FSUIPC .dll's used to have this also but know they don't.i tried to delete these two .dll's and i got a message unable to delete,disc full or write protected.i tried to replace with Pete Dowson's latest FSUIPC.dll and got the same message.i don't have a clue here! thanks for any help :-)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jim! and thanks for your response. i'm running XP. MATT

Share this post


Link to post
Share on other sites

hi,and thanks again Jim.this is frustrating.I am signed in as admin. and my modules folder is not Read Only.I right click to check properties and the read only box is not checked for my modules folder and the .dll's within are not checked as raed only.everything seems to be fine except these two; FDSConnection.dll & FSUIPC.dll,which no longer load with FS9 and they no longer look like all the other .dll's.I'm a long time simmer,but not terribly computer savvy,so I really appreciate your time and help jim! thanks again, MATT

Share this post


Link to post
Share on other sites

hey Jim,this was the first thing i tried a few days ago.I have version 3.7 in my modules and it has been there several months now with no probs till now.I went to that site a few days ago and downloaded version 3.8.2.0,unzipped & tried to move only the FSUIPC.dll to my modules folder.I get this message, "CANNOT MOVE,ACCESS DENIED. MAKE SURE DISC IS NOT FULL OR WRITE-PROTECTED AND THAT THE FILE IS NOT IN USE." I can move,delete,re-name all the other .dll's in my modules folder, but I can't do anything with these two; FDSConnection.dll & FSUIPC.dll. I tried to delete them out of the folder and then add the new FSUIPC,I get the same message as above.I get this message if i try to move,rename or delete.

Share this post


Link to post
Share on other sites

hello again,i think i mentioned before but will tell you again because i don't understand this crap.my FDSConnection.dll & FSUIPC.dll used to show the name of the .dll along with the version# and "microsoft flight simulator module". Now these two .dll's only show the name,and FS9 gives me a message on start-up that they wiil be disabled but i can continue to use FS9.thanks for all your help Jim, and I do have a big hammer as a last resort :-) MATT

Share this post


Link to post
Share on other sites

Hello,Just a other suggestion:Be sure those dll are not running...Make CTRL ALT DEL and check in the manager (tab process) if they are not running...If running .. right mouse clik on rhe DLL and stop the process.A other thing to try is maybe this:http://files.snapfiles.com/localdl834/delreb_setup-1.exe"Remove on Reboot Shell Extension is a simple but useful shell extension, that allows you to delete files automatically after the next reboot. This is useful if you need to deleted a file that is currently in use (locked) and cannot be deleted from within Windows. Just right-click and select "Delete on Reboot" and the file will be automatically deleted." Cheers.

Share this post


Link to post
Share on other sites

you da man Jim!!!the reboot worked.there were several files in my documents folder as well that would not delete (i would get the same message as with the .dll's in my modules folder),but now everything's in order.thanks again and happy flights! MATT

Share this post


Link to post
Share on other sites

sorted it out with the reboot. i've added your ctrl alt del to my useful notes. thanks Belga and cheers to you mate! MATT

Share this post


Link to post
Share on other sites