Archived

This topic is now archived and is closed to further replies.

Guest troyboy66

Asx Or Asa Installed On Both Server And Client

Recommended Posts

Hi,I was just wondering, I decided to try ASX on a client PC. I already had ASX, Xgraphics installed on server and decided to install it also on my client. I was able to connect and configure everything just fine however, from my client PC, the weather was not updating FSX. When I tried to use ASX from my server PC leaving all the required settings for WideFS and simconnect still configured on the client, it did not work anymore. So I removed all the settings from my client PC, unshared all the neccesary folders from server and deleted the required ports. It was then that ASX started working again from the server.Question: If I want to have ASX work from client, do I absolutely need to have it uninstalled from server?Secondly:With ASX installed on Server and installed and configured from client, will it no longer work from Server as indicated above?Thanks in advanceTroy

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Troy,Kind of confusing, but I'll give it a try!First, we don't use WideFS at all so you don't need to look at that.No, you can leave ASX on the server.The installs and settings are independent so it should work.Thanks,

Share this post


Link to post
Share on other sites
Hi Troy,Kind of confusing, but I'll give it a try!First, we don't use WideFS at all so you don't need to look at that.No, you can leave ASX on the server.The installs and settings are independent so it should work.Thanks,
Hi jim,Thanks for your quick answer. I mentioned WideFS only because its the one tool you can use to very there is a connection from Client to Server to FS.I've read thru your Network config. for Client configuration and thought that I had everthing configured properly. There were two suggetions of how to configure ASX (Client) to the shared folders on FS:Folders to shareC:\Program Files\Microsoft Games\Flight Simulator X (or your FSX installation folder)C:\Documents and Settings\[username]\Application Data\Microsoft\FSX (or if on Vista, C:\Users\[username]\AppData\Roaming\Microsoft\FSX)C:\Documents and Settings\[username]\My Documents\Flight Simulator X Files (or if on Vista, C:\Users\[username]\Documents\Flight Simulator X Files)1. On my client PC, I pointed to the locations on the three share folders as suggested...The paths were found successfully but when weather udates failed, I checked the registry entries listed below:The example below showed completely different paths compared to when I pointed to the folders. Is this ok? With the different configurations, WiedFS still showed a connection to server and FS...I think. Still no weather updates.HKEY_CURRENT_USER\Software\HiFi\XEngine\LastPlanPath: Set this to your desired flight plan folder, which should be shared on the FSX computer as \\fsxcomputername\Flight Simulator X Files HKEY_CURRENT_USER\Software\HiFi\XEngine\FSPath: Set this to your desired Flight Simulator X installation path, which should be shared on the FSX computer as \\fsxcomputername\Flight Simulator X HKEY_CURRENT_USER\Software\HiFi\XEngine\AppDataPath: Set this to your desired FSX AppData Path, which should be shared on the FSX computer as \\fsxcomputername\FSX I am running FSX SP2, SDK SP2 on Vista ultimate SP1, ASX Client on Winxp Pro Sp2....both PC's ca n communicate and share files.I'm not sure what the problem is. All the suggestions noted in the documentation is configured properly with Simconnect...Any suggestions?troy

Share this post


Link to post
Share on other sites

???

Hi jim,Thanks for your quick answer. I mentioned WideFS only because its the one tool you can use to very there is a connection from Client to Server to FS.I've read thru your Network config. for Client configuration and thought that I had everthing configured properly. There were two suggetions of how to configure ASX (Client) to the shared folders on FS:Folders to shareC:\Program Files\Microsoft Games\Flight Simulator X (or your FSX installation folder)C:\Documents and Settings\[username]\Application Data\Microsoft\FSX (or if on Vista, C:\Users\[username]\AppData\Roaming\Microsoft\FSX)C:\Documents and Settings\[username]\My Documents\Flight Simulator X Files (or if on Vista, C:\Users\[username]\Documents\Flight Simulator X Files)1. On my client PC, I pointed to the locations on the three share folders as suggested...The paths were found successfully but when weather udates failed, I checked the registry entries listed below:The example below showed completely different paths compared to when I pointed to the folders. Is this ok? With the different configurations, WiedFS still showed a connection to server and FS...I think. Still no weather updates.HKEY_CURRENT_USER\Software\HiFi\XEngine\LastPlanPath: Set this to your desired flight plan folder, which should be shared on the FSX computer as \\fsxcomputername\Flight Simulator X Files HKEY_CURRENT_USER\Software\HiFi\XEngine\FSPath: Set this to your desired Flight Simulator X installation path, which should be shared on the FSX computer as \\fsxcomputername\Flight Simulator X HKEY_CURRENT_USER\Software\HiFi\XEngine\AppDataPath: Set this to your desired FSX AppData Path, which should be shared on the FSX computer as \\fsxcomputername\FSX I am running FSX SP2, SDK SP2 on Vista ultimate SP1, ASX Client on Winxp Pro Sp2....both PC's ca n communicate and share files.I'm not sure what the problem is. All the suggestions noted in the documentation is configured properly with Simconnect...Any suggestions?troy

Share this post


Link to post
Share on other sites

Sorry, I had to eat lunch!If you run the AI traffic utility from the client does it run and recognize some AI traffic in FSX?Any error messages on the ASX main screen?Thanks,

Share this post


Link to post
Share on other sites
Sorry, I had to eat lunch!If you run the AI traffic utility from the client does it run and recognize some AI traffic in FSX?Any error messages on the ASX main screen?Thanks,
Jim, yes I did and AI traffic is recognized. However, I saw an earlier case I beleive was posted today. Someone was having the same exact issue and was using SDK SP2, same as me. He decided to use Simconnect from SDK SP1 and it worked just fine. Do you think the problem is with Simconnect SDK SP2?Troy

Share this post


Link to post
Share on other sites

Hi Troy,I went round this bend before...I wanted to have 2 networked computers simultaneously getting weather from ASX.http://forums1.avsim.net/index.php?showtopic=195416Short of it is that ASX has not been configured to be the client for one server. (IMHO The server client relationship is kind of backward in simconect The server is the computer running FSX and the client is the one running asx and serving weather data to the fsx server).So your server can get weather from the client but if you run fsx on the client (when it is setup to serve the server) it will not get any ASX weather. This is technically possible to do with simconnect but has not apparently been implemented for ASA.Damian did confirm that ASX client is not currently setup to handle multiple servers. He did say that they will consider it for the next version (I do not see any mention of this being added for ASX sp4 or ASA so that request slipped).

Share this post


Link to post
Share on other sites
Hi Troy,I went round this bend before...I wanted to have 2 networked computers simultaneously getting weather from ASX.http://forums1.avsim.net/index.php?showtopic=195416Short of it is that ASX has not been configured to be the client for one server. (IMHO The server client relationship is kind of backward in simconect The server is the computer running FSX and the client is the one running asx and serving weather data to the fsx server).So your server can get weather from the client but if you run fsx on the client (when it is setup to serve the server) it will not get any ASX weather. This is technically possible to do with simconnect but has not apparently been implemented for ASA.Damian did confirm that ASX client is not currently setup to handle multiple servers. He did say that they will consider it for the next version (I do not see any mention of this being added for ASX sp4 or ASA so that request slipped).
Sruddy, thanks for your response. Some suggestions by others seemed to be working just fine by using Simconnect from SDK SP1 rather than SP2. I haven't had an opportunity to try yet and will do so tonight after xmas shopping.Troy

Share this post


Link to post
Share on other sites