Archived

This topic is now archived and is closed to further replies.

Guest BadWhippet

ASA 394 - CPU usage maxed out suddenly

Recommended Posts

I'm really hoping someone can advise on anything I should be looking out for, any settings I've missed etc.I'd upgraded from ASX (which used to run beautifully) to ASA, which hammered my CPU cores to the point that it became unusable. A couple of nights back, I decided to try SP1 (build 394 beta). Amazing result! ASA ran on barely nothing, the weather effects were beautiful - all was resolved!However, it looks like that was a once-only. I attempted to run ASA three different times yesterday (even restarting my PC before the third attempt) but my CPU overload is back to being worse than ever. ASA averaged 73% of my CPU usage in Vista's 'Resource Monitor' and everything else (including FSX and Vista) was left to compete with the little that was left. It MUST be something on my PC otherwise I surely wouldn't have enjoyed the once-time perfect run. The problem doesn't impact on RAM (I have plenty of that left), just the CPUs - and it means I once again cannot use ASA unless I want to suffer 7-10fps framerates. Can anyone think of any underlying causes? Below, I've set out what I'm running (no changes in this set-up from when ASA ran well)...FSX config:FSX with Acceleration (SP1/SP2) running in DX9 (not the 'DX10 preview' setting)Screen res: 1680 x 1050 x 32SW Lights ReduxFS PassengersVFR GenX LondonASA (SP1 beta) - I use ASA to start FSXSaitek yoke and throttle quadrantMy PC specs are:E8500 Core 2 Duo (3.13MHz)4GB DDR2 RAMnVidia GTX260 OC (800Mb RAM)1000w PSUVista Ultimate 64-bitThe only two changes I made since the good run were (a) changing my local weather station to EGUW Wattisham Airfield (unfortunately, I can't remember what was set before this - it was somewhere I'd chosen with major storms), and (b) enhancing some settings in nVidia's control panel for FSX (which I've since reset back to their defaults, but it's made no difference). Thanks to anyone who can offer any help.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Just so you know that I have seen your post, I don't have any ideas. This has not been reported here, but if anyone else has ideas, please post.Thanks,

Share this post


Link to post
Share on other sites

Thanks Jim for the reply.I'm noticing that ASA is not maxing out when FSX is NOT running. I'm wondering whether, if FSX is configured badly (and my framerates are being disappointing despite trying settings recommended in other threads and having an okay PC (E8500, 4GB RAM, nVidia GTX260...). Maybe it is FSX that is making ASA work too hard? I dunno - wish I could find a solution. I might try a clean build of Vista and FSX at the weekend to see if this improves matters. :)

Share this post


Link to post
Share on other sites

Hi,You could try setting ASA to run on core 2 and see if that makes a difference.Thanks,

Share this post


Link to post
Share on other sites

It's cured! :( :( Unfortunately, I don't know which change I made resulted in the cure, but it's now running fantastically! I've basically reinstalled everything from scratch on a clean build of Vista, and (in case it's of any help to anyone else in the future) the only changes I've made this time include:

  • Installing SP1 on FSX before installing Acceleration (instead of FSX and Acceleration only)
  • Making some changes to FSX.cfg along the lines of those discussed in this thread: http://forums1.avsim.net/index.php?showtopic=246875 (I reduced the bufferpool to 300 but increased the Texture-Bandwidth_Mult to 80, otherwise I used the same settings as in this thread)
  • Installing ASA (and SP1 beta) cleanly on FSX (previously, ASX had been installed, then uninstalled before I'd added ASA).
  • I haven't installed XGraphics (not deliberate - I just haven't got round to it yet)
  • I haven't installed any add-on VFR scenery or airfield packs - I'm just using Microsoft default terrain at the moment

Any of those changes could have cured the problem. With ASA and FS Passengers running together, and with all scenery sliders on max, all else set to 'Ultra High', cloud redraw at 80 miles, and with anti-aliasing and anisotropic filtering set to decent levels in nVidia's FSX profile, these are the framerates I'm now getting:

  • at 3000ft over densely populated London are 23 - 27fps
  • at 3000ft over average scenery they're 30fps (the limit I have set for FSX)
  • at 10000ft over any terrain, they're 27-30fps
  • on the ground at busy airports, they're 16-20fps
  • in ASA heavy cloud weather with turbulence and rain, they're 20-23fps

Those are all roughly double the rates I was seeing before I reinstalled. At airports, I was only getting 6-8fps, Windows kept switching to a black screen when hovering my mouse over ASA in the status bar and my CPUs were being hammered whenever ASA connected to FSX. ASA is not now making any serious resource pull, and it's all running wonderfully!

Share this post


Link to post
Share on other sites