Sign in to follow this  
Guest

FS2004 - First Impressions

Recommended Posts

I was able to get a copy of FS2004 this afternoon at, where else, Office Depot, in the Kansas City area. When I first called to see if they had it, I was told, "Yes, it's been out for a couple of days." Geez, so what was I waiting for...The install went smoothly. I've had it running for perhaps 5 hours or so, with no stability issues noted.Am I impressed? You bet. The clouds are great, the rain and lightning are excellent. I may be easily amused, but I find this sim to be visually stunning. I've flown in the Seattle area, Honolulu, Chicago, So. Cal., and Kansas City.For the most part, the sim runs very smooth. I have a pretty fast machine, but it can still be noticably slowed with lots of goodies cranked up, say, at SeaTac when taxing in a turn. Not a slide show mind you, but not exactly 'smooth'. Please don't blow this observation out of proportion. I doubt I have all the settings optimized at this point.Landing the 737 at Honolulu in a thunderstorm was spectacular. They seem to have modeled cloud-to-cloud and cloud-to-ground lightning well. The view through heavy precip is pretty convincing. If you don't have it yet, you're in for a treat!I've spent a bit of time tweaking without reaching any real firm conclusions. For what it's worth:1600*1200*32Most settings are 1/2 to 3/4 to the right.Cloud Coverage Density = High3D Clouds are at 100 %P4-2.8/8001 Gb RamATI 9800 ProAsus P4P800 MBNoel_W

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you having any Radeon troubles like those below? I'm having terrible flickering when I hit "alt" and during the loading process. They also appear, though less violent, when I switch views in the 2D panels. I have a 9700 Pro. Colin

Share this post


Link to post
Share on other sites

Hi Colin,Yes, I think I'm seeing what you're describing, and what I've seen mentioned in other posts. If I use 'Alt' to go to the menu for something, and of course we have to do that a lot to get the joystick, etc. setup with a new sim - the menu will flash on and off a few time. While not ideal, it's not too bothersome for me, because the sim is stopped already anyway, so it doesn't exactly spoil the 'mood' - heck, I'm in pause. I have seen this when first loading the GPS window - but after the first time (for a particular flight and aircraft), it stops, and works normally.My ATI drivers are dated 6-23-2003 - I have not searched for newer ones yet.Noel_W

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this