Sign in to follow this  
Guest Anthony_D

Strange FPS hit with Ai Traffic

Recommended Posts

Hi Everyone,I've been doing some experimentation at EGLL (London Heathrow) under clear skies.If I set AI traffic to 0%, I get 19-20fps (locked at 20fps) wherever I look, at Heathrow, slew around London City centre, anywhere - I get the target performance.Now all my scenery and hardware settings are set to full (except mip-mapping which is set to 5).So, back at EGLL, I set AI traffic to 100%. On runway 27L I get 11-13fps and slewing around heathrow airport it remains around that figure. No suprises there, just like fs2002.Now then, I slew around London City centre and I still get sluggish fps even when looking away from Heathrow and any other sources of high AI traffic density. I never observed this effect in fs2002 so what's changed? It seems like AI traffic continues to eat fps even when it's not in view, but it seems to be linked to custom drawn buildings. If I go out to the countryside, the fps rises back to 20.Can anyone else verify this and if possible, are there any remedies?CheersAnthony Dyer

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

One thing I tried last night and I was surprised at the results. I installed MyTraffic 2004. I have been running 100 traffic on FS2004. Well with MyTraffic the FR hit was more than I wanted. I dropped down to 50% and started working my way back up. Surprisingly, the "breakpoint" for me was 96%. Up to that point, the FR was fine. When I went to 97%, the FR took a dump bigtime. I'm running a 3.0P4 800mhz FSB, 1 Gig Ram and ATI98011 pro.George Stoddard

Share this post


Link to post
Share on other sites

Interesting,I just did some more testing, one thing I forgot to mention in my last experiment was that I had the fs2002 - traffic.bgl file in fs2004. That file had lots of Project AI flightplans. I've since removed that and my previous observation in the first post no longer apply - I can get 20fps in London city centre or indeed anywhere where I don't see any AI traffic.I couldn't reproduce your observation George. However I would raise the conjecture that a lot of "My Traffic" flightplans have the 97% threshold put into the flightplans.txt file. My fps progressively got lower from 20 to 15fps when the threshold is risen from 80% to 100%. However with my imported fs2002 traffic.bgl file thrown in, hit ran at around 10-12fps even with the percentage slider at 10% and I suspect that's simply because many lines in my flightplan file have a low threshold value.I'll do some more testing over the next few days.Anthony DyerAthlon XP 2100+MSI Ti-4200 64MB512MB RamMSI KT-3 Ultra motherboard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this