Sign in to follow this  
Guest

Problem with Brakes

Recommended Posts

Hello,I'm using FS2004 and have everything set up so it is working reasonably well. However, I'm having a problem with brakes. I'm using the CH Pro Flight Yoke and Pro pedals USB. After flying and landing, the brakes stay on and can't be released by the pedals or pressing ".". There is a message in the lower left corner of the screen that says "Brakes" or "Differential Brakes". Moving the brakes on the pedals does not release them nor do any of the release brake commands release them. In other words, I'm stuck on the runway and can't take off or taxi to the gate because the breaks are stuck on.My system specs:Asus MB with Via Chipset(Latest Hyperion Drivers installed)AMD 2000 XP ProcessorNvidia Geforce 4 TI4200 (64 Meg) with 45.23 Drivers30 GBYte maxtor DriveAny help would be appreciated!Pat Livingston, St. Louis, MO

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Pat,There are a few folks here who have experienced the same problems. Do a search in this forum using "Brakes CH Pro Pedals". There are solutions, so hopefully you'll get the problem sorted soon.Good luck,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this